FORUMS
Remove All Ads from XDA

Camera Waterdamaged?

2,144 posts
Thanks Meter: 680
 
By Haldi4803, Senior Member on 5th January 2014, 02:34 PM
Post Reply Subscribe to Thread Email Thread
Hi guys.

Today i wanted to take a picture of something and realized the preview looks strange. At first i tought it was just to dark and enabled flash.
But after trying to take a scenery picture i realized that something definitly was off.



Thats when i made the obvious and took a look at the back of the phone to see if the camera was dirty.

Well, i sure was surprised!

(that metal ring is just for the smal magnetic objectives.)


What do you think ? is that a Water dmg? Did anything like this happen to anyone before ?


P.S yes i know... there are a lot of black dots... -.- should RMA that thing...
Attached Thumbnails
Click image for larger version

Name:	IMG_6425.jpg
Views:	576
Size:	264.9 KB
ID:	2495760  
 
 
5th January 2014, 06:52 PM |#2  
Senior Member
Thanks Meter: 11
 
More
Ya i think it's water.. Have you tested it in water

Sent from my C6603 using Tapatalk
5th January 2014, 11:43 PM |#3  
Haldi4803's Avatar
OP Senior Member
Thanks Meter: 680
 
More
you mean taking an underwater picture? did few times before, but not when this happened, and not afterwards.
6th January 2014, 04:09 AM |#4  
Senior Member
Thanks Meter: 11
 
More
Then water must have leaked into it some how and because of the heat water is getting evaporated. Put it under dhal for a day or teo while al d chaging headset ports are open.

Sent from my C6603 using Tapatalk
6th January 2014, 10:06 PM |#5  
Haldi4803's Avatar
OP Senior Member
Thanks Meter: 680
 
More
It's gone !

it really were just waterdrops, and the evaporated over time. So it's back to normal now! phew....
7th January 2014, 12:20 PM |#6  
Vepo's Avatar
Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by Haldi4803

It's gone !

it really were just waterdrops, and the evaporated over time. So it's back to normal now! phew....

Picture shows that your back glass is clearly lifted. Just a heads up before you wet the phone again.
7th January 2014, 03:30 PM |#7  
danilo_scala's Avatar
Member
Thanks Meter: 2
 
More
My cousin had this problem and it is technical and opened to dry (clean)
27th September 2015, 06:00 AM |#8  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by Haldi4803

It's gone !

it really were just waterdrops, and the evaporated over time. So it's back to normal now! phew....

How long did it take to dissapear? Any way to speed up the process.
27th September 2015, 10:07 AM |#9  
Member
Thanks Meter: 6
 
More
Bro ,
First question where did you get that camera ring [metal one] from , and how did you stick it .
Coming to your question , Did u try an hair dryer ? Well, you can try to open it up and wipe it off and stick back in with glue.
27th September 2015, 12:27 PM |#10  
Haldi4803's Avatar
OP Senior Member
Thanks Meter: 680
 
More
That's glued.
For camera lens attachment, about 10$ on eBay.

Hair dried is a bad idea. To much heat is bad for battery. Better to let it stay in a bowl of dry rice.

If you do nothing it takes about 1-3 days to fully disappear.

Gesendet von meinem D6503 mit Tapatalk
The Following User Says Thank You to Haldi4803 For This Useful Post: [ View ] Gift Haldi4803 Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes