FORUMS

Galaxy S6 & Edge get €100 Price Cut—New Models Incoming

Samsung has dropped the price of both the Galaxy S6 and S6 Edge by … more

How To Port Fully Featured Sony Xperia Z4 Camera

Xperia Z4’s hardware may not impress, but its software is definitely … more

Experimental TWRP Available For Moto G 2015

XDA Senior Member squid2 has posted experimental builds of TWRP for the Moto G … more

Sunday Debate: How Can We Get a No-Compromise Phone?

Join us in a fun Sunday Debate on Compromises. Come with your opinions and … more

What causing black dots on Xperia Z camera?

154 posts
Thanks Meter: 11
 
Post Reply Subscribe to Thread Email Thread
28th June 2014, 09:36 AM |#11  
androidfreak70's Avatar
Senior Member
Flag here!
Thanks Meter: 642
 
Donate to Me
More
Quote:
Originally Posted by androidtweaker1

There is a hardware fault with the camera module most probably

Xperia Z camera look like not 13mp
5mp cameras is looks better

Xperia™ Z (C6602) with tapatalk
 
 
28th June 2014, 10:35 AM |#12  
Nauju's Avatar
OP Senior Member
Flag Coimbatore
Thanks Meter: 11
 
More
Guys only solution is take it to the Sony service centre right??

Sent from my C6603 using XDA Premium 4 mobile app
28th June 2014, 11:21 AM |#13  
Senior Member
Thanks Meter: 310
 
More
Can confirm I now have two black dots in photos taken. Never been in water.
I'm thinking it might be software as it never happened on 4.3?

Sent from my C6603 using XDA Free mobile app
28th June 2014, 01:33 PM |#14  
Junior Member
Thanks Meter: 3
 
More
OMG I thought I was the only one with this problem..
My phone never touched water, so I think these are burnt pixels in the camera..
I can't really think of something else.
28th June 2014, 01:55 PM |#15  
Dsteppa's Avatar
Senior Member
Thanks Meter: 440
 
More
Quote:
Originally Posted by xchasa

Can confirm I now have two black dots in photos taken. Never been in water.
I'm thinking it might be software as it never happened on 4.3?

Sent from my C6603 using XDA Free mobile app

Quote:
Originally Posted by UnbredHalflingers

OMG I thought I was the only one with this problem..
My phone never touched water, so I think these are burnt pixels in the camera..
I can't really think of something else.

Guys this is it:
Quote:
Originally Posted by neoxx3m

First of all, I worked in Sony repair center and I've seen this problem many times. In some cases problem was gone with cleaning but in most cases problem was in defective camera lens.

The Following User Says Thank You to Dsteppa For This Useful Post: [ View ]
29th June 2014, 12:23 PM |#16  
Senior Member
Flag Ljubljana
Thanks Meter: 48
 
Donate to Me
More
All you need to do guys is to send your phone to repair center. I had same problem, my camera lense had over 50 black dots (dead pixels). They changed me few things and now it works as new .
29th June 2014, 01:24 PM |#17  
Member
Flag Lisboa
Thanks Meter: 4
 
More
Quote:
Originally Posted by droidhd

All you need to do guys is to send your phone to repair center. I had same problem, my camera lense had over 50 black dots (dead pixels). They changed me few things and now it works as new .

X2

Had the same problem, sent it to sony services and they said they replaced the camera, if they did that or not, i don't know, but the black dots are gone.

PS - They took my rooted rom away They installed a stock unrooted one
29th June 2014, 07:43 PM |#18  
Senior Member
Thanks Meter: 239
 
More
Just bad build quality.. I had mine replaced also..

Sent from my C6903 using XDA Premium 4 mobile app
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes