Chainfire Turns Your Bootanimation into a Logging Center

Having a nice boot animation certainly adds a little bit of aesthetic polish to your … more

Android TV Launcher Pushed to Google Play

Over the past decade, the tech universe has seen two drastic and widely contrasting changes with … more

Cyngn, OnePlus, Micromax – The Legal Battle

Recently, a battle has been waging in India over the rights to distribute the commercial … more

Lean Mean Battery Power Saving App Review

We talk a lot about battery topics here at XDA TV. We talk about everything from Power Banks to USB … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

What causing black dots on Xperia Z camera?

OP Nauju

28th June 2014, 10:36 AM   |  #11  
androidfreak70's Avatar
Senior Member
Flag here!
Thanks Meter: 636
 
3,799 posts
Join Date:Joined: Feb 2014
Donate to Me
More
Quote:
Originally Posted by androidtweaker1

There is a hardware fault with the camera module most probably

Xperia Z camera look like not 13mp
5mp cameras is looks better

Xperia™ Z (C6602) with tapatalk
28th June 2014, 11:35 AM   |  #12  
Nauju's Avatar
OP Senior Member
Flag Coimbatore
Thanks Meter: 8
 
123 posts
Join Date:Joined: Sep 2011
Guys only solution is take it to the Sony service centre right??

Sent from my C6603 using XDA Premium 4 mobile app
28th June 2014, 12:21 PM   |  #13  
Senior Member
Thanks Meter: 309
 
1,163 posts
Join Date:Joined: Dec 2010
Can confirm I now have two black dots in photos taken. Never been in water.
I'm thinking it might be software as it never happened on 4.3?

Sent from my C6603 using XDA Free mobile app
28th June 2014, 02:33 PM   |  #14  
Junior Member
Thanks Meter: 3
 
14 posts
Join Date:Joined: Dec 2013
OMG I thought I was the only one with this problem..
My phone never touched water, so I think these are burnt pixels in the camera..
I can't really think of something else.
28th June 2014, 02:55 PM   |  #15  
Dsteppa's Avatar
Senior Member
Thanks Meter: 386
 
1,630 posts
Join Date:Joined: May 2012
More
Quote:
Originally Posted by xchasa

Can confirm I now have two black dots in photos taken. Never been in water.
I'm thinking it might be software as it never happened on 4.3?

Sent from my C6603 using XDA Free mobile app

Quote:
Originally Posted by UnbredHalflingers

OMG I thought I was the only one with this problem..
My phone never touched water, so I think these are burnt pixels in the camera..
I can't really think of something else.

Guys this is it:
Quote:
Originally Posted by neoxx3m

First of all, I worked in Sony repair center and I've seen this problem many times. In some cases problem was gone with cleaning but in most cases problem was in defective camera lens.

The Following User Says Thank You to Dsteppa For This Useful Post: [ View ]
29th June 2014, 01:23 PM   |  #16  
Senior Member
Flag Ljubljana
Thanks Meter: 45
 
231 posts
Join Date:Joined: Jan 2011
Donate to Me
More
All you need to do guys is to send your phone to repair center. I had same problem, my camera lense had over 50 black dots (dead pixels). They changed me few things and now it works as new .
29th June 2014, 02:24 PM   |  #17  
Member
Flag Lisboa
Thanks Meter: 2
 
37 posts
Join Date:Joined: Apr 2011
More
Quote:
Originally Posted by droidhd

All you need to do guys is to send your phone to repair center. I had same problem, my camera lense had over 50 black dots (dead pixels). They changed me few things and now it works as new .

X2

Had the same problem, sent it to sony services and they said they replaced the camera, if they did that or not, i don't know, but the black dots are gone.

PS - They took my rooted rom away They installed a stock unrooted one
29th June 2014, 08:43 PM   |  #18  
Senior Member
Thanks Meter: 233
 
1,222 posts
Join Date:Joined: Feb 2012
Just bad build quality.. I had mine replaced also..

Sent from my C6903 using XDA Premium 4 mobile app

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes