Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,739,482 Members 53,843 Now Online
XDA Developers Android and Mobile Development Forum

Dead Xperia Z

Tip us?
 
murtaza02
Old
#1  
Senior Member - OP
Thanks Meter 18
Posts: 144
Join Date: Jan 2013
Location: Rawalpindi
Default Dead Xperia Z

So I'm making this quick, my dad's on vacation and he has a C6602 as well. He's in London, he called and said that his phone was 9% battery level so he turned it off. He then later called me from his other phone and said the Z isn't charging. He doesn't have the Z's original charger with him, for the past week he had been charging it with his Moto G charger and Nexus 7 charger. When he tried putting it on charge, he said the phone wasn't doing anything. The LED isn't lighting up and the phone isn't responding to anything. Any ideas on what to do? Its been used with care and was bought in Jan 2014. The phone has been left on charge for 7 hours straight and still no reaction!
What's wrong with it and is there a quick solution?

Thanks

Just letting you know, the phone was on 4.3 Jellybean (the build that ends with .101).



Sent from my C6602
Retired Devices: Samsung Galaxy Y GT-S5360 (broke it/died/still have it), Samsung Galaxy Ace GT-S5830 (best phone ever, sold due to low RAM), Sony Xperia U ST25i (sold), Samsung Galaxy S II GT-I9100 (sold), Samsung Galaxy S III SHV-E210L (sold, it was a piece of crap), Samsung Galaxy S III GT-I9300 (sold)

Current Device: Sony Xperia Z C6602 (16GB Internal & 16GB External) - Black (Android 4.3 Stock 10.4.1.B.0.101)
 
androidfreak70
Old
#2  
androidfreak70's Avatar
Senior Member
Thanks Meter 256
Posts: 1,188
Join Date: Feb 2014
Location: in mars underground

 
DONATE TO ME
Quote:
Originally Posted by murtaza02 View Post
So I'm making this quick, my dad's on vacation and he has a C6602 as well. He's in London, he called and said that his phone was 9% battery level so he turned it off. He then later called me from his other phone and said the Z isn't charging. He doesn't have the Z's original charger with him, for the past week he had been charging it with his Moto G charger and Nexus 7 charger. When he tried putting it on charge, he said the phone wasn't doing anything. The LED isn't lighting up and the phone isn't responding to anything. Any ideas on what to do? Its been used with care and was bought in Jan 2014. The phone has been left on charge for 7 hours straight and still no reaction!
What's wrong with it and is there a quick solution?

Thanks

Just letting you know, the phone was on 4.3 Jellybean (the build that ends with .101).



Sent from my C6602
if the phone no vibrate+no led+no screen on+charger connect nothing do+pc connect, the pc dont see the phone = HARD BRICKED ( throw it in the trash can)

and if no flashmode (hold vol down and plug into pc) and fastboot mode ( hold vol up and plug into pc) so BE SURE IT'S HARD BRICKED!!!!!

Send form my Xperia™ Z (C6602) using tapatalk😃
THATS FROM MY XPERIA™ Z
With:

Android 4.4.2
---------------------------------------------------
don't forget hit thanks if helped
-----------------------------------------------------
and ALWAYS QUOTE my posts if you replying to my post!
The Following User Says Thank You to androidfreak70 For This Useful Post: [ Click to Expand ]
 
wozzels
Old
#3  
wozzels's Avatar
Junior Member
Thanks Meter 1
Posts: 1
Join Date: Aug 2010
Hi Mate, I had a similar issue where my phone would not respond to anything, it only showed 3 red blinking lights when plugged into the charger, I left it for hours to charge but nothing, it would not even turn on while it was plugged into the charger, I read a few post and it seemed to be a battery issue. I tried one solution and it worked for me. Basically I had to wrap a rubber band around the phone so it holds the power button down and leave it on charge for a good few hours, it eventually came on again. now I know you said nothing happens when its plugged into the charger, but it won't hurt to give it a try and see if it helps, this may not be the solution to your problem but it might help. also try use the correct charger if possible. let me know if it worked.
The Following User Says Thank You to wozzels For This Useful Post: [ Click to Expand ]
 
murtaza02
Old
#4  
Senior Member - OP
Thanks Meter 18
Posts: 144
Join Date: Jan 2013
Location: Rawalpindi
Quote:
Originally Posted by androidfreak70 View Post
if the phone no vibrate+no led+no screen on+charger connect nothing do+pc connect, the pc dont see the phone = HARD BRICKED ( throw it in the trash can)

and if no flashmode (hold vol down and plug into pc) and fastboot mode ( hold vol up and plug into pc) so BE SURE IT'S HARD BRICKED!!!!!

Send form my Xperia™ Z (C6602) using tapatalk😃
but how does this happen? or is a Hard Brick just random? the phone wasn't rooted or anything.

Quote:
Originally Posted by wozzels View Post
Hi Mate, I had a similar issue where my phone would not respond to anything, it only showed 3 red blinking lights when plugged into the charger, I left it for hours to charge but nothing, it would not even turn on while it was plugged into the charger, I read a few post and it seemed to be a battery issue. I tried one solution and it worked for me. Basically I had to wrap a rubber band around the phone so it holds the power button down and leave it on charge for a good few hours, it eventually came on again. now I know you said nothing happens when its plugged into the charger, but it won't hurt to give it a try and see if it helps, this may not be the solution to your problem but it might help. also try use the correct charger if possible. let me know if it worked.
Thanks man. I'll try that.

I hope it works!

Sent from my C6602
Retired Devices: Samsung Galaxy Y GT-S5360 (broke it/died/still have it), Samsung Galaxy Ace GT-S5830 (best phone ever, sold due to low RAM), Sony Xperia U ST25i (sold), Samsung Galaxy S II GT-I9100 (sold), Samsung Galaxy S III SHV-E210L (sold, it was a piece of crap), Samsung Galaxy S III GT-I9300 (sold)

Current Device: Sony Xperia Z C6602 (16GB Internal & 16GB External) - Black (Android 4.3 Stock 10.4.1.B.0.101)
 
emiglet
Old
#5  
Junior Member
Thanks Meter 4
Posts: 21
Join Date: May 2014
Quote:
Originally Posted by murtaza02 View Post
So I'm making this quick, my dad's on vacation and he has a C6602 as well. He's in London, he called and said that his phone was 9% battery level so he turned it off. He then later called me from his other phone and said the Z isn't charging. He doesn't have the Z's original charger with him, for the past week he had been charging it with his Moto G charger and Nexus 7 charger. When he tried putting it on charge, he said the phone wasn't doing anything. The LED isn't lighting up and the phone isn't responding to anything. Any ideas on what to do? Its been used with care and was bought in Jan 2014. The phone has been left on charge for 7 hours straight and still no reaction!
What's wrong with it and is there a quick solution?

Thanks

Just letting you know, the phone was on 4.3 Jellybean (the build that ends with .101).



Sent from my C6602
Is it still on warranty? And do you have back-ups? I know it's an obvious answer, but a warranty claim is at its best.

Otherwise, bring it to a service. They can open the phone, connect a fresh battery and eventually swap it.

Otherwise, try plugging it in and out. Sometimes it works, sometimes not.

When I connect my Xperia Z with my battery unplugged, the phone doesn't do anything, unless I connect the battery. Obviously, I had to remove the back cover and I don't advise this. But it will give you insight.
 
murtaza02
Old
#6  
Senior Member - OP
Thanks Meter 18
Posts: 144
Join Date: Jan 2013
Location: Rawalpindi
Quote:
Originally Posted by emiglet View Post
Is it still on warranty? And do you have back-ups? I know it's an obvious answer, but a warranty claim is at its best.

Otherwise, bring it to a service. They can open the phone, connect a fresh battery and eventually swap it.

Otherwise, try plugging it in and out. Sometimes it works, sometimes not.

When I connect my Xperia Z with my battery unplugged, the phone doesn't do anything, unless I connect the battery. Obviously, I had to remove the back cover and I don't advise this. But it will give you insight.
Unfortunately in Pakistan, there is no Sony warranty.

Also, I might remove the back cover if I convince my dad to get a new phone and let me experiment with his old Z.
Retired Devices: Samsung Galaxy Y GT-S5360 (broke it/died/still have it), Samsung Galaxy Ace GT-S5830 (best phone ever, sold due to low RAM), Sony Xperia U ST25i (sold), Samsung Galaxy S II GT-I9100 (sold), Samsung Galaxy S III SHV-E210L (sold, it was a piece of crap), Samsung Galaxy S III GT-I9300 (sold)

Current Device: Sony Xperia Z C6602 (16GB Internal & 16GB External) - Black (Android 4.3 Stock 10.4.1.B.0.101)
 
androidtweaker1
Old
#7  
androidtweaker1's Avatar
Senior Member
Thanks Meter 168
Posts: 589
Join Date: May 2014
Quote:
Originally Posted by murtaza02 View Post
Unfortunately in Pakistan, there is no Sony warranty.

Also, I might remove the back cover if I convince my dad to get a new phone and let me experiment with his old Z.
Try using flashtool to flash to stock ftf.
Hit thanks if helped

Current Devices
Sony Xperia Z: Stock 4.4.2 rooted
Samsung Galaxy Nexus: Paranoid Android
 
murtaza02
Old
#8  
Senior Member - OP
Thanks Meter 18
Posts: 144
Join Date: Jan 2013
Location: Rawalpindi
Quote:
Originally Posted by emiglet View Post
Is it still on warranty? And do you have back-ups? I know it's an obvious answer, but a warranty claim is at its best.

Otherwise, bring it to a service. They can open the phone, connect a fresh battery and eventually swap it.

Otherwise, try plugging it in and out. Sometimes it works, sometimes not.

When I connect my Xperia Z with my battery unplugged, the phone doesn't do anything, unless I connect the battery. Obviously, I had to remove the back cover and I don't advise this. But it will give you insight.
So I removed the back cover, removed the plastic housing (that sits on top of the front camera cable and charging port) very violently disconnected the battery and connected the original charger and the red LED switched on. Now, while the charger was connected I re-connected the battery and the phone started charging. I switched the phone on and it was working fine. Now after the phone had charged to 50%, I copied my data to an SD Card. Then I (very stupid of me), very violently tried to re-fit that small piece of plastic housing back in and now the phone wont charge anymore and the plastic housing is slightly bent. check the picture to see how it looks. I then noticed the plastic housing had these little gold things inside it that make contact with the other little gold things on the motherboard. The phone is off right now but how do I fit that piece of crap plastic housing back in it's place? Any help will be appreciated.
Click image for larger version

Name:	uploadfromtaptalk1404563694531.jpg
Views:	56
Size:	140.4 KB
ID:	2833991

Sent from my Xperia Z C6602 using Tapatalk 4
Retired Devices: Samsung Galaxy Y GT-S5360 (broke it/died/still have it), Samsung Galaxy Ace GT-S5830 (best phone ever, sold due to low RAM), Sony Xperia U ST25i (sold), Samsung Galaxy S II GT-I9100 (sold), Samsung Galaxy S III SHV-E210L (sold, it was a piece of crap), Samsung Galaxy S III GT-I9300 (sold)

Current Device: Sony Xperia Z C6602 (16GB Internal & 16GB External) - Black (Android 4.3 Stock 10.4.1.B.0.101)
 
murtaza02
Old
#9  
Senior Member - OP
Thanks Meter 18
Posts: 144
Join Date: Jan 2013
Location: Rawalpindi
Okay, so I managed to fit the black piece of housing back in, BUT.
The phone only charges when its off.
If I switch it on, it doesn't charge and it doesn't show the Red/Orange LED either.

Sent from my Xperia Z C6602 using Tapatalk 4
Retired Devices: Samsung Galaxy Y GT-S5360 (broke it/died/still have it), Samsung Galaxy Ace GT-S5830 (best phone ever, sold due to low RAM), Sony Xperia U ST25i (sold), Samsung Galaxy S II GT-I9100 (sold), Samsung Galaxy S III SHV-E210L (sold, it was a piece of crap), Samsung Galaxy S III GT-I9300 (sold)

Current Device: Sony Xperia Z C6602 (16GB Internal & 16GB External) - Black (Android 4.3 Stock 10.4.1.B.0.101)
 
murtaza02
Old
#10  
Senior Member - OP
Thanks Meter 18
Posts: 144
Join Date: Jan 2013
Location: Rawalpindi
I broke the phone out of anger.
Thread can be closed now.
Thanks everyone.

Sent from my Xperia Z C6602 using Tapatalk 4
Retired Devices: Samsung Galaxy Y GT-S5360 (broke it/died/still have it), Samsung Galaxy Ace GT-S5830 (best phone ever, sold due to low RAM), Sony Xperia U ST25i (sold), Samsung Galaxy S II GT-I9100 (sold), Samsung Galaxy S III SHV-E210L (sold, it was a piece of crap), Samsung Galaxy S III GT-I9300 (sold)

Current Device: Sony Xperia Z C6602 (16GB Internal & 16GB External) - Black (Android 4.3 Stock 10.4.1.B.0.101)

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes