Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Earphone problem

OP lordriguez

23rd May 2014, 02:10 PM   |  #1  
lordriguez's Avatar
OP Senior Member
Thanks Meter: 4
 
101 posts
Join Date:Joined: Jun 2011
More
HI everyone!!!

I experience since some days à very annoying problem !!
Sometimes When à receive or make calls i don't hear any sound in earphone and Sometimes i have sound. It's appears randomly!!!
Can you help me to solve that??

Envoyé de mon C6603 en utilisant Tapatalk
23rd May 2014, 06:13 PM   |  #2  
Member
Thanks Meter: 5
 
32 posts
Join Date:Joined: May 2013
More
Quote:
Originally Posted by lordriguez

HI everyone!!!

I experience since some days à very annoying problem !!
Sometimes When à receive or make calls i don't hear any sound in earphone and Sometimes i have sound. It's appears randomly!!!
Can you help me to solve that??

Envoyé de mon C6603 en utilisant Tapatalk

Check if pressing around earpiece affects its function... If so, your connectors of internal speaker loose connection to the motherboard. Had the same problem, and opened the phone today, pulled the connectors out a bit and it works perfectly now.. But still trying to figure out how to put the back cover again.. So I suggest you try all the other options you may have before doing this..
The Following User Says Thank You to dakitz For This Useful Post: [ View ]
23rd May 2014, 08:14 PM   |  #3  
lordriguez's Avatar
OP Senior Member
Thanks Meter: 4
 
101 posts
Join Date:Joined: Jun 2011
More
Quote:
Originally Posted by dakitz

Check if pressing around earpiece affects its function... If so, your connectors of internal speaker loose connection to the motherboard. Had the same problem, and opened the phone today, pulled the connectors out a bit and it works perfectly now.. But still trying to figure out how to put the back cover again.. So I suggest you try all the other options you may have before doing this..

Yes pressing around it affects its function i can't desassembly so i think i will press it and deal with or send for repairs thanks for your reply
2nd June 2014, 05:46 PM   |  #4  
lordriguez's Avatar
OP Senior Member
Thanks Meter: 4
 
101 posts
Join Date:Joined: Jun 2011
More
Quote:
Originally Posted by dakitz

Check if pressing around earpiece affects its function... If so, your connectors of internal speaker loose connection to the motherboard. Had the same problem, and opened the phone today, pulled the connectors out a bit and it works perfectly now.. But still trying to figure out how to put the back cover again.. So I suggest you try all the other options you may have before doing this..

hiii ! Have you find a solution to put back the cover? Also do you have some advices for fixing it without open the phone because it's very annoying and there aren't Sony services in my country
Any advice is welcomed!!!!
2nd June 2014, 05:54 PM   |  #5  
Member
Thanks Meter: 5
 
32 posts
Join Date:Joined: May 2013
More
Quote:
Originally Posted by lordriguez

hiii ! Have you find a solution to put back the cover? Also do you have some advices for fixing it without open the phone because it's very annoying and there aren't Sony services in my country
Any advice is welcomed!!!!

Hi. Well if you have the same problem when pressing around earpiece then its hardware issue and you will have to open the phone...
I'm still waiting for my flex cable for power button, so I just heated the back cover and put it back. It holds, but it's not waterproof anymore... When I'm done fixing it, then I will seal it with some glue or similar. But I saw on ebay that they offer brand new adhesives for XZ, just like original... But personally, I don't trust those...
2nd June 2014, 07:23 PM   |  #6  
androidfreak70's Avatar
Senior Member
Flag here!
Thanks Meter: 636
 
3,799 posts
Join Date:Joined: Feb 2014
Donate to Me
More
I have the same problem... Its scares me is it normal? Or its half-damaged?
2nd June 2014, 07:50 PM   |  #7  
neoxx3m's Avatar
Recognized Contributor
Flag Ljubuski
Thanks Meter: 1,017
 
962 posts
Join Date:Joined: Dec 2009
Donate to Me
More
Adhesive from ebay holds very well, surley better than the one you take off and put it on again. Here is the link:
http://www.ebay.com/itm/New-Battery-...item1e8c0e667e

Sent from my C6603 using XDA Free mobile app

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes