FORUMS

XeroAsh Theme for CM12

This theme by XDA Senior Member balrajs99 features a black and slate gray UI that gives your phone a … more

Samsung Galaxy S6 To Receive Major Camera Update

When the Samsung Galaxy S6 and S6 Edge were launched, they became the prime focus for … more

Tactile: An Addicting Game with Beautiful Material Design

The game industry has been around for decades, catering to a wide … more

Android’s Consistency and The User Experience

This is a site of power users, and it is fair to say that most of us are more … more
Post Reply Subscribe to Thread Email Thread

[Q] Flashed Official 4.4.2 unbranded (C6616) onto C6606...Car Bluetooth issues....

14th June 2014, 02:21 AM |#1  
OP Member
Trampa
Thanks Meter: 54
 
More
As the title says, I bought a preowned C6606 and immediately flashed 4.4.2 ( I came from a Nexus4 Google Play Edition)

Got everything the way I wanted and went outside to connect and set up BT in my '13 subie stock system. Everything appeared to work fine.

Took a drive later on and BT didnt connect, turned BT on and then off again on the phone and it connected. Started Pandora and the volume was super low. I did check higher quality audio, turned up all the volumes on the phone, to no avail.

So, I accpeted this as a fluke. Parked, got out and later returned and BT wouldnt connect at all this time. Unpaired and reset up BT. Worked fine, left car, later came back and wouldnt pair again........(BTW none of the above gave me the loud volume my N4 produced, it just gave me mediocre levels)

After reading, I see others have had issues with 4.3....I was going to flash back to that, but if there is no fix...then.....

Please. Any and all ideas are greatly appreciated. I live on Pandora in the car, and cannot listen to FM radio for the life of me

Thank you.
 
 
14th June 2014, 07:36 AM |#2  
androidtweaker1's Avatar
Senior Member
Thanks Meter: 272
 
More
Quote:
Originally Posted by Jasonator

As the title says, I bought a preowned C6606 and immediately flashed 4.4.2 ( I came from a Nexus4 Google Play Edition)

Got everything the way I wanted and went outside to connect and set up BT in my '13 subie stock system. Everything appeared to work fine.

Took a drive later on and BT didnt connect, turned BT on and then off again on the phone and it connected. Started Pandora and the volume was super low. I did check higher quality audio, turned up all the volumes on the phone, to no avail.

So, I accpeted this as a fluke. Parked, got out and later returned and BT wouldnt connect at all this time. Unpaired and reset up BT. Worked fine, left car, later came back and wouldnt pair again........(BTW none of the above gave me the loud volume my N4 produced, it just gave me mediocre levels)

After reading, I see others have had issues with 4.3....I was going to flash back to that, but if there is no fix...then.....

Please. Any and all ideas are greatly appreciated. I live on Pandora in the car, and cannot listen to FM radio for the life of me

Thank you.

Just for clarity sake, did you flash C6616 rom on C6606?
14th June 2014, 11:55 AM |#3  
OP Member
Trampa
Thanks Meter: 54
 
More
Correct. I flashed stock android 4.4.2 for a C6616 onto my US. T-mobile C6606...... I am not Rooted, nor is the bootloader unlocked. I flashed it 2 times using flashtool....the first time I didn't wipe my data and it was very slow/laggy....after doing it the 2nd time......perfection. Everything else works beautifully. I had 30% battery still by the end of the day. WiFi has 0 issues. I have full LTE and got 50 some odd mbps on speed test. It's just the darned bluetooth in the car. It won't consistently connect and that's a big deal to me.

Thanks.
14th June 2014, 04:14 PM |#4  
androidtweaker1's Avatar
Senior Member
Thanks Meter: 272
 
More
Quote:
Originally Posted by Jasonator

Correct. I flashed stock android 4.4.2 for a C6616 onto my US. T-mobile C6606...... I am not Rooted, nor is the bootloader unlocked. I flashed it 2 times using flashtool....the first time I didn't wipe my data and it was very slow/laggy....after doing it the 2nd time......perfection. Everything else works beautifully. I had 30% battery still by the end of the day. WiFi has 0 issues. I have full LTE and got 50 some odd mbps on speed test. It's just the darned bluetooth in the car. It won't consistently connect and that's a big deal to me.

Thanks.

Try flashing your model specific firmware from here and see
14th June 2014, 06:09 PM |#5  
OP Member
Trampa
Thanks Meter: 54
 
More
That is exactly where I got it from....at the bottom of that article it reads

About the Torrents files:
Also, I would like to notify you that the download link to the torrent is not from me and is provided by Flashtool.net . I have seen the issue with C6606, when you download the file it says it is for C6616. I donít know if it is really for C6616 or C6606, but as to my knowledge there is not much of difference. I would like to ask you readers from T-mobile from US to make a ftf file for C6606 and upload it to some website and provide the link to me in Comment box. So that it will be useful for others users also. Is there anyone who could help me?



All of that said, what would really help, and I have searched, is a Google Play Edition Firmware for 4.4.2

I dont want to root or unlock the bootloader, so I am not looking for a custom ROM, but the official one that I can flash using Flashtool. If yu can point me int he right direction for that, then I would be a very happy person!
15th June 2014, 12:41 PM |#6  
mymeatb18's Avatar
Senior Member
Thanks Meter: 214
 
More
Quote:
Originally Posted by Jasonator

That is exactly where I got it from....at the bottom of that article it reads

About the Torrents files:
Also, I would like to notify you that the download link to the torrent is not from me and is provided by Flashtool.net . I have seen the issue with C6606, when you download the file it says it is for C6616. I donít know if it is really for C6616 or C6606, but as to my knowledge there is not much of difference. I would like to ask you readers from T-mobile from US to make a ftf file for C6606 and upload it to some website and provide the link to me in Comment box. So that it will be useful for others users also. Is there anyone who could help me?



All of that said, what would really help, and I have searched, is a Google Play Edition Firmware for 4.4.2

I dont want to root or unlock the bootloader, so I am not looking for a custom ROM, but the official one that I can flash using Flashtool. If yu can point me int he right direction for that, then I would be a very happy person!

the stock firmware for c6606 is still jellybean 4.2.2
15th June 2014, 01:39 PM |#7  
OP Member
Trampa
Thanks Meter: 54
 
More
I know this....
Quote:
Originally Posted by mymeatb18

the stock firmware for c6606 is still jellybean 4.2.2

I am not sure I am being clear..............

I have C6606 Tmobile U.S. Variant.

I flashed Stock ROM for 4.4.2 made for a C6616 Canadian Version. Using Flashtool......

EVERYTHING works perfectly....LTE WIFI Battery etc......

EXCEPT....My bluetooth wont connect automatically in my car.
15th June 2014, 02:46 PM |#8  
mymeatb18's Avatar
Senior Member
Thanks Meter: 214
 
More
Right I did the same thing to my wifes phone, c6606 on tmobile. We don't have Bluetooth in our cars so couldn't comment on that.
If something is not working properly its inevitable since you are modifying the phone. There is nothing that u can do but deal with it. It could also be a compatibility issue as well. Some Bluetooth devices are more compatible to certain devices than others.

Sent from my GT-P3110 using Tapatalk
17th June 2014, 03:03 PM |#9  
Tuckycv's Avatar
Senior Member
Leůn
Thanks Meter: 51
 
More
I went the other way around, I have a C661 and flashed a C6603, which I understand is just another variant. Everything works perfect for me. Here's the link for it; http://www.mediafire.com/download/an...d_4.4.2_XZ.zip

It is a pre-rooted if you are interested on that, and I do suffer from the google play services batter drain, I'm waiting on an update.
20th June 2014, 09:51 PM |#10  
Senior Member
Thanks Meter: 46
 
More
Quote:
Originally Posted by Jasonator

I am not sure I am being clear..............

I have C6606 Tmobile U.S. Variant.

I flashed Stock ROM for 4.4.2 made for a C6616 Canadian Version. Using Flashtool......

EVERYTHING works perfectly....LTE WIFI Battery etc......

EXCEPT....My bluetooth wont connect automatically in my car.

I had the same problem but I flashed a generic 4.4.2 C6603 from the UK. It was driving me crazy. Now I have issues where it will connect to my car but the audio won't trasnfer. It dosen't happen often. I didn't have the issue when I tried the generic 4.4.2 C6603 journalism software. Everything worked perfect then and my connections to the network for normal data and tethering are more responsive than the just released 4.3 T-Mobile software. Now that a root method has been found for KitKat I'll be going back to the jurnalism software. If you are willing to play with the software versions you might find one that works fine.

Maybe it has something to do with the audio software of the car and not the phone itself? Just a thought.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes