Build Custom Stock Kernel with Linaro GCC 4.9.1

With this guide for Sony devices, you will learn how to build a kernel using the Linaro … more

What’s Your Biggest Reason for Not Owning an iPhone?

With XDA being a community of Android enthusiasts, it is not uncommon to see … more

“New Kernel” for OnePlus One

If you are hungry for a new kernel on your OnePlus One, XDA Senior Member jgcaap‘s … more

GMD GestureControl Gets Lollipop Support

GMD GestureControl is an app that allows you to control your (rooted) devices with multitouch … more
Post Reply Subscribe to Thread Email Thread

[Q] Flashing stock rom - stuck at flashtool

20th August 2014, 10:07 PM |#1  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Dec 2012
Hi,

I'm awfully sorry to bother you, but I'm really stuck.

Been using my XZ for over a year now. Everything stock.

I then unlocked the bootloader, rooted it and flashed the latest stable release of CM (didn't use the flashtool for any of this)

CM was totally fine for me except for the camera app.

So I searched the board for a ROM that is better suited for my needs and found this:

http://forum.xda-developers.com/xper...-dark-t2779949

And this is where my problems began -->

Flash official Sony's 4.2.2 10.3.1.A.2.74 or 10.3.1.A.2.67 with flashtool (http://forum.xda-developers.com/show....php?t=2162907)

Even after hours and hours of tying, I cant get this working.

What I did so far:

Installed flash-tool; java development kit, android development kit, adb & fastboot drivers (via several different methods)

Windows (Win 7 64 Bit) recognizes my device as Sony Sa0107 when connected in normal mode.
And it recognizes it as S1 Device when connected in fastboot mode.

So, when I start the flashtool and get to the point where flashtool prompts me to connect my device in fastboot mode this happens:
it says that it didn't recognize my device and I have to search for the device in a list. I click on the XZ entry and flashtool then gets stuck. Just shows the screen where it says you to connect in fastboot.

I even tried to create cwm flashable zip to get around using the flashtool...but this didnt work out..

Has anyone any idea what I could have done wrong?
21st August 2014, 06:01 AM |#2  
Member
Flag Tre
Thanks Meter: 17
 
48 posts
Join Date:Joined: Aug 2014
More
Quote:
Originally Posted by J26M377

Hi,

I'm awfully sorry to bother you, but I'm really stuck.

Been using my XZ for over a year now. Everything stock.

I then unlocked the bootloader, rooted it and flashed the latest stable release of CM (didn't use the flashtool for any of this)

CM was totally fine for me except for the camera app.

So I searched the board for a ROM that is better suited for my needs and found this:

http://forum.xda-developers.com/xper...-dark-t2779949

And this is where my problems began -->

Flash official Sony's 4.2.2 10.3.1.A.2.74 or 10.3.1.A.2.67 with flashtool (http://forum.xda-developers.com/show....php?t=2162907)

Even after hours and hours of tying, I cant get this working.

What I did so far:

Installed flash-tool; java development kit, android development kit, adb & fastboot drivers (via several different methods)

Windows (Win 7 64 Bit) recognizes my device as Sony Sa0107 when connected in normal mode.
And it recognizes it as S1 Device when connected in fastboot mode.

So, when I start the flashtool and get to the point where flashtool prompts me to connect my device in fastboot mode this happens:
it says that it didn't recognize my device and I have to search for the device in a list. I click on the XZ entry and flashtool then gets stuck. Just shows the screen where it says you to connect in fastboot.

I even tried to create cwm flashable zip to get around using the flashtool...but this didnt work out..

Has anyone any idea what I could have done wrong?


Why are you trying to flash Flash official Sony's 4.2.2 10.3.1.A.2.74 or 10.3.1.A.2.67 with flashtool? If you are rooted and unlocked bootloader, you must have a custom recovery installed? I'm pretty sure that installing of an older official Sony firmware is mentioned at the installing instructions only to be able to root the XZ.

Try this:
1) Backup
2) Reboot to recovery
3) Wipe Data, Cache and Dalvik Cache
4) Flash the rom (existenz-ultimate)
The Following User Says Thank You to Kariharri For This Useful Post: [ View ]
21st August 2014, 08:19 AM |#3  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Dec 2012
Quote:
Originally Posted by Kariharri

Why are you trying to flash Flash official Sony's 4.2.2 10.3.1.A.2.74 or 10.3.1.A.2.67 with flashtool? If you are rooted and unlocked bootloader, you must have a custom recovery installed? I'm pretty sure that installing of an older official Sony firmware is mentioned at the installing instructions only to be able to root the XZ.

Try this:
1) Backup
2) Reboot to recovery
3) Wipe Data, Cache and Dalvik Cache
4) Flash the rom (existenz-ultimate)

Hi,

thank you for your reply.

Your version gets me stuck in a bootloop (cm logo).

I didn't need to install an older firmware, I was just using the Auto root files from doomlord (:Z_DooMLoRD_CF-Auto-Root-ported_FW-350.img & Z_DooMLoRD_insecure_FW-350.img)
21st August 2014, 09:14 AM |#4  
St.Jimmy90's Avatar
Senior Member
Flag Frankfurt
Thanks Meter: 145
 
618 posts
Join Date:Joined: Jul 2013
More
Did you wipe cache after flashing cm?
The Following User Says Thank You to St.Jimmy90 For This Useful Post: [ View ]
21st August 2014, 11:43 AM |#5  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Dec 2012
Thank you for your help.

I finally figured out what I did wrong.

I booted my phone in fastboot mode not flashmode (as it clearly stated by the flashtool ^^)
I guess I shouldn't have followed the guides so blindly.
21st August 2014, 11:53 AM |#6  
OP Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Dec 2012
Sorry for the double post, but I cant post in the existenz thread (not allowed to).

Is it possible to install a different theme for this rom (like this one: https://play.google.com/store/apps/d...bGV4LmJsdWUiXQ.. )

Didn't find an option in this rom
21st August 2014, 04:30 PM |#7  
Senior Member
Thanks Meter: 199
 
1,958 posts
Join Date:Joined: Nov 2009
More
no as that's a cm11 theme and you are now on a stock based rom, have a look in the thread for themes, that's if anyone has made them

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes