Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

FlashTool 0.9.16.0 + Linux, wrong java version

OP SamuelVimes

23rd May 2014, 02:09 PM   |  #1  
OP Junior Member
Flag Uttenreuth
Thanks Meter: 5
 
10 posts
Join Date:Joined: Feb 2014
More
Hi folks,

today I've stumbled across a tiny issue regarding the linux version of flashtool 0.9.16.0:
The script "FlashTool" is checking for java versions 1.6, 1.7 and whether it's 64bit or not.

The main problem is, that the zip is delivered with version 1.8 in the default directories, so every user using the built in mechanism schould fail with the following message:

Quote:

Java version must be 1.6 or 1.7

You won't get this error if you have java 1.6 or 1.7 on your system and have your environmental variables correctly to these instead of the built in ones but I think the creator of this tool had something in mind, putting 1.8 in the package. So the main question to me is: Is the script incomplete or is the wrong java version built in?

I'd posted this in the Cross Device Developement Thread for Xperia Devices but I unfortunateley don't have the permissions, so I hope Androxyde will read this post here in the Q&A.

Greetz,
Sammy

--- New information:
I had a look at the github-repository and I found out that in
master/ProgramExe/FlashTool
the script was completed with version 1.8 check. But the download from the FT-Homepage contains the old one without the check.
Last edited by SamuelVimes; 23rd May 2014 at 02:22 PM. Reason: New information
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes