Post Reply

Battery Full [SOLVED] Dead Xperia back to life!

OP emiglet

28th June 2014, 10:52 AM   |  #1  
OP Junior Member
Thanks Meter: 4
 
23 posts
Join Date:Joined: May 2014
Alright, so I was clumsy enough to drain my Xperia SEVERAL TIMES.

Honestly I blame the software or calibration, but also myself, since it didn't shut down when it should.

The following would happen, that my phone wouldn't charge. No red LED, nothing. Then when it showed, after countless tries and different power sources, it finally did. It worked like 3 times. Then it started shutting down at 30%, then once when I was using it at 50%. All of a sudden. Since then, it died. It didn't charge, even after I left it for 2 days on the charger. I tried every week, but nothing would happen. Eventually the phone would start vibrating when plugged into the charger, and just die after exactly 30 minutes, every time, giving pulses of vibration.

I opened up the phone, disconnected the battery, and pressed the connector of the vibration motor.

When the vibration is non-stop, even whent he phone is off, it's because of a faulty vibration motor itself, or its connector!! I only had to press it and it stopped.

I left the battery disconnected for 1 to 2 weeks, I don't remember. When I felt the CPU cover, it was kind of electrocuting me. I put a paper between the black strip that leads between the battery and the motherboard, to which somehow the electrocution stopped. I left it charging for 2 days, with the RED led full on all the time. I gave it little hope, but I still pressed the power button mutliple times through out the charging time. This morning, te RED led was Dark Red, very weak. I pressed PWR + VLM DOWN and it gave a little pulse.

It's alive again! I let it charge to 100%, made immediately a backup, and I'll see if it will keep working. I will have to send the phone back to Sony anyway, as I think that the vibration motor will start acting up again as soon as I pick up the phone from the table (it's that sensistive yes). Also, I cannot leave the paper there, and I just want a full functioning phone. Only need to get the silicone glue strip from a distributor that I know so I can properly close it off.

I didn't send it because I needed my data, basically.

I would say, if your phone doesn't react to anything and you're out of warranty, it's worth it to keep trying to charge it, or take the shortcut and buy a new battery, open the phone and connect the new battery. It's really that simple. Otherwise, it might be your motherboard that's dead.

I hope this could help some future troubles of XDA's. Maybe make a new sticky, as this question comes along quite often?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes