Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,809,862 Members 44,202 Now Online
XDA Developers Android and Mobile Development Forum

[HARDWARE FIX] Xperia Z not charging or booting

Tip us?
 
quickstyler
Old
(Last edited by quickstyler; 23rd May 2014 at 05:38 PM.)
#1  
quickstyler's Avatar
Junior Member - OP
Thanks Meter 12
Posts: 25
Join Date: Aug 2009
Default [HARDWARE FIX] Xperia Z not charging or booting

Problem: Xperia Z is not charging, not turning on, false battery stats or stuck in an non-software-caused bootloop... It's caused by a broken battery connector on the mainboard

Ok guys... I present you...

XPERIA Z BATTERY BUG ***HARDWARE FIX***

It's a cheap n' dirty fix! Use at your own risk - I don't care if your house burned down because of this...

STEP 1 - Remove the Backcover (see this youtube video how to do it - http://www.youtube.com/watch?v=jNrtamZuf7E)
STEP 2 - Remove the Battery (Be very carefull not to crack your display doing this...)
STEP 3 - Bend Battery Connector Pins



STEP 4
- Get a very thin cable (eg. from a USB Cable you cut down) and a soldering iron
STEP 5 - Solder the cable to the battery pinpoint >> TH << and on to the testing pinpoint on the mainboard according to my images


Should look like this...

STEP 6 - Assemble everything together again and connect the phone to the original Sony Charger
STEP 7 - Wait 2-3h for the handset to be charged
STEP 8 *additional* - Boot up device and install Sony Mobile Battery Test from here: http://forum.xda-developers.com/xper...rsion-t2527932 <--- (You can just take the .apk from the .rar file and install it)

STEP 9
SUCCESS! If your screen looks like this everything went fine:



Image of finished repair...I put some red plasti-dip around the fix-cable to isolate it

---
Notes:

Battery stats should be now OK - If not solder battery pinpoint EN to the PCB pinpoint behind (not under)

So what was the problem?

Sony's battery connector on the PCB is a cheap plastic sh*t... there are 6 connection points... 2 for +, 2 for -, 1 for temperature (TN - located middle top) and one EN ??? after some time the TN signal does not connect correctly causing this problem. you can't charge the battery and/or get false battery stats...if the battery is empty you can't boot anymore even with ac charger connected...

On my screenshot on top you see the battery temperature is 34° and green - OK - everything working fine

But without the fix you'lI get this:



Complete bull****...minus -30°...I'm not even close to Sibiria

So one step was to get rid of this fault... Since I got sometimes the right values (about + 30°C) when I was holding the connection between battery and pcb together with my fingers while device was on, I thought it is a problem with the connection.

The main problem on my two devices was that they didn't charge... When connected to AC -> bootloop ...

I got a fully charged battery and found this problem with the battery test app.. Fixing the battery connection to transmit correct temperature data made it possible to charge the battery fully again...battery stats are working and correct...I can now charge the devices as normal (in turned on or off state) ... i did buy new batterys but used the old ones for the fix and they work perfectly

TESTED ON TWO DEVICES WITH BOOTLOOP / NOT CHARGING and they are working FULLY again!!!!

Note if you open your device it may not be water resistant anymore...you can buy a new seal on ebay

If it worked for you please say thanks/like


thx 2 hunix for his software fix thread
The Following 3 Users Say Thank You to quickstyler For This Useful Post: [ Click to Expand ]
 
ABCdude
Old
#2  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: May 2014
Thanks for the thread, quickstyler, I had lost all hope before checking this and hunix's thread. I am yet to try the hardware fix as I wanted to first check if I have the same issue using the battery tester. I ran into some problem with the software fix, please check my post in the other thread and reply if you can help with anything.
 
emiglet
Old
#3  
Junior Member
Thanks Meter 4
Posts: 21
Join Date: May 2014
This guy explains the whole battery temperature thing.

http://www.youtube.com/watch?v=A6mKd5_-abk#t=451
 
cheychao
Old
#4  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Jul 2014
my xperia Z battery didn't charge and run dry then I'm change to new battery with have 60% connect pc andd repair.
But my battery still didn't charged i'm try Sony Mobile Battery Test and it say "Charge System Fail"
so i'm change to my old battery and follow your instuction but it doesn't seem work.
btw i'm try to google "xperia Charge System Fail" but not find any solution.
Attached Thumbnails
Click image for larger version

Name:	10533724_769780713043070_142926570_o.jpg
Views:	146
Size:	61.7 KB
ID:	2850642  
 
jai554
Old
#5  
jai554's Avatar
Senior Member
Thanks Meter 762
Posts: 907
Join Date: Jun 2012
Location: Kuching

 
DONATE TO ME
My problem is that my phone charges very slow and discharges very fast!
When i turn off the phone, it stays hot/warm
XPERIA Z
SpikeLabs Xperia Z - Performance Edition v3 | 10.5.A.0.230
XzKernel v25
1.5GHz X 4 Undervolted
BOOTLOADER UNLOCKED!

XPERIA X10
SPL Gaming 4.1.2
CMX10 Kernel
BOOTLOADER UNLOCKED!

 
androidfreak70
Old
(Last edited by androidfreak70; 17th July 2014 at 01:04 AM.)
#6  
androidfreak70's Avatar
Senior Member
Thanks Meter 424
Posts: 2,633
Join Date: Feb 2014
Location: here!

 
DONATE TO ME
####off topiC!

From where i get SONY MOBILE BATTERY TEST aPp?¿
THATS FROM MY XPERIA™ Z
RUNNING ROM
C6602
Android 4.4.4
Stock Omni kernel
Xposed modules

---------------------------------------------------
don't forget hit thanks if helped
-----------------------------------------------------
and ALWAYS QUOTE my posts if you replying to my post!
 
KyoForever
Old
#7  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: May 2009
Hi, great info!!

I have a Z1 with the same battery-not-charging issue, any hints about the testpoint on that model?
 
jai554
Old
#8  
jai554's Avatar
Senior Member
Thanks Meter 762
Posts: 907
Join Date: Jun 2012
Location: Kuching

 
DONATE TO ME
My phone only work when plugged in... Blackout when unplugged... Will this fix work?
XPERIA Z
SpikeLabs Xperia Z - Performance Edition v3 | 10.5.A.0.230
XzKernel v25
1.5GHz X 4 Undervolted
BOOTLOADER UNLOCKED!

XPERIA X10
SPL Gaming 4.1.2
CMX10 Kernel
BOOTLOADER UNLOCKED!


Tags
xperia z battery bug, xperia z battery dead, xperia z charging problem, xperia z false battery stats, xperia z not charging
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


ARChon Lets You Run Android Apps in Google Chrome Browser

Not too long ago, Google added the ability torun select Android applications on … more

Flyme OS Finds Its Way to the Google Nexus 5

Flyme OS is a heavily modified Android variantdeveloped by the Meizu team for their MX … more

MultiROM Makes Its Way to the LG G2

Over the last few weeks, we’ve seen quite a fewflagship (and former flagship) devicesget to … more