FORUMS

Index Project For XDA Device Subforums

Another ambitious project from the collaborative efforts of Recognized Contributors and Forum … more

The Atlas of XDA

A few weeks ago, we asked you “How Does Your Location Affect Your Life As A Power User?”. In the days that … more

New Snapdragons: Some Context & Contrast

It hasn’t been a good year for Qualcomm so far. Every device featuring the Snapdragon 810 … more

Google To Launch Next Gen Android One On July 14

The first gen of Android One devices to be launched in India in September 2014 were … more

[HARDWARE FIX] Xperia Z not charging or booting

32 posts
Thanks Meter: 16
 
By quickstyler, Member on 23rd May 2014, 04:19 PM
Post Reply Subscribe to Thread Email Thread
2nd February 2015, 09:43 PM |#41  
Member
Thanks Meter: 9
 
More
Quote:
Originally Posted by pampanz

tried without success (did it last night)
phone is 6603 and only lights led to green briefly or blue (fastboot or flashboot as per instructions), it also buzz when holding power + vol up. Flash works (apparently according to logs on flashtool) but then nothing happens only red light when charging. Note that after soldering the cable it behaves same as before.
The other think that doesn't seem to work is trying to flash the kernel, where I get operation not permitted.
I can't say I have the same problem but have tried so many things that thought another one won't hurt as I have two batteries (bought another one thinking it was the culprit).

Thanks for your answer pampanz.I did the hardware fix that quickstyler posted today.It solved the problem of false battery stats,however it was the only problem i had.I did not had trouble with charging(i mean i had partially but since i did tap the back at the point of the battery connector to get rid of the -30)or not booting.I guess you problem is more complicated pampanz.Good luck finding solution.Also i want to thank quickstyler of the fix and guide.
Last edited by xdagfg; 2nd February 2015 at 09:47 PM.
 
 
2nd February 2015, 11:57 PM |#42  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by xdagfg

Thanks for your answer pampanz.I did the hardware fix that quickstyler posted today.It solved the problem of false battery stats,however it was the only problem i had.I did not had trouble with charging(i mean i had partially but since i did tap the back at the point of the battery connector to get rid of the -30)or not booting.I guess you problem is more complicated pampanz.Good luck finding solution.Also i want to thank quickstyler of the fix and guide.

I thought it was worth a try. My phone was working fine but the screen had a crack and a section of it had the touchscreen broken. When I replaced it initially it worked but then while completing the installation broke it again ... yeah I know ,anyway once I got the second screen put it together and that was it. Now my reasoning was since all the notifications are correct (blue led, buzz, green led, flashing seems to complete correctly) that out of removing the battery a few times while repearing the screen may have affected one of the connectors. However so far no luck. My other explanation is that because the second screen took forever to arrive (well over a month) that the battery may have drained, but bought a replacement battery which behaves exactly the same as the original
Post Reply Subscribe to Thread

Tags
xperia z battery bug, xperia z battery dead, xperia z charging problem, xperia z false battery stats, xperia z not charging
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes