5,596,235 Members 35,349 Now Online
XDA Developers Android and Mobile Development Forum

Help! Water in my camera? :S

Tip us?
 
Chechare
Old
(Last edited by Chechare; 19th December 2013 at 08:25 PM.)
#1  
Chechare's Avatar
Junior Member - OP
Thanks Meter 2
Posts: 11
Join Date: Apr 2012
Exclamation Help! Water in my camera? :S

Hi guys, I think I have a serious problem with my Xperia Z...



The glass is a little unglued from the upper left conner, I didn't noticed it until today when I wash my XZ (It had many finger print) so the device began to works a little weird, It unlocks and unlocks by itself and the down volume key starts to fail also.

The acelerometer is not working now and I am scared about if the warranty covers it. I didn't submerge I just wash out to clean it. Also, when I open the camera app i can see that the camera is working yet, but suddenly after a second the phone restart by itself.

In the past three days I went to the beach and used over the water to take pictures, I didn't submerge because I was concious about the seawater can cause problems in the devices, but my phone fell in the sand and I decided to washed it with potable water, It also the lens of the camera got tarnished but It returns to normality after a little minutes so I think that only was the glass that got a little tarnished in cause of the changes of temperature.

I am afraid about if the warranty covers this kind of issues, I am from Mexico and a friend bougth it for me in USA, what Can I do?

Sorry for my english, thanks.
 
DrKrFfXx
Old
#2  
DrKrFfXx's Avatar
Senior Member
Thanks Meter 170
Posts: 544
Join Date: Mar 2011
Location: Madrid
It is condensation. Just let it be, it will be gone in a while.

What I did though, was to make the phone hot by playing games, it gets quite hot and it'll evaporate the water inside the lens.
The Following User Says Thank You to DrKrFfXx For This Useful Post: [ Click to Expand ]
 
Chechare
Old
#3  
Chechare's Avatar
Junior Member - OP
Thanks Meter 2
Posts: 11
Join Date: Apr 2012
Quote:
Originally Posted by DrKrFfXx View Post
It is condensation. Just let it be, it will be gone in a while.

What I did though, was to make the phone hot by playing games, it gets quite hot and it'll evaporate the water inside the lens.
But the acelorometer is not working yet
 
DrKrFfXx
Old
#4  
DrKrFfXx's Avatar
Senior Member
Thanks Meter 170
Posts: 544
Join Date: Mar 2011
Location: Madrid
Quote:
Originally Posted by Chechare View Post
But the acelorometer is not working yet
Well, then, leave it on rice for the night, turned off with all flaps open.
The Following User Says Thank You to DrKrFfXx For This Useful Post: [ Click to Expand ]
 
Chechare
Old
#5  
Chechare's Avatar
Junior Member - OP
Thanks Meter 2
Posts: 11
Join Date: Apr 2012
Quote:
Originally Posted by DrKrFfXx View Post
Well, then, leave it on rice for the night, turned off with all flaps open.
It could works, but I need to repair the unglued glass
 
Denhot
Old
#6  
Member
Thanks Meter 19
Posts: 45
Join Date: Jun 2013
Happened to me 2 days back
Same cleaning from water and then power button went buzurk along with water condensation on camera lens within 2 hours I was at the service centre..

Are any of your water indicators red instead of white??!

If not then send it under warranty without taking a breath..because as someone specified on an another thread the power button and volume problem will remain even later.



Sent from my MT15i using xda app-developers app
The Following User Says Thank You to Denhot For This Useful Post: [ Click to Expand ]
 
Chechare
Old
#7  
Chechare's Avatar
Junior Member - OP
Thanks Meter 2
Posts: 11
Join Date: Apr 2012
Quote:
Originally Posted by Denhot View Post
Happened to me 2 days back
Same cleaning from water and then power button went buzurk along with water condensation on camera lens within 2 hours I was at the service centre..

Are any of your water indicators red instead of white??!

If not then send it under warranty without taking a breath..because as someone specified on an another thread the power button and volume problem will remain even later.



Sent from my MT15i using xda app-developers app
Actually all my water indicator are in white, but until today the acelorometer and giroscoper are not working yet :/ That's mean I can't initialize the camera without the device reboot itself.

A problem is that here in my town there are no service centers. I don't know what to do :/
 
Denhot
Old
#8  
Member
Thanks Meter 19
Posts: 45
Join Date: Jun 2013
I think maybe you should go to a local mobile repair shop..I'm not sure if the device will be water proof after that.. But it will not be dead atleast

If even that's not viable.

Because the damage is continuing.
As someone said then you should try drying it..leave the flaps on keep it in rice..
Hope nothing big is damaged man.
Camera won't work if it doesn't get Reading from the gyro.. Hence it's rebooting..so the cam may still be fine.
Sent from my MT15i using xda app-developers app
The Following User Says Thank You to Denhot For This Useful Post: [ Click to Expand ]
 
Chechare
Old
#9  
Chechare's Avatar
Junior Member - OP
Thanks Meter 2
Posts: 11
Join Date: Apr 2012
Quote:
Originally Posted by Denhot View Post
I think maybe you should go to a local mobile repair shop..I'm not sure if the device will be water proof after that.. But it will not be dead atleast

If even that's not viable.

Because the damage is continuing.
As someone said then you should try drying it..leave the flaps on keep it in rice..
Hope nothing big is damaged man.
Camera won't work if it doesn't get Reading from the gyro.. Hence it's rebooting..so the cam may still be fine.
Sent from my MT15i using xda app-developers app
I prefer that Sony take hands on the business, the model is not available in Mexico so I'm not sure about some technician can fixed it correctly, I will try to contact to Sony USA and Mexico.

I will try to put it in a bag of rice hoping it works for the moment :/

Thanks.

Just I have the doubt about if the back glass will unglue after Sony fixed.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes