Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[HELP] Xperia Z brick?

OP chudy432

31st August 2014, 08:26 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Aug 2014
hi,

sorry for my bad English,

I bought Xperia With a damaged touch. The phone is normally turn on. the touch did not work. I decided to take himself for the replacement of touch (glued to the LCD). I disassembly phone . before removing the motherboard still plugged in the battery to see if the battery will not hurt the dismantling of the display, the phone is turned saw the Sony logo and disconnected the battery (do not know if it was a good idea). After removing all nicely warmed the screen and slowly removing pieces touch. Unfortunately, at the end it turned out that a little too much it warmed, because the screen began to appear discolored, so were pissed, I ordered a new display and in the meantime, as I wait for the touch I wanted to see if it works. I have connected to the display board, tape, buttons and battery. Turned on, the phone vibrated and enough black screen. So I stitched it to "poop" and I wanted to run, but it was all the same. Computer can not detect, etc.. After some time, as it was plugged into usb turn on the red light. Ive loaded software program SUS, and after you press the power button flashing red LED 3 times. I left the phone on the charger overnight from nokia (1200mA), but it does not improve, after that, that when you try to turn the vibration and again, so much. The phone is detected in fastboot mode (blue LED) and flash (theoretically green), because as I press the phone turned off and hold down my Vol- is a second red LED will flash immediately changes to green and then turns off the computer recognizes the phone as SOMC Flash Device (SEMC not SOMC) and in this mode for the update service is normally upload the software to the end, in the Flashtool the same situation. I do not know if it's important, but after every uploading the software when you try to turn this unfortunate flashes red LED 3 times as if the battery is discharged. Could this be a defective battery? Phone before you got in my hands was lying unused for some time. How it got it it plugged into the car charger (840mA) for around 40min +/- and normally work. I do not remember whether if it was on some LED.
1st September 2014, 04:18 AM   |  #2  
androidfreak70's Avatar
Senior Member
Flag here!
Thanks Meter: 636
 
3,799 posts
Join Date:Joined: Feb 2014
Donate to Me
More
Why could you buy a Xperia Z with damaged touch? And why you try to repair it yourself?

Tapatalk'ed from my Xperia™ Z (C6602) running Dirty Unicorns ROM!
The Following User Says Thank You to androidfreak70 For This Useful Post: [ View ]
1st September 2014, 11:08 AM   |  #3  
androidtweaker1's Avatar
Senior Member
Thanks Meter: 261
 
831 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by chudy432

hi,

sorry for my bad English,

I bought Xperia With a damaged touch. The phone is normally turn on. the touch did not work. I decided to take himself for the replacement of touch (glued to the LCD). I disassembly phone . before removing the motherboard still plugged in the battery to see if the battery will not hurt the dismantling of the display, the phone is turned saw the Sony logo and disconnected the battery (do not know if it was a good idea). After removing all nicely warmed the screen and slowly removing pieces touch. Unfortunately, at the end it turned out that a little too much it warmed, because the screen began to appear discolored, so were pissed, I ordered a new display and in the meantime, as I wait for the touch I wanted to see if it works. I have connected to the display board, tape, buttons and battery. Turned on, the phone vibrated and enough black screen. So I stitched it to "poop" and I wanted to run, but it was all the same. Computer can not detect, etc.. After some time, as it was plugged into usb turn on the red light. Ive loaded software program SUS, and after you press the power button flashing red LED 3 times. I left the phone on the charger overnight from nokia (1200mA), but it does not improve, after that, that when you try to turn the vibration and again, so much. The phone is detected in fastboot mode (blue LED) and flash (theoretically green), because as I press the phone turned off and hold down my Vol- is a second red LED will flash immediately changes to green and then turns off the computer recognizes the phone as SOMC Flash Device (SEMC not SOMC) and in this mode for the update service is normally upload the software to the end, in the Flashtool the same situation. I do not know if it's important, but after every uploading the software when you try to turn this unfortunate flashes red LED 3 times as if the battery is discharged. Could this be a defective battery? Phone before you got in my hands was lying unused for some time. How it got it it plugged into the car charger (840mA) for around 40min +/- and normally work. I do not remember whether if it was on some LED.

If battery was working properly before the experiment that you did there must be something wrong that you must have did.
Try a different battery and see whether it solves issue or else you must have damage the mo-bo
6th September 2014, 12:50 AM   |  #4  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Aug 2014
My Xperia dead after remove battery.
Stuck in flash mode.
Fastboot and flash mode works. (Blue and green led)
unbrick from flashtool?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes