Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,812,470 Members 40,576 Now Online
XDA Developers Android and Mobile Development Forum

HELP! Xperia Z screen goes blank after start up

Tip us?
 
asadkhanduhh
Old
#1  
Member - OP
Thanks Meter 4
Posts: 68
Join Date: Mar 2012
Default HELP! Xperia Z screen goes blank after start up

hello all,

i am experiencing a new problem with my xperia z.

the phone will start and display will work then within thirty seconds, the phone screen will slowly dim out to black.

after this the reboot process repeats and repeats.

i need help with a fix.

i can do hard reset and feel the three vibrates, and also sony and xperia screens still come up.

please help! thanks
 
monivan
Old
#2  
monivan's Avatar
Senior Member
Thanks Meter 316
Posts: 636
Join Date: Apr 2010
Location: Berlin

 
DONATE TO ME
Flash stock firmwares, it would fix the problem.

Sent from my C6903 using XDA Premium 4 mobile app
 
gregbradley
Old
#3  
gregbradley's Avatar
Forum Moderator
Thanks Meter 3,968
Posts: 9,319
Join Date: Mar 2011
Location: Manchester
PLease post questions in the Q&A section

Thread moved

How to get root on Xperia Z1 with KitKat 4.4.2, 4.4.3 & 4.4.4

If you are unsure, then read this.
If you are still unsure, watch this.
 

My contributions.
If I have seen further it is by standing on the shoulders of giants. Sir Isaac Newton

[X10] | [NEO] | [Xperia T/TX] |
[Xperia Z1]
You are free to share my work, but please provide the correct credits and a link to my original thread.


 
gege88
Old
#4  
Junior Member
Thanks Meter 2
Posts: 12
Join Date: Nov 2010
flash this:

httpforum.xda-developers.comxperia-zgeneralstock-rom-xperia-z-c6602-android-4-4-2-t2758893
 
androidfreak70
Old
#5  
androidfreak70's Avatar
Senior Member
Thanks Meter 430
Posts: 2,661
Join Date: Feb 2014
Location: here!

 
DONATE TO ME
Quote:
Originally Posted by gege88 View Post
flash this:

httpforum.xda-developers.comxperia-zgeneralstock-rom-xperia-z-c6602-android-4-4-2-t2758893
Please post the link again because it's incorrect

Tapatalked from my Xperia™Z with Dirty Unicorns ROM!
THATS FROM MY XPERIA™ Z
RUNNING ROM
C6602
Android 4.4.4
Stock Omni kernel
Xposed modules

---------------------------------------------------
don't forget hit thanks if helped
-----------------------------------------------------
and ALWAYS QUOTE my posts if you replying to my post!
 
gege88
Old
#6  
Junior Member
Thanks Meter 2
Posts: 12
Join Date: Nov 2010
Just delete the http from my link and it should work!
 
asadkhanduhh
Old
#7  
Member - OP
Thanks Meter 4
Posts: 68
Join Date: Mar 2012
hi,

ive flashed that rom, and still no luck. the phone keeps resetting itself!

any other remedies?

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes