Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,892 Members 43,018 Now Online
XDA Developers Android and Mobile Development Forum

[Q] L2TP VPN connection always fails

Tip us?
 
CoolRaoul
Old
(Last edited by CoolRaoul; 3rd September 2014 at 09:19 PM.) Reason: fix facts description
#1  
Member - OP
Thanks Meter 3
Posts: 30
Join Date: Aug 2012
Default [Q] L2TP VPN connection always fails

Hello,

I unable to connect to my home NAS VPN server using built-in L2TP/IPSec profile: It stays in "connecting" state for many seconds then switch back to "disconnected".

I thought it was an incompatibility between my NAS VPN stack and Android built-in client.

But yesterday I had the opportunity to make a test using a Samsung Galaxy S3 "Mini" (using same profile and settings) and it worked!

And today, I tried with two colleagues devices: a LG G3 and a Samsung Galaxy S4, both running same android version (4.4.2) as the Z, and using same mobile operator and mobile plan.

They are connecting fine too!

Would anyone have an explanation of what's happening here?
The Following User Says Thank You to CoolRaoul For This Useful Post: [ Click to Expand ]
 
CoolRaoul
Old
#2  
Member - OP
Thanks Meter 3
Posts: 30
Join Date: Aug 2012
Something which could be interesting:

A member of another forum has been able to connect succesfully with an Xperia Z1 which was still using 4.3 firmware.

Just after that he has updated his phone to latest availlable firmware (4.4.4) and has been unable to connect then.
 
CoolRaoul
Old
#3  
Member - OP
Thanks Meter 3
Posts: 30
Join Date: Aug 2012
My tests results so far:
test results matrix
 
CoolRaoul
Old
#4  
Member - OP
Thanks Meter 3
Posts: 30
Join Date: Aug 2012
No surprise: bug still present after latest updated.
Tags
ipsec, l2tp, vpn
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes