FORUMS

Which OEM Would You Like to Help?

Most manufacturers have moments of greatness and moments of decadence, and in the past few years … more

Root T-Mobile S6/Edge on 5.1.1 Without Tripping Knox

If you purchase phones from a carrier, you may be no stranger to the difficulties … more

IonVR Coming Soon, HTC M9 Dev Edition Gets Android 5.1 – XDA TV

The HTC M9 Developer Edition has received Android 5.1. That and … more

Android 5.1.1 Omni ROM For Motorola Xoom

Back in Feb 2011, the Motorola Xoom became the first device to be sold with Android 3.0 … more

[Q] L2TP VPN connection always fails

63 posts
Thanks Meter: 5
 
By CoolRaoul, Member on 2nd September 2014, 08:45 AM
Post Reply Subscribe to Thread Email Thread
Hello,

I unable to connect to my home NAS VPN server using built-in L2TP/IPSec profile: It stays in "connecting" state for many seconds then switch back to "disconnected".

I thought it was an incompatibility between my NAS VPN stack and Android built-in client.

But yesterday I had the opportunity to make a test using a Samsung Galaxy S3 "Mini" (using same profile and settings) and it worked!

And today, I tried with two colleagues devices: a LG G3 and a Samsung Galaxy S4, both running same android version (4.4.2) as the Z, and using same mobile operator and mobile plan.

They are connecting fine too!

Would anyone have an explanation of what's happening here?
Last edited by CoolRaoul; 3rd September 2014 at 09:19 PM. Reason: fix facts description
The Following User Says Thank You to CoolRaoul For This Useful Post: [ View ]
 
 
3rd September 2014, 09:20 PM |#2  
OP Member
Thanks Meter: 5
 
More
Something which could be interesting:

A member of another forum has been able to connect succesfully with an Xperia Z1 which was still using 4.3 firmware.

Just after that he has updated his phone to latest availlable firmware (4.4.4) and has been unable to connect then.
4th September 2014, 08:13 AM |#3  
OP Member
Thanks Meter: 5
 
More
My tests results so far:
test results matrix
The Following User Says Thank You to CoolRaoul For This Useful Post: [ View ]
14th September 2014, 05:42 PM |#4  
OP Member
Thanks Meter: 5
 
More
No surprise: bug still present after latest updated
Last edited by CoolRaoul; 23rd December 2014 at 12:20 PM.
23rd December 2014, 12:20 PM |#5  
OP Member
Thanks Meter: 5
 
More
Since my last post, I've been able to perform new others tests on different devices.

My conclusion is that is a Sony specific issue since it fails on every "Z" model I've tried so far (including latest Z3) running Android 4.4.*

Contacted Sony support which did'nt even respond to my queries.

Solution found: replace phone with a model of another brand (scheduled to be delivered soon )
29th June 2015, 10:05 PM |#6  
DcR-Nl's Avatar
Member
localhost
Thanks Meter: 77
 
More
Thumbs up
Finally some good progress on this issue. Sony has acknowledged the issue and will try to fix it in a future release.
Source.
The Following User Says Thank You to DcR-Nl For This Useful Post: [ View ]
30th June 2015, 08:18 AM |#7  
OP Member
Thanks Meter: 5
 
More
Nice.
I don't have my Z anymore but I will share this information.
Thanks
Post Reply Subscribe to Thread

Tags
ipsec, l2tp, vpn
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes