Post Reply Subscribe to Thread Email Thread

Loudspeaker has stopped working - sound only coming out of ear speaker

4th May 2013, 04:49 PM |#1  
OP Member
Thanks Meter: 7
 
96 posts
Join Date:Joined: Mar 2013
As the title says, sound has stopped coming out of my loudspeaker, and is now only coming out through the ear speaker. It's only just started happening. Any ideas? I really want to avoid a factory reset if possible.
The Following User Says Thank You to C1emen7s For This Useful Post: [ View ]
4th May 2013, 04:52 PM |#2  
Senior Member
Thanks Meter: 331
 
2,270 posts
Join Date:Joined: Oct 2009
Quote:
Originally Posted by C1emen7s

As the title says, sound has stopped coming out of my loudspeaker, and is now only coming out through the ear speaker. It's only just started happening. Any ideas? I really want to avoid a factory reset if possible.

did u put it underwater? if so wait about 2-3 hours and it should come back, if not do a reset or flash a different rom to see if it a hardware failure or software.
4th May 2013, 04:52 PM |#3  
OP Member
Thanks Meter: 7
 
96 posts
Join Date:Joined: Mar 2013
Quote:
Originally Posted by G1_enthusiast

did u put it underwater? if so wait about 2-3 hours and it should come back, if not do a reset or flash a different rom to see if it a hardware failure or software.

nope it just randomly stopped. i've never put it in water. will try flashing another rom
19th July 2013, 04:06 PM |#4  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Sep 2012
Same problem
I know this is two months old , but i thought to share though, I started to notice this problem last month , video ,alarms ,music ,etc all play through the ear speaker , then i restart the phone ,the loud speaker is working again , after few days suddenly it stops again and everything plays through the ear speaker. the problem is gone when i restart , but i don't know why it keeps on happening again.
19th July 2013, 04:33 PM |#5  
gm007's Avatar
Senior Member
Thanks Meter: 3,423
 
4,958 posts
Join Date:Joined: May 2011
Repair the phone with sony update service.

Sent from my C6603 using xda premium
20th July 2013, 07:51 AM |#6  
Senior Member
Thanks Meter: 29
 
187 posts
Join Date:Joined: Feb 2012
Have you flashed the pure audio mod?

Xperia Z
23rd October 2013, 08:59 PM |#7  
Member
Thanks Meter: 5
 
36 posts
Join Date:Joined: Dec 2010
More
Im having this Problem since a few days. External speaker stops working, only the phone speaker works. After a reboot the problem's gone. Did try a full wipe, different Roms, like Aosp, Miui and flashed original Sony ftf. Nothing worked....

Sent from my C6603 using XDA Premium 4 mobile app
24th October 2013, 07:26 PM |#8  
Member
Thanks Meter: 5
 
36 posts
Join Date:Joined: Dec 2010
More
Bzw: never flashed pure audio, but when i think about it, i maybe forgot to try to flash a stock ftf....

Sent from my C6603 using XDA Premium 4 mobile app
16th July 2014, 08:30 PM |#9  
Fearnoid's Avatar
Junior Member
Flag Johannesburg
Thanks Meter: 0
 
2 posts
Join Date:Joined: Feb 2012
More
262
I've figured out a way that works on my Sony Xperia T and S. It might work for you too. Try restarting the device in recovery mode (using the vol+up keys while booting up the device.)

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes