Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] my Z volumm down buttob is broken & stuck in safe mode

OP nasunap

8th May 2013, 05:11 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: May 2013
please help
Last edited by nasunap; 14th May 2013 at 06:35 AM.
8th May 2013, 09:46 PM   |  #2  
indycar's Avatar
Senior Member
Flag Bohinjska Bela
Thanks Meter: 75
 
520 posts
Join Date:Joined: Apr 2010
More
open all flaps and turn it off. leave it for few days so it drys out (if it hasnt already)
10th May 2013, 08:48 AM   |  #3  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: May 2013
I have the exact same problem, but in my case it was due to heavy rain and my mobile was in my pocket with all flaps tightly closed. Quite disappointing when the phone is market as water proof. I will give the open flaps for a couple of days. Any other ideas about how this can be solved?
25th June 2013, 08:37 AM   |  #4  
Senior Member
Flag Bhilwara
Thanks Meter: 58
 
214 posts
Join Date:Joined: Apr 2010
More
So did you found out any solution for this prob. I'm in a similar situation. Phone is stuck in safe mode and Power and Vol down keys are not working.

Please let me know if you found any solution
25th June 2013, 09:33 AM   |  #5  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: May 2013
Quote:
Originally Posted by itskapil

So did you found out any solution for this prob. I'm in a similar situation. Phone is stuck in safe mode and Power and Vol down keys are not working.

Please let me know if you found any solution

What I did, as suggested by others, was to let it dry out with open flaps for several days. I also used heardryaer and hoover. After a while it restarted normally, but then I had a problem with camera, flash and closing chrome windows. This final problem I did manage to solve and sent the phone to repair. I got the phone back with a note that the hole phone was changed (got new IMEI number)
1st July 2013, 10:11 AM   |  #6  
Senior Member
Flag Bhilwara
Thanks Meter: 58
 
214 posts
Join Date:Joined: Apr 2010
More
Unhappy
Quote:
Originally Posted by TrondEinar

What I did, as suggested by others, was to let it dry out with open flaps for several days. I also used heardryaer and hoover. After a while it restarted normally, but then I had a problem with camera, flash and closing chrome windows. This final problem I did manage to solve and sent the phone to repair. I got the phone back with a note that the hole phone was changed (got new IMEI number)

Okay thanks for the tip. I did put my phone in rice with all flaps opened for one day but didn't help at all. Will do that again for a week now, and then hair dryer too. Hope that works.

My phone is doing fine otherwise. It's just that malfunctioned Vol down key that's forcing the phone to boot into safe mode on reboot. Hell! I can't even turn off the phone. Firmware update, forced reboot, discharge battery.. all leads to the same "safe mode"

The service center reps say that they are not authorised by Sony to open the phone and fix a silly moisture problem. And that they'd replace the phone for a new IF i agree to PAY 80% cost of the new phone.

Stupid company.
1st July 2013, 10:43 AM   |  #7  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: May 2013
subject willecD
In my case some vital parts was damaged and I got it repaired for free. After all the phone is marketed as water resistant and all my flaps was closed. The rain was heavy though and me and the phone was soaking wet. The volume button and safe mode problem, I think, will be solved as soon as you manage to dry the phone and if you do not have other malfunction.
/Trond
9th July 2013, 08:55 PM   |  #8  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jul 2013
i have the exact same problem too, the phone has only ever been wet when all of the flaps are closed, and even the it wasnt for long or at high pressure, also, when the phone gets hot, i can see condensation in the front camera lens, and my power button will wake the screen but will not lock the phone, im glad to see its not just me and that many people have experienced this same issue, im going to try drying it for a few days, but if that doesnt work i will see what sony say, and i will see what my service provider says about fixing/replacing the phone, also, i have noticed the phone can get quite hot, i am going to see if i can use this as an advantage in drying the phone

EDIT: also, all of my water sensor tabs are all white, and not red or pink
Last edited by mckenziefrazer; 9th July 2013 at 09:02 PM.
27th August 2013, 07:02 PM   |  #9  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Oct 2010
Quote:
Originally Posted by nasunap

please help

@nasunap do you fixed? I have the same Problem
27th August 2013, 08:33 PM   |  #10  
DrKrFfXx's Avatar
Senior Member
Flag Madrid
Thanks Meter: 179
 
547 posts
Join Date:Joined: Mar 2011
More
Thumbs up
And your E and your N keys.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes