Learn How to Create an Old School Dialer

XDA is not only a great source for custom ROMs, kernels, and various modifications for numerous … more

USB Desktop Charger Roundup – XDA TV

Sometimes you learn one way to do something, and that’s the way you do it forever. You never … more

Samsung Galaxy Grand Duos Receives Early CM12 Port

Samsung Galaxy Grand is a dual-SIM phone with a 5 screen that was announced two years ago. … more

Google Adds New Features to Drive, Sheets, Slides and Docs

In the last few months, Google has been working very hard to adapt all its apps to … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Rare Case - Red LED always on while screen is on

OP Vinardo_ZzZ 2000

30th May 2014, 03:57 PM   |  #1  
Vinardo_ZzZ 2000's Avatar
OP Senior Member
Flag Aperture Laboratories
Thanks Meter: 1,091
 
1,128 posts
Join Date:Joined: Mar 2013
Donate to Me
More
Alright. My brother bought a used Xperia Z about 2 weeks ago. After using it some days, suddenly this happened. The red LED always stays on while the screen is on. And this is a rare problem. I don't see any problems like this before in XDA. The phone is not rooted nor the bootloader has been unlocked. Can someone help fix this problem, or tell me what partition is damaged, etc? I can't confirm this is a HW damage coz it's not dropped, or punched, etc The red LED acts normally if the screen is off (e.g. while charging, notification, etc).
30th May 2014, 10:31 PM   |  #2  
androidtweaker1's Avatar
Senior Member
Thanks Meter: 261
 
829 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by Vinardo_ZzZ 2000

Alright. My brother bought a used Xperia Z about 2 weeks ago. After using it some days, suddenly this happened. The red LED always stays on while the screen is on. And this is a rare problem. I don't see any problems like this before in XDA. The phone is not rooted nor the bootloader has been unlocked. Can someone help fix this problem, or tell me what partition is damaged, etc? I can't confirm this is a HW damage coz it's not dropped, or punched, etc The red LED acts normally if the screen is off (e.g. while charging, notification, etc).

Factory reset will solve your issue most probably
The Following User Says Thank You to androidtweaker1 For This Useful Post: [ View ]
31st May 2014, 09:01 AM   |  #3  
Vinardo_ZzZ 2000's Avatar
OP Senior Member
Flag Aperture Laboratories
Thanks Meter: 1,091
 
1,128 posts
Join Date:Joined: Mar 2013
Donate to Me
More
Quote:
Originally Posted by androidtweaker1

Factory reset will solve your issue most probably

My bro tried it many times. Using PC Companion doesn't work either...
31st May 2014, 10:51 AM   |  #4  
androidtweaker1's Avatar
Senior Member
Thanks Meter: 261
 
829 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by Vinardo_ZzZ 2000

My bro tried it many times. Using PC Companion doesn't work either...

bro you can try flashing stock rom again.

---------- Post added at 12:51 PM ---------- Previous post was at 12:45 PM ----------

Quote:
Originally Posted by Vinardo_ZzZ 2000

My bro tried it many times. Using PC Companion doesn't work either...

download 4.4.2 official ftf from here https://mega.co.nz/#!Bk0XlY7S!7rhLzB...omXmNTcrI3h4Vc
download flashtool from here http://www.flashtool.net/download.php

after installing flashtool go to c: then flashtool folder
go to drivers install from exe file, select flashboot and fastboot and finish installation

open flashtool, click on the lightning button, select flashboot.
select the firmware downloaded(make sure you cut paste the ftf file in the firmware folder of flashtool folder)
put phone in flashmode when prompted(hold power down key and connect usb)
once flashing is complete disconnect and switch on the phone
31st May 2014, 03:44 PM   |  #5  
Vinardo_ZzZ 2000's Avatar
OP Senior Member
Flag Aperture Laboratories
Thanks Meter: 1,091
 
1,128 posts
Join Date:Joined: Mar 2013
Donate to Me
More
Quote:
Originally Posted by androidtweaker1

bro you can try flashing stock rom again.

---------- Post added at 12:51 PM ---------- Previous post was at 12:45 PM ----------



download 4.4.2 official ftf from here https://mega.co.nz/#!Bk0XlY7S!7rhLzB...omXmNTcrI3h4Vc
download flashtool from here http://www.flashtool.net/download.php

after installing flashtool go to c: then flashtool folder
go to drivers install from exe file, select flashboot and fastboot and finish installation

open flashtool, click on the lightning button, select flashboot.
select the firmware downloaded(make sure you cut paste the ftf file in the firmware folder of flashtool folder)
put phone in flashmode when prompted(hold power down key and connect usb)
once flashing is complete disconnect and switch on the phone

I think he already tried flashing with flash mode too. I will ask him later. Thanks for your suggestion
31st May 2014, 03:53 PM   |  #6  
androidtweaker1's Avatar
Senior Member
Thanks Meter: 261
 
829 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by Vinardo_ZzZ 2000

I think he already tried flashing with flash mode too. I will ask him later. Thanks for your suggestion

ok
The Following User Says Thank You to androidtweaker1 For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes