Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Not receiving push notifications from Facebook / Messenger on sleep?

OP airlessproject

8th March 2014, 12:03 AM   |  #1  
airlessproject's Avatar
OP Senior Member
Flag Prilep
Thanks Meter: 27
 
178 posts
Join Date:Joined: Aug 2013
More
Hi all.

Anyone else not receiving push notifications from Facebook / Messenger on sleep (with or without Stamina Mode on)?
For messages, notifications only have a 100% received rate only when a chat head is popped out and the screen is on.

Also I'm trying to figure out whether it is a Facebook / Messenger bug and/or XZ / XZ related bug.

Thanks in advance for your answers.

Kind regards.
8th March 2014, 11:57 AM   |  #2  
Dsteppa's Avatar
Senior Member
Thanks Meter: 389
 
1,630 posts
Join Date:Joined: May 2012
More
The most probable reason I can think of is that somewhere it states to block everything when the screen is off, aka not really to sleep mode, but due to the screen being off.
Does it happen on Wifi only or any connection?
8th March 2014, 08:43 PM   |  #3  
airlessproject's Avatar
OP Senior Member
Flag Prilep
Thanks Meter: 27
 
178 posts
Join Date:Joined: Aug 2013
More
Quote:
Originally Posted by Dsteppa

Does it happen on Wifi only or any connection?

On any connection. Even more, when a push notification for e.g. Messenger message is missed while the screen is off, it is received immediately after turning the screen on.
8th March 2014, 09:39 PM   |  #4  
Dsteppa's Avatar
Senior Member
Thanks Meter: 389
 
1,630 posts
Join Date:Joined: May 2012
More
Quote:
Originally Posted by airlessproject

On any connection. Even more, when a push notification for e.g. Messenger message is missed while the screen is off, it is received immediately after turning the screen on.

Hmmm that's freaky...
Did you try to reflash?
9th March 2014, 12:29 AM   |  #5  
airlessproject's Avatar
OP Senior Member
Flag Prilep
Thanks Meter: 27
 
178 posts
Join Date:Joined: Aug 2013
More
Quote:
Originally Posted by Dsteppa

Did you try to reflash?

Reflashing either kernel, even more ROM would be my last resort on this as I regard it as a minor issue. I was mostly wondering if anyone else got this and fixed it somehow.
9th March 2014, 05:18 PM   |  #6  
airlessproject's Avatar
OP Senior Member
Flag Prilep
Thanks Meter: 27
 
178 posts
Join Date:Joined: Aug 2013
More
Reading user reviews on Play Store for Messenger, it turns out it is a Messenger issue. Will wait for an improved version.
11th March 2014, 03:00 AM   |  #7  
Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Sep 2008
Try adding Facebook/Messenger to your Stamina Mode white list. I had similar issue which was fixed by adding apps to SM white list

Sent from my C6603 using Tapatalk
11th March 2014, 12:24 PM   |  #8  
airlessproject's Avatar
OP Senior Member
Flag Prilep
Thanks Meter: 27
 
178 posts
Join Date:Joined: Aug 2013
More
Quote:
Originally Posted by madheadwil

Try adding Facebook/Messenger to your Stamina Mode white list. I had similar issue which was fixed by adding apps to SM white list

Sent from my C6603 using Tapatalk

They were already added. I'm 99.9% definite it is a Messenger issue, so I'll wait for fixes in updates.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes