Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Xperia Z keeps rebooting on 'Sony'

OP kaykaa5

19th June 2014, 01:31 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Oct 2011
Hi,

Recently my Sony Xperia Z device is showing some issues. One of them (to start with) is that the battery is dropping really hard from for example 40 percent to 13 percent. The strange thing is that it also goes up from (for example) 43 percent to 50 percent. These issues started when my phone got really warm from lying in the sun for a short period. It also doesn't charge properly when it is on the charger.

Now the real problem is that yesterday my phone got out of battery and it wont start up anymore. When I try to start up by holding the power button I don't get any response from it. When I put it on the charger it keeps restarting/rebooting on the 'Sony' logo. The device keeps doing this without doing anything else.

I've tried to flash the device with the Sony Update Service, without any luck.

I am really out of ideas and I'm hoping that you guys could help me.


Greetings,

Kay.
19th June 2014, 02:06 PM   |  #2  
androidtweaker1's Avatar
Senior Member
Thanks Meter: 261
 
829 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by kaykaa5

Hi,

Recently my Sony Xperia Z device is showing some issues. One of them (to start with) is that the battery is dropping really hard from for example 40 percent to 13 percent. The strange thing is that it also goes up from (for example) 43 percent to 50 percent. These issues started when my phone got really warm from lying in the sun for a short period. It also doesn't charge properly when it is on the charger.

Now the real problem is that yesterday my phone got out of battery and it wont start up anymore. When I try to start up by holding the power button I don't get any response from it. When I put it on the charger it keeps restarting/rebooting on the 'Sony' logo. The device keeps doing this without doing anything else.

I've tried to flash the device with the Sony Update Service, without any luck.

I am really out of ideas and I'm hoping that you guys could help me.


Greetings,

Kay.

Try flashing the firmware using flashtool
Whats the model of your phone?
19th June 2014, 04:25 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Oct 2011
Quote:
Originally Posted by androidtweaker1

Try flashing the firmware using flashtool
Whats the model of your phone?

It's a Sony Xperia Z
19th June 2014, 04:31 PM   |  #4  
androidtweaker1's Avatar
Senior Member
Thanks Meter: 261
 
829 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by kaykaa5

It's a Sony Xperia Z

Which variant of Xperia Z: C6603 or C6602 or C6606 or C6616
19th June 2014, 05:01 PM   |  #5  
OP Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Oct 2011
Quote:
Originally Posted by androidtweaker1

Which variant of Xperia Z: C6603 or C6602 or C6606 or C6616

Oh, sorry... I actually have no idea. Is there a way to check this without getting the phone one?
19th June 2014, 05:07 PM   |  #6  
androidtweaker1's Avatar
Senior Member
Thanks Meter: 261
 
829 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by kaykaa5

Oh, sorry... I actually have no idea. Is there a way to check this without getting the phone one?

The variant is written at the bottom of the phone, check and let me know
19th June 2014, 05:11 PM   |  #7  
OP Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Oct 2011
Quote:
Originally Posted by androidtweaker1

The variant is written at the bottom of the phone, check and let me know

It's a C6603.
19th June 2014, 05:36 PM   |  #8  
androidtweaker1's Avatar
Senior Member
Thanks Meter: 261
 
829 posts
Join Date:Joined: May 2014
Quote:
Originally Posted by kaykaa5

It's a C6603.

.
You can download kitkat stock firmware for 6603 from here
Download flashtool to flash firmware from here

How to flash instructions are given below

Download and install the Flashtool
Go to the flashtool folder in c drive, keep the firmware ie the ftf file in the firmware folder of flashtool
Next go to where you installed flashtool folder in C drive and then to the drivers folder.
Run the Flashtool-drivers.exe file.
Xperia Z drivers, flashmode drivers and fastboot drivers.
Accept all the prompts and once finished load flashtool
Click the thunder button on top left
Now select flashmode
Select the firmware you want to flash
Turn off phone(Hold power and both the volume keys till you feel 3 vibrations)
When it tells you to connect hold down the volume button and connect usb to phone
Flashing will start
After flashing is complete boot the phone
Last edited by androidtweaker1; 19th June 2014 at 05:39 PM.
19th June 2014, 07:50 PM   |  #9  
OP Junior Member
Thanks Meter: 0
 
11 posts
Join Date:Joined: Oct 2011
Quote:
Originally Posted by androidtweaker1

.
You can download kitkat stock firmware for 6603 from here
Download flashtool to flash firmware from here

How to flash instructions are given below

Download and install the Flashtool
Go to the flashtool folder in c drive, keep the firmware ie the ftf file in the firmware folder of flashtool
Next go to where you installed flashtool folder in C drive and then to the drivers folder.
Run the Flashtool-drivers.exe file.
Xperia Z drivers, flashmode drivers and fastboot drivers.
Accept all the prompts and once finished load flashtool
Click the thunder button on top left
Now select flashmode
Select the firmware you want to flash
Turn off phone(Hold power and both the volume keys till you feel 3 vibrations)
When it tells you to connect hold down the volume button and connect usb to phone
Flashing will start
After flashing is complete boot the phone

When I unplug the phone it doesn't do anything while powering on. When I connect it on the charger it begins booting with 'Sony' again
22nd June 2014, 12:14 AM   |  #10  
androidfreak70's Avatar
Senior Member
Flag here!
Thanks Meter: 636
 
3,799 posts
Join Date:Joined: Feb 2014
Donate to Me
More
Quote:
Originally Posted by kaykaa5

When I unplug the phone it doesn't do anything while powering on. When I connect it on the charger it begins booting with 'Sony' again

Do the phone vibrate???? Do you get the led (shiny small dote on the right of sony logo!) light??
If the both are NO! so take your phone to service center to replace the battery!!!

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes