Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,814,393 Members 52,989 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Xperia Z 6603, 10.3.1.A.0.244/ 10.3.1.A.2.67 - mobile data problem

Tip us?
 
barbacan
Old
(Last edited by barbacan; 12th June 2014 at 01:41 PM.) Reason: Misspelt model number - should be 6603
#1  
Junior Member - OP
Thanks Meter 0
Posts: 12
Join Date: Aug 2012
Default [Q] Xperia Z 6603, 10.3.1.A.0.244/ 10.3.1.A.2.67 - mobile data problem

Hello All,
I am afraid this not is going to be a short and easy story... I will try to be short
After the Stock update to 4.4.2 i got finally fed up with the fact that the long awaited KitKat drains battery like a power addict and decided to go back to stock 4.2.2 - which, for me, solves two problems - in this version the Bluetooth connectivity in my car works properly and the battery is used more 'soberly' as well as that I can easily root it and clear all the bloatware.

I found several stock versions of 4.2.2 - e.g. C6603_10.3.1.A.0.244_Generic NCB.ftf, C6603_10.3.1.A.0.244_CE.ftf, C6603_10.3.1.A.2.67_CE.ftf
After flashing them with the latest flashtool everything seems fine - battery, bluetooth,wifi etc. BUT the mobile data has the following problem: the phone connects to 4G, 3G and GPRS, but apart from Youtube none of the applications is able to use the Internet connection from the mobile operator. This to me seems like a problem with DNS resolution but I do not have any firewalls etc. installed or activated.

It may be worth mentioning that when Chrome tries to connect to a web address (e.g. xyz) for an instant there is a message on the screen "Redirecting you to xyz web address", maybe this is the place where it goes wrong? Needles to say that the connection to the specified website is not possible because "Chrome could not find the xyz page"... (this does not happen on wifi connection).

I would be very grateful if U could suggest a way out !
 
Orangewanted
Old
#2  
Orangewanted's Avatar
Member
Thanks Meter 12
Posts: 43
Join Date: Jun 2014
Have you tried downloading the Internet setting ?
at setting -> xperia -> Internet setting.
 
barbacan
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 12
Join Date: Aug 2012
Quote:
Originally Posted by Orangewanted View Post
Have you tried downloading the Internet setting ?
at setting -> xperia -> Internet setting.
Hi,
I reloaded the Internet settings from my operator several times, also changed to another sim. What is really puzzling is that Youtube has no problem with connecting. There is something funny going on with the DNS service I suppose....
Any thoughts ?
Thx
 
androidtweaker1
Old
#4  
androidtweaker1's Avatar
Senior Member
Thanks Meter 255
Posts: 821
Join Date: May 2014
Quote:
Originally Posted by barbacan View Post
Hello All,
I am afraid this not is going to be a short and easy story... I will try to be short
After the Stock update to 4.4.2 i got finally fed up with the fact that the long awaited KitKat drains battery like a power addict and decided to go back to stock 4.2.2 - which, for me, solves two problems - in this version the Bluetooth connectivity in my car works properly and the battery is used more 'soberly' as well as that I can easily root it and clear all the bloatware.

I found several stock versions of 4.2.2 - e.g. C6603_10.3.1.A.0.244_Generic NCB.ftf, C6603_10.3.1.A.0.244_CE.ftf, C6603_10.3.1.A.2.67_CE.ftf
After flashing them with the latest flashtool everything seems fine - battery, bluetooth,wifi etc. BUT the mobile data has the following problem: the phone connects to 4G, 3G and GPRS, but apart from Youtube none of the applications is able to use the Internet connection from the mobile operator. This to me seems like a problem with DNS resolution but I do not have any firewalls etc. installed or activated.

It may be worth mentioning that when Chrome tries to connect to a web address (e.g. xyz) for an instant there is a message on the screen "Redirecting you to xyz web address", maybe this is the place where it goes wrong? Needles to say that the connection to the specified website is not possible because "Chrome could not find the xyz page"... (this does not happen on wifi connection).

I would be very grateful if U could suggest a way out !
manually flash 4.3
check whether it rectifies issues
after that manually flash 4.4.2 without data wipe
Hit thanks if helped

“You have not lived today until you have done something for someone who can never repay you ― John Bunyan”


Current Devices
Sony Xperia Z:Stock 4.4.4 Rooted
Samsung Galaxy Nexus: Dirty Unicorns
The Following User Says Thank You to androidtweaker1 For This Useful Post: [ Click to Expand ]
 
barbacan
Old
#5  
Junior Member - OP
Thanks Meter 0
Posts: 12
Join Date: Aug 2012
Quote:
Originally Posted by androidtweaker1 View Post
manually flash 4.3
check whether it rectifies issues
after that manually flash 4.4.2 without data wipe
Hello - thanks for this attempt, but unfortunately no luck with it. Here is what I did (please check if I understood you correclty):
1) downloaded - C6603_10.4.1.B.0.101_CE.ftf (4.3)
2) flashed 4.3.(above) with Flashtool (wiping all)
3) restarted - mobile data could be accessed by Chrome and other apps
4) flashed 4.2.2 ver 10.3.1.A.0.244 and then 10.3.1.A.2.67 with the data wipe disabled,
Result - again in 4.2.2 the mobile data is not available to apps other than Youtube ...
Any more thoughts on this?
Thanks again !
 
androidtweaker1
Old
#6  
androidtweaker1's Avatar
Senior Member
Thanks Meter 255
Posts: 821
Join Date: May 2014
Quote:
Originally Posted by barbacan View Post
Hello - thanks for this attempt, but unfortunately no luck with it. Here is what I did (please check if I understood you correclty):
1) downloaded - C6603_10.4.1.B.0.101_CE.ftf (4.3)
2) flashed 4.3.(above) with Flashtool (wiping all)
3) restarted - mobile data could be accessed by Chrome and other apps
4) flashed 4.2.2 ver 10.3.1.A.0.244 and then 10.3.1.A.2.67 with the data wipe disabled,
Result - again in 4.2.2 the mobile data is not available to apps other than Youtube ...
Any more thoughts on this?
Thanks again !
Another solution will be root the 4.2.2 using easyroot
flash prerooted 4.4.2
download no frills cpu from playstore and under-clock the processor a bit it will greatly improve battery life.I am doing the same
Hit thanks if helped

“You have not lived today until you have done something for someone who can never repay you ― John Bunyan”


Current Devices
Sony Xperia Z:Stock 4.4.4 Rooted
Samsung Galaxy Nexus: Dirty Unicorns
The Following User Says Thank You to androidtweaker1 For This Useful Post: [ Click to Expand ]
 
barbacan
Old
#7  
Junior Member - OP
Thanks Meter 0
Posts: 12
Join Date: Aug 2012
Quote:
Originally Posted by androidtweaker1 View Post
Another solution will be root the 4.2.2 using easyroot
flash prerooted 4.4.2
download no frills cpu from playstore and under-clock the processor a bit it will greatly improve battery life.I am doing the same

OK - So I see where we have a misunderstanding ... I wanted to go back to 4.2.2. which worked fine for me for the small exception of the mobile data transmission but not go up to 4.4.2.
I am looking for a solution to make the 4.2.2. work with data transmission.
Could you give this a thought ? I would appreciate it a lot!
Regards!
 
androidtweaker1
Old
#8  
androidtweaker1's Avatar
Senior Member
Thanks Meter 255
Posts: 821
Join Date: May 2014
Quote:
Originally Posted by barbacan View Post
OK - So I see where we have a misunderstanding ... I wanted to go back to 4.2.2. which worked fine for me for the small exception of the mobile data transmission but not go up to 4.4.2.
I am looking for a solution to make the 4.2.2. work with data transmission.
Could you give this a thought ? I would appreciate it a lot!
Regards!
I gave 4.4.2 solution because the data issue is sufficing in 4.2.2 repeatedly
and from what i had read the only issue you had with 4.4.2 was battery drain so gave you a solution for 4.4.2
Hit thanks if helped

“You have not lived today until you have done something for someone who can never repay you ― John Bunyan”


Current Devices
Sony Xperia Z:Stock 4.4.4 Rooted
Samsung Galaxy Nexus: Dirty Unicorns
The Following User Says Thank You to androidtweaker1 For This Useful Post: [ Click to Expand ]
 
barbacan
Old
#9  
Junior Member - OP
Thanks Meter 0
Posts: 12
Join Date: Aug 2012
Quote:
Originally Posted by androidtweaker1 View Post
I gave 4.4.2 solution because the data issue is sufficing in 4.2.2 repeatedly
and from what i had read the only issue you had with 4.4.2 was battery drain so gave you a solution for 4.4.2
Your help is very much appreciated!
The reason I keep trying with 4.2.2 is that I am also struggling with the bluetooth issue: on anything above 4.2.2. - simply does not connect to my car's buletooth handsfree....
Thanks anyway. I need to decide whether I have the bluetooth and no mobile data or mobile data and no bluetooth, Seems like Sony is not too generous ...
 
androidtweaker1
Old
(Last edited by androidtweaker1; 12th June 2014 at 08:20 PM.)
#10  
androidtweaker1's Avatar
Senior Member
Thanks Meter 255
Posts: 821
Join Date: May 2014
Quote:
Originally Posted by barbacan View Post
Your help is very much appreciated!
The reason I keep trying with 4.2.2 is that I am also struggling with the bluetooth issue: on anything above 4.2.2. - simply does not connect to my car's buletooth handsfree....
Thanks anyway. I need to decide whether I have the bluetooth and no mobile data or mobile data and no bluetooth, Seems like Sony is not too generous ...
Have u given 4.3 a try?

Edit ignore this
Hit thanks if helped

“You have not lived today until you have done something for someone who can never repay you ― John Bunyan”


Current Devices
Sony Xperia Z:Stock 4.4.4 Rooted
Samsung Galaxy Nexus: Dirty Unicorns

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes