Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,778,591 Members 36,381 Now Online
XDA Developers Android and Mobile Development Forum

Sony Smart accessories and Xperia Z issues

Tip us?
 
Spectre51
Old
#1  
Spectre51's Avatar
Recognized Contributor - OP
Thanks Meter 1322
Posts: 3,305
Join Date: Jul 2010

 
DONATE TO ME
Default Sony Smart accessories and Xperia Z issues

I have the Smartwatch and Smart wireless headset pro paired to my Xperia Z. I have noticed a couple of issues.

Smartwatch:
Disconnects quite a bit and requires me to swipe up on the watch screen to make it reconnect. I would say today it happened 30-40 times in a 10 hour period. Haven't had any issue with the watch like that on any of my other devices. Anyone else had this happen? Smartwatch is running the latest firmware.

Smart wireless headset pro:
It paired fine to the XZ and seems to work without issue. The thing I have noticed though is the Throw icon will pop up in the notification area and allow me to toggle between phone and the headset, or at least appears that way. If I change it to the headset via the throw function nothing changes. Sound continues based on how I have it setup in the bluetooth headset settings. Even stranger is if I disconnect the headset by turning it off the Throw icon will still be there. When I open it the headset will disappear from the options and when I go back to the home screen the throw icon is gone from the notification area but will return some time later again showing the headset even though it has been off that whole time.

Not sure why the throw options would show up if they won't change how the audio is handled or why it keeps showing up after I have disconnected the device. Anyone else with either of these accessories having any issues?

Current Phones/Tablets:
Xperia Z2 // OnePlus One // Xperia Z Ultra // Lumia 1020 // Xperia Tablet Z // Surface Pro
Accessories
Sony Smart Wireless Headset pro MW1 // Smart Bluetooth Handset SBH52 // Z Ultra Power Cover CP12
Past Phones/Tablets:
iPhone 1st Gen/3GS/4S // Nexus One // Dell Streak // Atrix 4g // Lumia 900, 920 // Xperia Play, S, P, ion, TL, Z, Z1 // iPad 1, 3

Click here for my Xperia firmware downloads.
Use the Thanks button if I helped.
 
DeadlyDazza
Old
#2  
DeadlyDazza's Avatar
Senior Member
Thanks Meter 78
Posts: 624
Join Date: Jul 2010
Default Re: Sony Smart accessories and Xperia Z issues

It could be a jellybean issue.

Those of us in the Nexus 7 forum had issues with bluetooth with jellybean, audio lag, skip & disconnects.

Seems to be much better after the latest jellybean update.
 
Spectre51
Old
(Last edited by Spectre51; 22nd February 2013 at 11:00 AM.)
#3  
Spectre51's Avatar
Recognized Contributor - OP
Thanks Meter 1322
Posts: 3,305
Join Date: Jul 2010

 
DONATE TO ME
Default Re: Sony Smart accessories and Xperia Z issues

Q
Quote:
Originally Posted by DeadlyDazza View Post
It could be a jellybean issue.

Those of us in the Nexus 7 forum had issues with bluetooth with jellybean, audio lag, skip & disconnects.

Seems to be much better after the latest jellybean update.
Didn't have the issue with my TL running the LT30p JB update though.

And tonight I unpaired the headset from the phone completely and turned the headset off. The phone still popped up the throw notification and had the headset listed there. This was after a reboot too.

Sent from my Sony Xperia™ Z

Current Phones/Tablets:
Xperia Z2 // OnePlus One // Xperia Z Ultra // Lumia 1020 // Xperia Tablet Z // Surface Pro
Accessories
Sony Smart Wireless Headset pro MW1 // Smart Bluetooth Handset SBH52 // Z Ultra Power Cover CP12
Past Phones/Tablets:
iPhone 1st Gen/3GS/4S // Nexus One // Dell Streak // Atrix 4g // Lumia 900, 920 // Xperia Play, S, P, ion, TL, Z, Z1 // iPad 1, 3

Click here for my Xperia firmware downloads.
Use the Thanks button if I helped.
 
markiepuk
Old
(Last edited by markiepuk; 23rd February 2013 at 01:22 PM.)
#4  
Member
Thanks Meter 10
Posts: 41
Join Date: Mar 2009
Location: Ipplepen
Quote:
Originally Posted by Spectre51 View Post
I have the Smartwatch and Smart wireless headset pro paired to my Xperia Z. I have noticed a couple of issues.

Smartwatch:
Disconnects quite a bit and requires me to swipe up on the watch screen to make it reconnect. I would say today it happened 30-40 times in a 10 hour period. Haven't had any issue with the watch like that on any of my other devices. Anyone else had this happen? Smartwatch is running the latest firmware.
My Smart watch randomly disconnects to, sometimes it works for hours no issues other time disconnects every 2-3 mins, again both running the latest firmware.

Also when i restart the phone liveware/ (Smart Connect?) FC`s a couple of times before it settles.
Chequered Phone History:

Alcatel HC400- Barclaycard phone, Phillips Diga, Nokia 8210
NEC DB200, Nokia 3510i, Motorola C550, Sony Ericson 550i
Nokia N95, IPhone 3g. Sony Ericson X10,Sony Xperia S, Sony Xperia Z

Current: Sony Xperia Z1 & Nokia Lumia 925
 
jadaress1
Old
#5  
Senior Member
Thanks Meter 52
Posts: 361
Join Date: Nov 2010
Default Re: Sony Smart accessories and Xperia Z issues

The smartwatch works perfectly with my note 2, thought it would work just as good or better with the xz seeing as there both sonys. Strange

Sent from my GT-N7100 using xda premium
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes