Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,810,846 Members 37,314 Now Online
XDA Developers Android and Mobile Development Forum

Sony Xperia Z won't turn on [Red notification LED]

Tip us?
 
aaronkatrini
Old
#1  
Member - OP
Thanks Meter 3
Posts: 60
Join Date: Feb 2012
Location: rome, italy
Unhappy Sony Xperia Z won't turn on [Red notification LED]

Hi all,
I have a Sony Xperia Z from my friend, the problem is that the phone won't turn on. I've been pressing all the button combinations (power + volume up; power + volume down; power + vol up + vol down), and nothing happens, no vibration, no Red LED blinking whatsoever.
The only "vital" sign it gives is the Red LED when you plug it on the charger or on the USB on the Pc (detects nothing).
I've left my device charge overnight (9+ hours) and nothing has changed.
My friend told me the phone kept rebooting it self (don't really know what caused this as himself couldn't explain) to the point the device didn't turn on anymore.
I really don't know what has happened to the phone. I've been trying to find on the forums about this but other people say the phone vibrates or the Red LED starts to blink, to my phone nothing!
Any help, suggestion, thought from personal experience is Highly appreciated!
Thanks in advance,

-aaronkatrini
 
kingvortex
Old
(Last edited by kingvortex; 29th March 2014 at 11:51 AM.)
#2  
kingvortex's Avatar
Senior Member
Thanks Meter 2,288
Posts: 3,315
Join Date: Mar 2010
Location: Nottingham
Have you tried holding volume down when connecting it to your PC? That should enter Flashmode. If it does, then you can try flashing a stock rom.
If not, try volume up when connecting to your PC, which should enter Fastboot mode.

If none of those work, it looks like either a hardware error, or a corrupted bootloader. Neither of those are repairable by yourself.

Sent from my C6603 using Tapatalk
The Following User Says Thank You to kingvortex For This Useful Post: [ Click to Expand ]
 
aaronkatrini
Old
(Last edited by aaronkatrini; 29th March 2014 at 12:03 PM.)
#3  
Member - OP
Thanks Meter 3
Posts: 60
Join Date: Feb 2012
Location: rome, italy
hi, thanks, just tried that but it wont recognize at all, I've seen the device manager on my pc and nothing is detected at all. Just the notification LED, it gets Red and nothing happens.
Anything else I can try?
One more question, can I send it for repair to Sony, will my warranty cover it?
 
kingvortex
Old
(Last edited by kingvortex; 29th March 2014 at 12:11 PM.)
#4  
kingvortex's Avatar
Senior Member
Thanks Meter 2,288
Posts: 3,315
Join Date: Mar 2010
Location: Nottingham
It sounds like it needs sending for repair then, unfortunately.

Edit - Yes, warranty should cover it.

Sent from my C6603 using Tapatalk
 
aaronkatrini
Old
#5  
Member - OP
Thanks Meter 3
Posts: 60
Join Date: Feb 2012
Location: rome, italy
Quote:
Originally Posted by kingvortex View Post
It sounds like it needs sending for repair then, unfortunately.

Edit - Yes, warranty should cover it.

Sent from my C6603 using Tapatalk
Thanks, you're very kind!
Tags
led, red, sony, turn, xperia z
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes