Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Unbrick Xperia Z - Not charging or Booting

OP hunix

28th May 2014, 01:07 AM   |  #11  
OP Member
Kuwait
Thanks Meter: 16
 
58 posts
Join Date:Joined: Jan 2005
More
Quote:
Originally Posted by ABCdude

Hey hunix,

Thanks for making this guide, this exact issue has been troubling me for a few days now. I had already bought a new battery which charged once but has the same status now, and this thread also confirms that battery is not the issue. Now, I am trying to follow the steps to get the device working once to check whether the issue on my xperia Z is the same as what quickstyler suggests (Many thanks for the hardware fix, quickstyler) before trying any soldering on my phone.

I am able to get into fastboot mode, but when flashing system.sin, fastboot returns an error : remote (data too large). Even after lots of googling and searching on xda (tried different fastboot binaries, but none helped), I am none the wiser on that error. Any chance you guys encountered that error or have a solution?

Also, if this error cannot be resolved, can fixing the charging circuit hardware get my phone in flash mode as I have erased /system on my phone.

Hey,

Make sure your in FlashMode not fastboot mode as @quickstyler mentioned and regarding the hardware fix i didn't have any free time to try it but its a logical fix to the problem i already disassembled my device and going to solder the wire in a bit

thanks
26th July 2014, 07:56 PM   |  #12  
Junior Member
kolkata
Thanks Meter: 2
 
29 posts
Join Date:Joined: Jan 2012
More
Unhappy Bricked Sonly Z
Quote:
Originally Posted by hunix

Hey everyone, first of all I've been struggling with the Xperia Z C6602 for long time now and no one could fix it, i kept on playing around until i got it booting up again, here are the symptoms and the solution, btw my device is stock, unrooted and the bootloader is locked

-Symptoms
First it started by showing weird battery levels and battery draining then its totally dead as its not charging

*Device not booting up, only showing Sony logo then turns itself off
*Device not charging
*When ever i try to use Flashtool in Flashmode the process gets interrupted and fails because the device restarts by itself
*Using SUS doesn't help because the device keeps on rebooting by itself
*The only stable state of the device is in Fastboot mode
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------

-Solution
This solution gets the device working again BUT i still have the charging bug as i haven't tried other firmwares that i wish they have the bug fix

Required tools and files:

1- A Firmware in FTF format which can be found on the following link (http://forum.xda-developers.com/xper...0-101-t2639943)
2- Flashtool which can be found on the following link (http://www.flashtool.net/index.php)
3- Winrar or any archive decompressing tool

Procedures:

1- Get a charge for your device by keeping it plugged into the DC charger (Wall Charger) and pressing Volume Up + Power while connecting until the device vibrates (Keep it plugged in for a couple of hours even if the device keeps on rebooting)
2- Open the downloaded FTF file with Winrar and extract all the files into a folder of your choice on your computer
3- Execute Flashtool by going to its default installation folder (C:\Flashtool\) and double clicking on FlashTool.exe (Start it up as an administrator)
4- Now after having the device plugged into a power source for a couple of hours you can take it off and make sure its shutdown completely, Keep on pressing the "Volume UP" button while connecting the device to your computer until you see the LED on the top right of the device lighting in "Blue" then the Flashtool Status Box should indicate that a device has been connected in Fastboot mode
5- Click on the "Thunder" icon on the top left of the window just under the File menu and choose Fastboot mode
6- A Window will open with multiple Buttons, Click on the "Select System to Flash" button and browse your computer to locate the files that were extracted from the FTF file and choose the file named "system.sin"
7- Keep an eye on the Status Text Box on the main window of the application to check if the process went smoothly or its showing an error, it should go smoothly after that you will have to click on the "Thunder" button again and choose Fastboot mode
8- Click on the button named "Select kernel to HotBoot" and navigate your files to select the "kernel.sin" file from the same folder as "system.sin"
9- The device will reboot and the main window of Flashtool will indicate that a device has been disconnected and then connected again in "FlashMode" this time, This time it won't reboot by itself and it will remain in Flashmode as long as its connected to the PC
10- Now click on the "Thunder" button on the top left again and this time choose "FlashMode", make sure you have the FTF file or the desired firmware in the firmwares folder of Flashtool which is "C:\Flashtool\Firmwares", The desired firmware will be listed in the firmware list, Select it and click on "Flash" button on the bottom right
11- Keep watching the status text box to make sure everything is going on smoothly, When it indicates that flashing is done please disconnect your phone and start it up normally

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Now you should have your device alive again, If some one is aware of a specific firmware build that has the battery bug fixed please post it here, The firmware on my device now is .101 which was updated through OTA update once i booted up again but the bug persists

Hope it helps, thanks

I Have SOny Z , I Bricked My Phone , Rooted , Unlocked Bootloader , Can I Use Your Method? Will Your Method WOrk?
25th September 2014, 07:19 PM   |  #13  
Junior Member
Thanks Meter: 0
 
6 posts
Join Date:Joined: Aug 2007
i have phone xperia z which is on while on charging after remove charging phone switch off have you above method work?
20th October 2014, 11:43 AM   |  #14  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Oct 2014
problem
Hi, sorry bad english...

I tried to instal some ROM with CWM. I got some errors...and now my phone is bricked.
I can only use fastboot mode. My BL is UL so SonyCompanion cant help me.
When I use flashtools to flash stosck system i get this message and thats all...

- INFO - Selected system (system.img or system.sin): C:\Users\Siki\Desktop\system.sin
-INFO - Flashing selected system
- INFO - Please check the log before rebooting into system

Any help, please? Thanks
23rd November 2014, 01:44 PM   |  #15  
Member
Thanks Meter: 13
 
79 posts
Join Date:Joined: May 2012
Quote:
Originally Posted by gbkuvad2000

i have phone xperia z which is on while on charging after remove charging phone switch off have you above method work?

Same Problem Here. I will try to replace my battery ? See what happen Next ?
Post Reply Subscribe to Thread

Tags
xperia z, xperia z bricked
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes