Nvidia and Robotics w/ Barrett Williams – XDA:DevCon 2014

Robotics continues to dominate our videos from this years XDA:DevCon 2014 in … more

Speed Up Deodexing with JoelDroid Batch Deodexer

Android 5.0 Lollipop brings many under-the-hood changes like changing the default compiler … more

Top 5 Apps for 2014 + Top Xposed Mod of 2014 – XDA TV

Its that time of year where you look back and remember the things that happened … more

NVIDIA SHIELD Tablet Gets Android 5.0.1, OTA Available

The NVIDIA SHIELD Tablet is the latest Android-powered device released by famed GPU … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] unlock bootloader camera red&green noise issue could be solved?

OP Mijiwo

14th February 2014, 05:37 PM   |  #1  
OP Member
Thanks Meter: 2
 
41 posts
Join Date:Joined: Oct 2012
as the title, I just got this phone for about a month so I don't know much about it. maybe someone asked the same question or has some fix but I can't find thread about this issue or maybe I just missed.
It's about after bootloader unlocked the camera takes photo with lot of red&green noise, and after restored TA this issue gone. I find that on lock bootloader when I taking a photo, It still shows a lot of R&G noise, but after I pressd the shutter, the noise didn't shows on photo or just turned to white&black. so I think maybe there is some kind of process or permission of optimization for camera in TA partitionand maybe it could fixed like BE2 without lock bootloader?
forgive my poor English and silly question
14th February 2014, 05:55 PM   |  #2  
worf_1977's Avatar
Senior Member
Flag Barcelona
Thanks Meter: 99
 
664 posts
Join Date:Joined: Jul 2011
More
By unlocking your bootloader you loose the DRM Keys, and what the hell are related to them

Sent from my C6603 using xda app-developers app
14th February 2014, 06:24 PM   |  #3  
Senior Member
Flag Jakarta
Thanks Meter: 88
 
642 posts
Join Date:Joined: Dec 2010
More
Yes, I've posted something like this before and haven't got the answer except to lock the bootloader and restore TA.

Sent from my C6603 using Tapatalk
14th February 2014, 10:18 PM   |  #4  
Senior Member
Flag singapore
Thanks Meter: 122
 
881 posts
Join Date:Joined: Jan 2013
More
So if I just lock the bootloader without restoring TA, the results will be the same as unlocked?

Sent from my C6603 using Tapatalk
15th February 2014, 01:07 AM   |  #5  
Senior Member
Flag Jakarta
Thanks Meter: 88
 
642 posts
Join Date:Joined: Dec 2010
More
Quote:
Originally Posted by joejoe23

So if I just lock the bootloader without restoring TA, the results will be the same as unlocked?

Sent from my C6603 using Tapatalk

yes. Here take a look.

http://forum.xda-developers.com/show...1&postcount=66
15th February 2014, 02:31 AM   |  #6  
worf_1977's Avatar
Senior Member
Flag Barcelona
Thanks Meter: 99
 
664 posts
Join Date:Joined: Jul 2011
More
If unlocking without a ta backup, you can say good bye to Bravia engine 2 or x-reality, unless you can manage a mod to work.

Period.

Sent from my C6603 using xda app-developers app
15th February 2014, 04:34 AM   |  #7  
OP Member
Thanks Meter: 2
 
41 posts
Join Date:Joined: Oct 2012
Quote:
Originally Posted by worf_1977

If unlocking without a ta backup, you can say good bye to Bravia engine 2 or x-reality, unless you can manage a mod to work.

Period.

Sent from my C6603 using xda app-developers app

I saw a mod to restore the BE2 and x-reality, but none to fix the camera...I don't know is that very hard to fix this issue or people on UB just don't care these...that's why I post hereI don't know how the be2 restore mod work but I think maybe camera can be fixed at same way? I like to use a customized kernel but also a good camera
15th February 2014, 07:06 AM   |  #8  
xarive's Avatar
Senior Member
Flag Georgetown, Ayer Itam
Thanks Meter: 114
 
530 posts
Join Date:Joined: Dec 2011
More
I'm on locked BL. I unlocked the bootloader before Ta backup tool exists. And yet the camera quality getting sucks day by day. Wondering what are those Sony Dev thinking by encouraging us to Dev and yet in sacrifices of some essential features.

Sent from my C6603 using Tapatalk 2
15th February 2014, 12:11 PM   |  #9  
Senior Member
Flag singapore
Thanks Meter: 122
 
881 posts
Join Date:Joined: Jan 2013
More
Quote:
Originally Posted by worf_1977

If unlocking without a ta backup, you can say good bye to Bravia engine 2 or x-reality, unless you can manage a mod to work.

Period.

Sent from my C6603 using xda app-developers app

I'm not concerned about Bravia. I'm asking about the noise.

Sent from my C6603 using Tapatalk
15th February 2014, 02:20 PM   |  #10  
fards's Avatar
Recognized Developer
Flag Currently Reverse Engineering 42
Thanks Meter: 835
 
5,682 posts
Join Date:Joined: Nov 2005
Donate to Me
More
I can't see exactly why it's happening, there's no calls to anything in the TA when pictures are taken, but it's definitely happening.

I've gone back and forth between unlocked/restored TA and there's quite a bit of noise, but the only calls are to the image processing, unless that is calling a drm that isn't there.

Post Reply Subscribe to Thread

Tags
ub camera issue noise fix
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes