Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,803,209 Members 44,413 Now Online
XDA Developers Android and Mobile Development Forum

Xperia Z bricked after restore with TWRP

Tip us?
 
Dookie1302
Old
#1  
Member - OP
Thanks Meter 5
Posts: 39
Join Date: Nov 2010
Location: Mumbai
Default Xperia Z bricked after restore with TWRP

Hey guys,
i had installed TWRP and flashed Excelsus 1.2.2 onto my phone.
Still on a locked bootloader.

When i went to restore my phone.
It restarted and is stuck on the SONY screen and the notification LED is red.

I've tried to connect it to flashtool, but it does not connect.
Tried the power + volume up button for 10 seconds [vibrates once + restarts]
Tried the power + volume up button for 15 seconds [vibrates thrice + restarts]
Tried the power + volume down button [nothing happens]

I can't shut down the phone.

and the Sony Update tool does not detect the phone.
 
Maddhouse
Old
#2  
Maddhouse's Avatar
Senior Member
Thanks Meter 77
Posts: 376
Join Date: Jul 2012
Location: West Sussex
Quote:
Originally Posted by Dookie1302 View Post
Hey guys,
i had installed TWRP and flashed Excelsus 1.2.2 onto my phone.
Still on a locked bootloader.

When i went to restore my phone.
It restarted and is stuck on the SONY screen and the notification LED is red.

I've tried to connect it to flashtool, but it does not connect.
Tried the power + volume up button for 10 seconds [vibrates once + restarts]
Tried the power + volume up button for 15 seconds [vibrates thrice + restarts]
Tried the power + volume down button [nothing happens]

I can't shut down the phone.

and the Sony Update tool does not detect the phone.
Look at pervious threads or even my last posts I help someone with the same problem earlier hours of this morning

Sent from my C6603 using xda premium
The Following User Says Thank You to Maddhouse For This Useful Post: [ Click to Expand ]
 
gire.prasad
Old
#3  
gire.prasad's Avatar
Senior Member
Thanks Meter 214
Posts: 819
Join Date: May 2011
Location: Fairborn

 
DONATE TO ME
Quote:
Originally Posted by Dookie1302 View Post
Hey guys,
i had installed TWRP and flashed Excelsus 1.2.2 onto my phone.
Still on a locked bootloader.

When i went to restore my phone.
It restarted and is stuck on the SONY screen and the notification LED is red.

I've tried to connect it to flashtool, but it does not connect.
Tried the power + volume up button for 10 seconds [vibrates once + restarts]
Tried the power + volume up button for 15 seconds [vibrates thrice + restarts]
Tried the power + volume down button [nothing happens]

I can't shut down the phone.

and the Sony Update tool does not detect the phone.
Press power + volume buttons, let it to vibrate thrice and after vibrating thrice immediately release your hand from phone or maybe you could release it while in second vibration itself, this allows the mobile to switch off. Now you can go to flashtool, connect it in flash mode and flash stock firmware. I had this problem yday and I used this method to switch it off!
Xperia arc --> Xperia Z --> Xperia Z1

The Following User Says Thank You to gire.prasad For This Useful Post: [ Click to Expand ]
 
Dookie1302
Old
#4  
Member - OP
Thanks Meter 5
Posts: 39
Join Date: Nov 2010
Location: Mumbai
sorted it out.
I don't really know what i did though.

used Flashtool to flash the stock firmware onto the phone.
still didn't start.

Plugged in my phone a couple of times.
each time i did another driver would install.

i had already installed the Flashtool drivers.

after the last driver installed, the phone started up
 
danw_oz
Old
#5  
Senior Member
Thanks Meter 198
Posts: 870
Join Date: Jul 2011
Location: Brisbane
Quote:
Originally Posted by Dookie1302 View Post
sorted it out.
I don't really know what i did though.

used Flashtool to flash the stock firmware onto the phone.
still didn't start.

Plugged in my phone a couple of times.
each time i did another driver would install.

i had already installed the Flashtool drivers.

after the last driver installed, the phone started up
Great news mate, glad you got it sorted
 
kaumba 187
Old
#6  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Oct 2013
Default bricked xperia Z

Quote:
Originally Posted by Maddhouse View Post
Look at pervious threads or even my last posts I help someone with the same problem earlier hours of this morning

Sent from my C6603 using xda premium
Hi, I seem to be having the same problem, accidently flashed the wrong kernel on my xperia Z with stock jellybean 4.3 in hopes of rooting it but now it just gets stuck on sony logo. Could you direct me to the thread where you said you helped a guy with a similar problem? Can't seem to find it..

Thanx
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes