Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,786,442 Members 40,508 Now Online
XDA Developers Android and Mobile Development Forum

Xperia Z without LCD

Tip us?
 
martis347
Old
#1  
Member - OP
Thanks Meter 2
Posts: 82
Join Date: May 2011
Location: Raseiniai,Lithuania
Default Xperia Z without LCD

Hello, I cracked digitizer of my Xperia.
So I took it apart and wanted to fix it.
I heated, took LCD and digitizer off, tried to separate them nicely, but I'm pretty sure I made a little bit of damage to LCD.
Anyway, now I wanted to try phone without screen before ordering parts (you know, maybe I damaged motherboard or something... )
So... I plug all the cables, make everything back except digitizer is off now, but LCD is on.
I try to turn it on, it vibrates and that's it. Nothing more and after waiting over 10 minutes it still doesn't show any signs of life. Plugging USB cable from PC or ac does not show any signs. I can't do anything until I unplug battery and plug it back.
If I try to stick USB cable before turning it on, red led flashes brightly and that's it. What's even more interesting, if I unplug the cable, led keeps flashing and I have to unplug battery again.
I can see green led flash for a second when holding volume up and plugging to PC and blue led keeps for long time if I plug to PC while holding volume down.

So now you know my situation, does it have to be like that or no?
Maybe there's a back signal from LCD I mean if it's not connected, phone does not work or something.

Before everything phone was working perfectly.

Hope to hear some advice, thank you.
 
androidtweaker1
Old
#2  
androidtweaker1's Avatar
Senior Member
Thanks Meter 216
Posts: 737
Join Date: May 2014
Quote:
Originally Posted by martis347 View Post
Hello, I cracked digitizer of my Xperia.
So I took it apart and wanted to fix it.
I heated, took LCD and digitizer off, tried to separate them nicely, but I'm pretty sure I made a little bit of damage to LCD.
Anyway, now I wanted to try phone without screen before ordering parts (you know, maybe I damaged motherboard or something... )
So... I plug all the cables, make everything back except digitizer is off now, but LCD is on.
I try to turn it on, it vibrates and that's it. Nothing more and after waiting over 10 minutes it still doesn't show any signs of life. Plugging USB cable from PC or ac does not show any signs. I can't do anything until I unplug battery and plug it back.
If I try to stick USB cable before turning it on, red led flashes brightly and that's it. What's even more interesting, if I unplug the cable, led keeps flashing and I have to unplug battery again.
I can see green led flash for a second when holding volume up and plugging to PC and blue led keeps for long time if I plug to PC while holding volume down.

So now you know my situation, does it have to be like that or no?
Maybe there's a back signal from LCD I mean if it's not connected, phone does not work or something.

Before everything phone was working perfectly.

Hope to hear some advice, thank you.
Its looks like a mo-bo issue for USB and LED issue. Check whether all connectors are in place.Also for digitizer issue i thing either the connector is not properly attached or the flex cable is damage.
Hit thanks if helped

“You have not lived today until you have done something for someone who can never repay you ― John Bunyan”


Current Devices
Sony Xperia Z: Dirty Unicorns
Samsung Galaxy Nexus: Dirty Unicorns
 
martis347
Old
#3  
Member - OP
Thanks Meter 2
Posts: 82
Join Date: May 2011
Location: Raseiniai,Lithuania
Any more opinions?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes