5,604,219 Members 49,300 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Xperia Z Refuses to go into flashmode

Tip us?
 
MADNJPN
Old
#1  
Senior Member - OP
Thanks Meter 37
Posts: 163
Join Date: Apr 2013
Location: Tbilisi
Info 2 [Q] Xperia Z Refuses to go into flashmode

Before posting that I'm idiot and I should have searched for the solution myself I want to say that there was no actual solution to my problem!

A month ago I decided to install CyanogenMod 10.2 because of more camera options so I backed up my TA partition, then unlocked my bootloader and installed CyanogenMod 10.2 that was perfect for me, but as official 4.3 is going to be released I decided to migrate to stock android and ran into a problem, I downloaded many FTF's for my C6602, downloaded new flashtool also all drivers are perfectly installed but when it came to loading phone into flashmode it refused to do so, I'm holding Volume down button and connecting USB into the main USB port on the PC, first I see red LED then suddenly it changes to GREEN for about half a sec and then turns off, as for Fastboot mode it works perfect I even tried flashing different kernel but it did not help, I also tried and successfully installed Android 4.4 KitKat OmniRom without problems but I still can't get into the flashmode, also I was unable to use EMMA because I did not receive confirmation e-mail. Please help... Thanks in advance.
 
MADNJPN
Old
#2  
Senior Member - OP
Thanks Meter 37
Posts: 163
Join Date: Apr 2013
Location: Tbilisi
I managed to reflash to stock .67 firmware with new flashtool but the led was not green during the installation it was off but it still got flashed, now when I reflashed my phone, I rooted it and restored my TA partition , so now I want repair it with SEUS but the problem still exists phone wont go into flashmode !!!!
 
shoey63
Old
(Last edited by shoey63; 11th December 2013 at 10:40 AM.)
#3  
shoey63's Avatar
Recognized Contributor
Thanks Meter 1241
Posts: 2,095
Join Date: Jun 2012
Location: Somewhere in Oz...
Once green led goes of and screen is black, you ARE in flashmode
Make sure flashtool prepares files BEFORE pressing volume down and plugging usb cord in.
There is no persistent led or visible screen in flashmode.

Sent from my C6603 using xda app-developers app
The Following 3 Users Say Thank You to shoey63 For This Useful Post: [ Click to Expand ]
 
MADNJPN
Old
#4  
Senior Member - OP
Thanks Meter 37
Posts: 163
Join Date: Apr 2013
Location: Tbilisi
Yea you were correct for some reason when I started updating phone with SEUS it just restarted and started update, so it seems that it really was in flash mode, but what's wrong with the led? It was always on once in flashmode ...
 
shoey63
Old
(Last edited by shoey63; 11th December 2013 at 12:23 PM.)
#5  
shoey63's Avatar
Recognized Contributor
Thanks Meter 1241
Posts: 2,095
Join Date: Jun 2012
Location: Somewhere in Oz...
Forget SUES. Just flash a stock FTF for your region. Sony won't know the difference. There's plenty out there. Which one do you want?
Edit; In flashmode, Led stays on until flashing starts then it turns off while system is being flashed.. In the case of PC companion or SUS, it will take considerably longer while files are downloaded, but with flashtool, the files are already in place, so it goes off almost instantaneously
Sent from my C6603 using xda app-developers app
The Following User Says Thank You to shoey63 For This Useful Post: [ Click to Expand ]
 
MADNJPN
Old
#6  
Senior Member - OP
Thanks Meter 37
Posts: 163
Join Date: Apr 2013
Location: Tbilisi
Thanks again, no I just wanted to get BE back Thanks to guy who invented TA partition backup : )
The Following User Says Thank You to MADNJPN For This Useful Post: [ Click to Expand ]
 
shoey63
Old
#7  
shoey63's Avatar
Recognized Contributor
Thanks Meter 1241
Posts: 2,095
Join Date: Jun 2012
Location: Somewhere in Oz...
+1
That's a brilliant tool.
Just be sure to be on stock, rooted, with USB debugging on, and superuser accepting adb shell command while restoring:thumbup:

Sent from my C6603 using xda app-developers app
 
Onmehedson
Old
#8  
Member
Thanks Meter 13
Posts: 47
Join Date: Jan 2013
Location: Swansea
Quote:
Originally Posted by shoey63 View Post
Once green led goes of and screen is black, you ARE in flashmode
Make sure flashtool prepares files BEFORE pressing volume down and plugging usb cord in.
There is no persistent led or visible screen in flashmode.

Sent from my C6603 using xda app-developers app
Just wanted to say I was a bit worried my xz was not in flashmode the first time I flashed un-branded firmware as the led did not stay lit..

When I used to flash my old Arc S the light would remain on until flashing finished...

Thanx for confirming this !!
 
FinalSurrender
Old
#9  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: Dec 2012
Default Different Problem with Flashmode

Can someone please help me, When I unlocked my bootloader (Xperia Z) I didn't use flashtools. I used SE Bootloader Unlocking, this software worked well for my Tipo and S. What happened is that my bootloader got unlocked but my flashmode got corrupted. Fastboot works fine. But when I try to get into Flashmode, the green LED blinks for like a second and nothing happens. Does anyone know how I can fix this? Please Please help me? I can't update my Baseband to go to 4.3.
I wouldn't mind relocking my bootloader to go back to stock, but I need flashmode to this as well!
 
shoey63
Old
(Last edited by shoey63; 5th April 2014 at 02:51 PM.)
#10  
shoey63's Avatar
Recognized Contributor
Thanks Meter 1241
Posts: 2,095
Join Date: Jun 2012
Location: Somewhere in Oz...
That's how it works on The Z. Nothing to worry about
Just let flashtool prepare the files , then plug in to pc holding volume down
Sent from my C6603 using xda app-developers app

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes