Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,771,243 Members 53,266 Now Online
XDA Developers Android and Mobile Development Forum

[Q] New Xperia Z stuttering issue

Tip us?
 
kristianity1977
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 1
Join Date: Mar 2013
Default [Q] New Xperia Z stuttering issue

Hey all

Ive had my XZ now for a few days and i'm over the moon with it. I was worried reading reviews and opinions on the screen etc but I really think its great. I have one small issue with it that I just wanted to know if it was normal, or if indeed I might have an issue somewhere.

Now, I've never used this project butter android before, but flicking between menus gives quite frequent "jumps" in the animation as soon on older android operating systems. Also, if I play any games, even basic 2D ones, I still get the hiccups in the frame rates. IE ill get a couple of seconds of it being totally smooth, and then a hiccup where it jumps a few frames. Its not a deal breaker, but it is annoying.

Now, if I put the phone into airplane mode, then everything runs absolutely smooth, no hiccups in the UI, and games run absolutely flawlessly.

Is this normal, or should it still run totally smooth regardless of settings?

when not in Airplane mode, i checked with WIFI on and off, Mobile data On and off also. Bluetooth is always off, and so is NFC. The issue only seems to resolve itself in Airplane mode.

Can anyone help with this issue, or is it normal for this phone?

Thanks in advance
 
indycar
Old
#2  
indycar's Avatar
Senior Member
Thanks Meter 72
Posts: 504
Join Date: Apr 2010
Location: Bohinjska Bela
everything should run smooth

do you run those games from older Sd card (class 2 or 4)

maybe you should do factory reset and check if everything works like it should or repair via SEUS (sony update service)
 
Retxud
Old
#3  
Junior Member
Thanks Meter 3
Posts: 22
Join Date: Mar 2013
Did you do a fresh install of the apps or did you restore them from a previous phone using titanium?
 
kristianity77
Old
#4  
Member
Thanks Meter 1
Posts: 36
Join Date: Oct 2011
There is currently no SD card installed so everything is coming off the interal memory.

I havent done a reset or anything as I didnt think of that seeing as it was new out the box and only a few days old.

All the apps that I had previously or had bought I just redownloaded from Google Play.
 
xiaopai89
Old
#5  
Junior Member
Thanks Meter 18
Posts: 22
Join Date: Mar 2013
Quote:
Originally Posted by kristianity1977 View Post
Hey all

Ive had my XZ now for a few days and i'm over the moon with it. I was worried reading reviews and opinions on the screen etc but I really think its great. I have one small issue with it that I just wanted to know if it was normal, or if indeed I might have an issue somewhere.

Now, I've never used this project butter android before, but flicking between menus gives quite frequent "jumps" in the animation as soon on older android operating systems. Also, if I play any games, even basic 2D ones, I still get the hiccups in the frame rates. IE ill get a couple of seconds of it being totally smooth, and then a hiccup where it jumps a few frames. Its not a deal breaker, but it is annoying.

Now, if I put the phone into airplane mode, then everything runs absolutely smooth, no hiccups in the UI, and games run absolutely flawlessly.

Is this normal, or should it still run totally smooth regardless of settings?

when not in Airplane mode, i checked with WIFI on and off, Mobile data On and off also. Bluetooth is always off, and so is NFC. The issue only seems to resolve itself in Airplane mode.

Can anyone help with this issue, or is it normal for this phone?

Thanks in advance

Yeah, me too. I was playing Temple Run OZ and the phone get really warm and it began to show frames and lag
 
kristianity77
Old
#6  
Member
Thanks Meter 1
Posts: 36
Join Date: Oct 2011
Well in the end, to get around the "oh so not smooth" Sony UI, i went with a different launcher called Apex. Now its running as expected. I hope the impending update to 4.2 solves these issues as its a bit rubbish to have lags and skips on a phone this powerful. But I might just keep with the alternate launcher anyway
 
x102x96x
Old
#7  
x102x96x's Avatar
Senior Member
Thanks Meter 278
Posts: 1,272
Join Date: May 2012
Location: Linux

 
DONATE TO ME
Quote:
Originally Posted by kristianity77 View Post
Well in the end, to get around the "oh so not smooth" Sony UI, i went with a different launcher called Apex. Now its running as expected. I hope the impending update to 4.2 solves these issues as its a bit rubbish to have lags and skips on a phone this powerful. But I might just keep with the alternate launcher anyway
it happens for all phone
little bit lagy UI
don't worry about sony UI
i saw this problem in all android phones from htc, samsung & sony
it should be fixed but even ur PC have little bit lag when using it alot
 
Java.Symbian.WP8.iOS4/5/6/7
Android; Fy \GB \ICS \JB \KK \CustomROM
Devices; Nexus \Xperia \Galaxy \LG \htc \Lenovo
./Android-Ubuntu Programming


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes