FORUMS

New Xposed for Lollipop 5.0 Update Fixes Major Bugs

Senior Recognized Developer rovo89 has patched Xposed for Lollipop 5.0 to … more

Download Sony’s new AOSP-like concept for Xperia Z3

Over in our forums, Recognized Contributor Jozinek has posted a very … more

OnePlus 2 vs Moto X Style: Which is The Better Flagship?

Two big industry names have announced their newest flagship phones within the … more

Making Your Own Xposed Modules Is Easier Than You Think

Close to the heart of XDA is the Xposed Framework by Rovo89. Most of … more

Xperia Z T-Mobile ROM

140 posts
Thanks Meter: 14
 
By DarkLP, Senior Member on 18th March 2014, 03:09 AM
Post Reply Subscribe to Thread Email Thread
19th March 2014, 05:50 PM |#11  
Senior Member
Thanks Meter: 20
 
More
TMo will probably be further behind than that as we don't even have an official 4.3 yet.

Thanks for the instructions. That's exactly what I have been looking for. I'll give that a shot asap, when I get the courage to flash the phone. Probably the next day our two.

Sent from my C6606 using Tapatalk
 
 
20th March 2014, 09:51 AM |#12  
Knucklessg1's Avatar
Senior Member
Thanks Meter: 81
 
More
What are the chances of porting the Z1 4.4 update to our Zs?

Sent from my C6603 using xda app-developers app
20th March 2014, 11:28 PM |#13  
tg2012's Avatar
Senior Member
Flag Boston
Thanks Meter: 12
 
More
Quote:
Originally Posted by Dhickory

This one should be good to go http://forum.xda-developers.com/xper...-2-67-t2512422
Flashtool instructions (follow just as it says, baseband and all) - http://forum.xda-developers.com/xper...-roms-t2240614

Root http://forum.xda-developers.com/xper...3-1-0-t2386405

Recovery http://forum.xda-developers.com/show....php?t=2261606

Update to .569 http://forum.xda-developers.com/xper...0-569-t2565850
Update to .101 http://forum.xda-developers.com/xper...0-101-t2643898
Flash custom stock ROM of your choice. There may be an easier way than this, but this is the route I have taken and all has worked well.

T-mobile APN's for 3G/4G/LTE. I input these every time I clean flash. I confirmed these settings with a friends moto x that is completely stock http://forum.xda-developers.com/show....php?t=2236735 4G will actually show as H+ by the signal bars.

If you run into any problems let me know and I'll try to help. Just take your time and follow all instructions. It's well worth it rather than waiting on t-mobile to push our updates, especially now that KK has been officially announced for Q2 (hopefully May). T-mobile will probably be another 2-3 months behind that.

Yeah I tried doing this method and now I'm stuck in the boot loop at the sony logo screen. Still not giving up though, am I suppose to flash Update to .101 after or before installation of the rom. I installed the rom prior and now my phone is stuck in bootloop.. I tried using Sony recovery and flash tool to get it back, but it wont recognize my phone and if it does its for a second. I can get it in fastboot mode and CWM and that's it..now I'm stuck AGAIN atm..

---------- Post added at 11:28 PM ---------- Previous post was at 11:07 PM ----------

Somehow I was able to get and keep it in flashmode and flash the whole firmware C6603_10.3.1.A.2.67_Generic UK. Looks like I'm back from start one! So again, am I suppose to flash .101 before or after the rom is installed?
Last edited by tg2012; 20th March 2014 at 11:16 PM.
21st March 2014, 04:30 AM |#14  
Dhickory's Avatar
Senior Member
Thanks Meter: 54
 
More
To be on the safe side make sure you install everything in the order that I posted them following instructions. Work your way to the .101 pre-rooted ROM.

When you get to the .101 ROM
flash .zip provided in recovery
Do not reboot after flashing .zip, in twrp go to power off
Then flash everything in the .ftf with flashtool
Reboot and you should be good.

Also make sure you have the latest flashtool and drivers loaded. Never hurts to check the obvious too like USB debugging..

Sent from my ASUS Transformer Pad TF300T using xda app-developers app
Last edited by Dhickory; 21st March 2014 at 04:45 AM.
The Following 2 Users Say Thank You to Dhickory For This Useful Post: [ View ]
21st March 2014, 05:53 AM |#15  
tg2012's Avatar
Senior Member
Flag Boston
Thanks Meter: 12
 
More
Thanks it's completed now I got it! Wicked cool features on this.. Now I'm going to read around and get to know all this a little better now that I got this working. .
21st March 2014, 11:27 PM |#16  
Junior Member
Thanks Meter: 0
 
More
What steps in the process would I have to omit if I dont want to root and just want to flash 4.3, Also there seems to be many versions of 4.3 such as UK unbranded Ch unbranded. If I'm using it for Tmobile US, which would I choose?
22nd March 2014, 12:59 AM |#17  
Junior Member
Thanks Meter: 0
 
More
Never mind! Used the UK unbranded and I love it! everything worked nicely! thanks so much for this!
22nd March 2014, 02:09 AM |#18  
Dhickory's Avatar
Senior Member
Thanks Meter: 54
 
More
Quote:
Originally Posted by tg2012

Thanks it's completed now I got it! Wicked cool features on this.. Now I'm going to read around and get to know all this a little better now that I got this working. .




Quote:
Originally Posted by knicks20828

Never mind! Used the UK unbranded and I love it! everything worked nicely! thanks so much for this!

Glad to see everyone got where they wanted. :beer::beer:

Sent from my ASUS Transformer Pad TF300T using xda app-developers app
22nd March 2014, 07:07 PM |#19  
Junior Member
Thanks Meter: 0
 
More
Hey man yeah everything seems to be perfect except for the MMS aspect of my messages. I can't seem to download the MMS messages, the default texting app keeps telling me that "Could not download message. Check settings for multimedia messages and try again later" I tried the APN settings to the forum you directed us too but that's not working =(
22nd March 2014, 10:27 PM |#20  
Dhickory's Avatar
Senior Member
Thanks Meter: 54
 
More
Quote:
Originally Posted by knicks20828

Hey man yeah everything seems to be perfect except for the MMS aspect of my messages. I can't seem to download the MMS messages, the default texting app keeps telling me that "Could not download message. Check settings for multimedia messages and try again later" I tried the APN settings to the forum you directed us too but that's not working =(


Make sure the APN you created is selected and then reboot after.

Make sure LTE (preferred) is selected.

Once verified APN is selected and reboot, go to MMS and long press picture, select download. It should DL after that.

If that doesn't work you can also try to "Service Providers" and there should be an option for a T-Mobile network.

Can also try turning on/off airplane mode, but the APN always works for me.

Sent from my C6603 using xda app-developers app
Last edited by Dhickory; 22nd March 2014 at 10:33 PM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes