Document the Story of Your Social Life with 8tory

The different forms of social media are growing every day. It’s hard to imagine a day … more

Make Calling Your Loved Ones Easier and Cheaper this Diwali

Diwali, or Deepawali as some Indians call it, is the pride and joy of Indian … more

Big Android BBQ 5.0 Recap – XDA TV

This fifth annual Big Android BBQ has come and gone. The speakers have spoke, the sponsors have … more

Microsoft to Counter “OK Google” with Bing Torque

When Microsoft is making apps for Android, users should be aware that something … more
Post Reply

Xperia Z T-Mobile ROM

OP DarkLP

19th March 2014, 05:50 PM   |  #11  
Senior Member
Thanks Meter: 9
 
147 posts
Join Date:Joined: Apr 2012
More
TMo will probably be further behind than that as we don't even have an official 4.3 yet.

Thanks for the instructions. That's exactly what I have been looking for. I'll give that a shot asap, when I get the courage to flash the phone. Probably the next day our two.

Sent from my C6606 using Tapatalk
20th March 2014, 09:51 AM   |  #12  
Knucklessg1's Avatar
Senior Member
Thanks Meter: 78
 
455 posts
Join Date:Joined: Mar 2010
More
What are the chances of porting the Z1 4.4 update to our Zs?

Sent from my C6603 using xda app-developers app
20th March 2014, 11:28 PM   |  #13  
Senior Member
Flag Boston
Thanks Meter: 11
 
124 posts
Join Date:Joined: Mar 2012
More
Quote:
Originally Posted by Dhickory

This one should be good to go http://forum.xda-developers.com/xper...-2-67-t2512422
Flashtool instructions (follow just as it says, baseband and all) - http://forum.xda-developers.com/xper...-roms-t2240614

Root http://forum.xda-developers.com/xper...3-1-0-t2386405

Recovery http://forum.xda-developers.com/show....php?t=2261606

Update to .569 http://forum.xda-developers.com/xper...0-569-t2565850
Update to .101 http://forum.xda-developers.com/xper...0-101-t2643898
Flash custom stock ROM of your choice. There may be an easier way than this, but this is the route I have taken and all has worked well.

T-mobile APN's for 3G/4G/LTE. I input these every time I clean flash. I confirmed these settings with a friends moto x that is completely stock http://forum.xda-developers.com/show....php?t=2236735 4G will actually show as H+ by the signal bars.

If you run into any problems let me know and I'll try to help. Just take your time and follow all instructions. It's well worth it rather than waiting on t-mobile to push our updates, especially now that KK has been officially announced for Q2 (hopefully May). T-mobile will probably be another 2-3 months behind that.

Yeah I tried doing this method and now I'm stuck in the boot loop at the sony logo screen. Still not giving up though, am I suppose to flash Update to .101 after or before installation of the rom. I installed the rom prior and now my phone is stuck in bootloop.. I tried using Sony recovery and flash tool to get it back, but it wont recognize my phone and if it does its for a second. I can get it in fastboot mode and CWM and that's it..now I'm stuck AGAIN atm..

---------- Post added at 11:28 PM ---------- Previous post was at 11:07 PM ----------

Somehow I was able to get and keep it in flashmode and flash the whole firmware C6603_10.3.1.A.2.67_Generic UK. Looks like I'm back from start one! So again, am I suppose to flash .101 before or after the rom is installed?
Last edited by tg2012; 20th March 2014 at 11:16 PM.
21st March 2014, 04:30 AM   |  #14  
Dhickory's Avatar
Senior Member
Thanks Meter: 47
 
157 posts
Join Date:Joined: Jul 2010
More
To be on the safe side make sure you install everything in the order that I posted them following instructions. Work your way to the .101 pre-rooted ROM.

When you get to the .101 ROM
flash .zip provided in recovery
Do not reboot after flashing .zip, in twrp go to power off
Then flash everything in the .ftf with flashtool
Reboot and you should be good.

Also make sure you have the latest flashtool and drivers loaded. Never hurts to check the obvious too like USB debugging..

Sent from my ASUS Transformer Pad TF300T using xda app-developers app
Last edited by Dhickory; 21st March 2014 at 04:45 AM.
The Following 2 Users Say Thank You to Dhickory For This Useful Post: [ View ]
21st March 2014, 05:53 AM   |  #15  
Senior Member
Flag Boston
Thanks Meter: 11
 
124 posts
Join Date:Joined: Mar 2012
More
Thanks it's completed now I got it! Wicked cool features on this.. Now I'm going to read around and get to know all this a little better now that I got this working. .
21st March 2014, 11:27 PM   |  #16  
Junior Member
Thanks Meter: 0
 
12 posts
Join Date:Joined: Sep 2013
More
What steps in the process would I have to omit if I dont want to root and just want to flash 4.3, Also there seems to be many versions of 4.3 such as UK unbranded Ch unbranded. If I'm using it for Tmobile US, which would I choose?
22nd March 2014, 12:59 AM   |  #17  
Junior Member
Thanks Meter: 0
 
12 posts
Join Date:Joined: Sep 2013
More
Never mind! Used the UK unbranded and I love it! everything worked nicely! thanks so much for this!
22nd March 2014, 02:09 AM   |  #18  
Dhickory's Avatar
Senior Member
Thanks Meter: 47
 
157 posts
Join Date:Joined: Jul 2010
More
Quote:
Originally Posted by tg2012

Thanks it's completed now I got it! Wicked cool features on this.. Now I'm going to read around and get to know all this a little better now that I got this working. .




Quote:
Originally Posted by knicks20828

Never mind! Used the UK unbranded and I love it! everything worked nicely! thanks so much for this!

Glad to see everyone got where they wanted. :beer::beer:

Sent from my ASUS Transformer Pad TF300T using xda app-developers app
22nd March 2014, 07:07 PM   |  #19  
Junior Member
Thanks Meter: 0
 
12 posts
Join Date:Joined: Sep 2013
More
Hey man yeah everything seems to be perfect except for the MMS aspect of my messages. I can't seem to download the MMS messages, the default texting app keeps telling me that "Could not download message. Check settings for multimedia messages and try again later" I tried the APN settings to the forum you directed us too but that's not working =(
22nd March 2014, 10:27 PM   |  #20  
Dhickory's Avatar
Senior Member
Thanks Meter: 47
 
157 posts
Join Date:Joined: Jul 2010
More
Quote:
Originally Posted by knicks20828

Hey man yeah everything seems to be perfect except for the MMS aspect of my messages. I can't seem to download the MMS messages, the default texting app keeps telling me that "Could not download message. Check settings for multimedia messages and try again later" I tried the APN settings to the forum you directed us too but that's not working =(


Make sure the APN you created is selected and then reboot after.

Make sure LTE (preferred) is selected.

Once verified APN is selected and reboot, go to MMS and long press picture, select download. It should DL after that.

If that doesn't work you can also try to "Service Providers" and there should be an option for a T-Mobile network.

Can also try turning on/off airplane mode, but the APN always works for me.

Sent from my C6603 using xda app-developers app
Last edited by Dhickory; 22nd March 2014 at 10:33 PM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes