Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,743,150 Members 44,055 Now Online
XDA Developers Android and Mobile Development Forum

XPeria Z won't turn on and LED doing strange patterns

Tip us?
 
S.P.F
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jan 2014
Post XPeria Z won't turn on and LED doing strange patterns

Hello !

My problem is a bit long to explain, but I'll try to make it short ^^

So, at the beginning, I think the problem is about water resistance, because I put it in water with all the covers closed but when I took it back, the jack's "white thing" turned red and so did the others as well (even if I don't know how it happened).

From that moment, I began to try a lot of things, like charging it, connecting it to the computer, put it in rice during one night, etc... In order to dry it and to see how it's reacting, and here is the differents "states" I noticed:

-when it was charging with the wall charger, the red LED was blinking regularly
-when I connected it to my computer, the red LED turned on, my computer made the connected sound, the LED turned off 2 seconds after, and 10seconds after it went on again with the disconnected sound and the connected sound again and repeating (disconnected - LED on - connected - 2sec - LED off - 10sec)
-it wasn't doing that usually but it did it one time; red LED blinking without any connection to anything ( blinking 2 times every 2 seconds)
-and nothing was happening with the dock

At the moment I'm writing, it's acting a bit different:

-nothing's happening whithout connection
-when charging to the wall charger or the dock, it vibrates 1 time, red LED turning on, waiting 4 seconds, vibrating 3 times pretty fast, then the LED is turning off and it repeats a dozen of seconds right after that. (a bit like that - --- - --- - --- - --- - ---)
-when it's connected to the computer, it's now doing the connected and disconnected sound without stopping just like somebody is playing with the USB

I tried to press any button at any state, but I did'nt noticed anything changing.

I think that's all.

So if you have any idea about what's happening to my phone, please tell me

Thank you !
 
kingvortex
Old
#2  
kingvortex's Avatar
Senior Member
Thanks Meter 1919
Posts: 2,906
Join Date: Mar 2010
Location: Nottingham
...
It's water damaged and needs sending for repair. Red LED indicates a hardware error.
There is nothing you can do yourself to repair it.

Sent from my Hudl HT7S3 using Tapatalk 4
 
S.P.F
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jan 2014
So, yesterday, I brought it to a repairer but instantly when he saw that the "little squares" were red, he told me that there's nothing to do, end of discussion.
I came back home a bit sad because I knew I had to buy a new phone but then, this morning, I was in a mood like "I don't give a f***" so I put it in charge and I tried hard with the Power Button, and the Vol+/- when suddendly, I saw the screen blinking during one short moment. Then, I tried again and I finally saw the "Charging screen" but the screen was going on and off. I waited a bit and it turned on by itself, and it went until the PIN-code phase but there again, the screen was turning on and off repeatedly, and, trying hard again with the buttons, I managed to go until the homescreen, but seeing the screen turning on and off again with sometimes the menu to power off the phone/restart/etc... I realised that the real problem was about the buttons ! So I turned it off ( trying to press the button rapidly before the screen do it again) and now I finally understood evrything ! When it was doing the strange patterns with the LED and the vibrations, it was because there is some problem in the contact with the buttons (it was turning on and resetting by itself because of this).

Now that we finally know what the problem is, have you got an idea about how to solve it ? Do you think there is still some water around the buttons and that I should try to dry it again (and how in that case ? Rice ? Hair-dryer ?) ? Or will the buttons stay like that even without water remaining ? In that case, do you have any solution ?

Thanks again !
 
keringkien
Old
#4  
Junior Member
Thanks Meter 0
Posts: 15
Join Date: Dec 2013
You can buy all the replacement buttons on ebay if you are confident enough, it seems that you're warranty has been voided by the water so that's out of the question. I would suggest buying a new battery at the same time.
 
antonili
Old
#5  
Junior Member
Thanks Meter 0
Posts: 17
Join Date: Mar 2007
replace the battery ..
Quote:
Originally Posted by S.P.F View Post
So, yesterday, I brought it to a repairer but instantly when he saw that the "little squares" were red, he told me that there's nothing to do, end of discussion.
I came back home a bit sad because I knew I had to buy a new phone but then, this morning, I was in a mood like "I don't give a f***" so I put it in charge and I tried hard with the Power Button, and the Vol+/- when suddendly, I saw the screen blinking during one short moment. Then, I tried again and I finally saw the "Charging screen" but the screen was going on and off. I waited a bit and it turned on by itself, and it went until the PIN-code phase but there again, the screen was turning on and off repeatedly, and, trying hard again with the buttons, I managed to go until the homescreen, but seeing the screen turning on and off again with sometimes the menu to power off the phone/restart/etc... I realised that the real problem was about the buttons ! So I turned it off ( trying to press the button rapidly before the screen do it again) and now I finally understood evrything ! When it was doing the strange patterns with the LED and the vibrations, it was because there is some problem in the contact with the buttons (it was turning on and resetting by itself because of this).

Now that we finally know what the problem is, have you got an idea about how to solve it ? Do you think there is still some water around the buttons and that I should try to dry it again (and how in that case ? Rice ? Hair-dryer ?) ? Or will the buttons stay like that even without water remaining ? In that case, do you have any solution ?

Thanks again !
 
JamesDudang
Old
(Last edited by JamesDudang; 1st June 2014 at 03:40 AM.) Reason: wrong information
#6  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Jun 2014
Default How is it now?

Quote:
Originally Posted by S.P.F View Post
So, yesterday, I brought it to a repairer but instantly when he saw that the "little squares" were red, he told me that there's nothing to do, end of discussion.
I came back home a bit sad because I knew I had to buy a new phone but then, this morning, I was in a mood like "I don't give a f***" so I put it in charge and I tried hard with the Power Button, and the Vol+/- when suddendly, I saw the screen blinking during one short moment. Then, I tried again and I finally saw the "Charging screen" but the screen was going on and off. I waited a bit and it turned on by itself, and it went until the PIN-code phase but there again, the screen was turning on and off repeatedly, and, trying hard again with the buttons, I managed to go until the homescreen, but seeing the screen turning on and off again with sometimes the menu to power off the phone/restart/etc... I realised that the real problem was about the buttons ! So I turned it off ( trying to press the button rapidly before the screen do it again) and now I finally understood evrything ! When it was doing the strange patterns with the LED and the vibrations, it was because there is some problem in the contact with the buttons (it was turning on and resetting by itself because of this).

Now that we finally know what the problem is, have you got an idea about how to solve it ? Do you think there is still some water around the buttons and that I should try to dry it again (and how in that case ? Rice ? Hair-dryer ?) ? Or will the buttons stay like that even without water remaining ? In that case, do you have any solution ?

Thanks again !
yeah i think my problem is buttons too.. after i wash it, with flaps closed tightly, my volume indicator increases automatically and constantly.. and after a while it will take a rest and annoy me again.. my power button doesnt respond too.. until it opened in safe mode.. to cut it short, my phone wont boot and whenever i charge it it vibrates with a pattern 1 short and long stop and 3 short and so on

i think the buttons is pressing power button and volume up by itself when it is charged.. pls help
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Count Cells Like a Pro with White Coat Buddy

There are times when we need to use our devices for things other than playing games, checking … more

Slide Dial Replacement Dialer Lets You Make Calls from Anywhere

If you frequently make phone calls, your dialer (aka phone app)is one of the … more

Navigate with Your Samsung Gear 2 Using DMA Navi Watch

Whether you’re travelling to a new destination or exploring some previously … more