Unhappy Can anyone build a pure AOSP for Z1?

Need 4.4.2.
I tried to build it but failed
I need AOSP 4.4.2 to build MIUI 4.4 , There are so many rejects to patch if I use Official 4.4.4, 4.4.2 or CM.
HELLLLLLLLP!:cryin g: