FORUMS

Top Forum Discussions

[Q] USB port Disabled | Not Charging

6 posts
Thanks Meter: 0
 
By yadu11384, Junior Member on 28th August 2014, 11:07 AM
Post Reply Subscribe to Thread Email Thread
I connected my z1 on charging after taking few clicks underwater. I saw flickering in charging and got message saying charging paused. After few time, it showed me red warning triangle saying USB disable due too high voltage. After that my usb port has stopped working completely. Neither it's charging nor getting detected on PC. Meanwhile magnetic charging is still functional.

Does anyone know how to enable usb port again??
Last edited by yadu11384; 28th August 2014 at 11:19 AM.
 
 
29th August 2014, 09:06 AM |#2  
OP Junior Member
Thanks Meter: 0
 
More
help please...
29th August 2014, 06:24 PM |#3  
olokos's Avatar
Recognized Contributor
Flag Warsaw
Thanks Meter: 1,967
 
Donate to Me
More
I guess that the water got into the device and there was a short circuit because of that. I guess that you've fried your USB port. I'd get it on a warranty and prey that they would accept it. If they don't then either replace it yourself or get it on repairs. Authorized Sony service is one of the best I guess, but do read the opinions about a particular service because there are many different services.
29th August 2014, 09:38 PM |#4  
abo hani's Avatar
Recognized Contributor
Flag Latakia
Thanks Meter: 2,866
 
Donate to Me
More
Put the phone in rice bag for 6 hours and open all ports.
After that it should be fixed.

Sent from my C6903 using Tapatalk
1st September 2014, 10:28 AM |#5  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by olokos

I guess that the water got into the device and there was a short circuit because of that. I guess that you've fried your USB port. I'd get it on a warranty and prey that they would accept it. If they don't then either replace it yourself or get it on repairs. Authorized Sony service is one of the best I guess, but do read the opinions about a particular service because there are many different services.

I went to sony service center. they are not repairing it under warranty bcoz of water damage. they are asking for 80% of original price for giving new handset with 1 yr warranty.
Last edited by yadu11384; 1st September 2014 at 10:34 AM.
1st September 2014, 10:36 AM |#6  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by abo hani

Put the phone in rice bag for 6 hours and open all ports.
After that it should be fixed.

Sent from my C6903 using Tapatalk

i put the phone in bright sunlight for 2hrs n also used hair dryer bt still no response in usb port.
1st September 2014, 10:41 AM |#7  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by olokos

I guess that the water got into the device and there was a short circuit because of that. I guess that you've fried your USB port. I'd get it on a warranty and prey that they would accept it. If they don't then either replace it yourself or get it on repairs. Authorized Sony service is one of the best I guess, but do read the opinions about a particular service because there are many different services.

can be it bcoz of software rather hardware problem? I got the error warning message that disabling USB port due too high voltage. Does android have some security/safety program that block the usb port on facing issue?
1st September 2014, 10:56 AM |#8  
OP Junior Member
Thanks Meter: 0
 
More
after litle research, I found that there is overcharging protection chip.
Quote:

S-8205A/B Series Applications-Optimized-Battery-Protection Circuits.
All contained voltage detectors are of high precision between 15mV and 100mV depending on the function. Overcharge detection voltage is 3.55V..4.4V with 25mV accuracy. Overdischarge detection voltage is 2.0V..3.2V with 80mV accuracy. Discharge overcurrent detection voltage is 0.05V..0.3V with 15mV accuracy and charge overcurrent detection voltage is -0.05V..-0.3V with 30mV accuracy. The detection voltage in short circuit case is 0.5V..1.0V with 100mV accuracy.

somebody know how to enable it?
Last edited by yadu11384; 1st September 2014 at 11:02 AM.
6th September 2014, 12:05 AM |#9  
abo hani's Avatar
Recognized Contributor
Flag Latakia
Thanks Meter: 2,866
 
Donate to Me
More
If you didn't root it / unlock its bl , take to to Sony Service Center

Sent from my C6903 using Tapatalk
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes