Should You Get Wear? Wearer’s Practical Observations

Wear is said to not offer enough for mass adoption, even though its been in … more

SlimRoms: Updates on the Horizon

SlimRoms’ website has been experiencing technical difficulties for the last month or so, but … more

Your Favorite Wireless Charger?

Wireless charging is becoming more and more common as many OEMs are now starting to include this feature … more

ASUS US Invites Developers at XDA to Special Event

ASUS has built a solid name over the years for their computer components, but in the … more
Post Reply Subscribe to Thread Email Thread

[Q] faulty screen? lots of green dots and specs

8th March 2015, 12:24 AM   |  #31  
Senior Member
Thanks Meter: 43
 
484 posts
Join Date:Joined: Oct 2013
More
I have the exact same problem gonna send it off when I got the time mine has green blue and red pixels all over and one completely dead near the bottom left i sent my old water damaged xperia z before all went well so should with this hope to get it fix soon
13th March 2015, 09:54 PM   |  #32  
HarpingOn's Avatar
Senior Member
Thanks Meter: 61
 
293 posts
Join Date:Joined: Oct 2010
Quote:
Originally Posted by martinbowden

No mines been fine still struggling with random restarts but have turned off auto updates today and hasn't played up yet lol let me know how it goes with screen

Martin

Got the tablet back today, posting this on it. New screen, and no dots. Looks different. I mean, the screen just looks... Different. Can't put my finger on it, might be a different kind or manufacturer of panel?

Going well so far, I'm in full on fiddling mode whilst I get it all set back up
25th March 2015, 04:05 PM   |  #33  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Mar 2015
Quote:
Originally Posted by HarpingOn

Got the tablet back today, posting this on it. New screen, and no dots. Looks different. I mean, the screen just looks... Different. Can't put my finger on it, might be a different kind or manufacturer of panel?

Going well so far, I'm in full on fiddling mode whilst I get it all set back up

Hi,
I got the same green/blue dots a while back.
Sendt the device back to sony for repair. They now claim that the cause of the stuck pixels are pressure made on the screen, and it's my fault.
This is not the case.
Did you get a description of what they did? Something I can use in my case towards Sony?
26th March 2015, 06:51 AM   |  #34  
Junior Member
Thanks Meter: 2
 
29 posts
Join Date:Joined: Jul 2012
Which country are you in?
Sony seem to have differing attitudes to screen issues in some countries.
I know in Australia they will not service screen problems at all, saying they are user caused.
26th March 2015, 09:24 AM   |  #35  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Mar 2015
Quote:
Originally Posted by wooly1

Which country are you in?
Sony seem to have differing attitudes to screen issues in some countries.
I know in Australia they will not service screen problems at all, saying they are user caused.

Im in Norway.
Is there any chance this can be caused by presshure on the screen?
26th March 2015, 11:35 AM   |  #36  
Junior Member
Thanks Meter: 2
 
29 posts
Join Date:Joined: Jul 2012
I don't know, but that will be Sony's response and probably wont be covered by warranty.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes