Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,742,782 Members 38,422 Now Online
XDA Developers Android and Mobile Development Forum

[Q] WiFi issues?

Tip us?
 
DeadlyDazza
Old
#1  
DeadlyDazza's Avatar
Senior Member - OP
Thanks Meter 78
Posts: 623
Join Date: Jul 2010
Default [Q] WiFi issues?

Anybody have any issues with wifi?
My XZ2 will often time out trying to get an ip address from my router, or it will connect with a strong signal but be marked as limited connectivity (basically rendering the tablet offline).
Most times a reboot of the XZ2 resolves it but it is a bit of a ball ache.
Never have this issue with any of the various wifi devices we use in the house.
TIA.
 
SANGER_A2
Old
#2  
Member
Thanks Meter 12
Posts: 88
Join Date: Aug 2009
Me too. After the tablet has been on for a while and has gone to sleep and been woken a few times it will not reconnect to my wifi. A reboot will fix it
I've tried using static IP settings and not had the issue again yet. Everything else on the network works fine.
 
DeadlyDazza
Old
#3  
DeadlyDazza's Avatar
Senior Member - OP
Thanks Meter 78
Posts: 623
Join Date: Jul 2010
That's exactly the same here. Oh well. It's not that bad that I want to return it but it is a pain.
 
degraaff
Old
#4  
Senior Member
Thanks Meter 9
Posts: 111
Join Date: Jan 2012
I used to have the problem with my old Xperia tablet S, and it only happened when wifi was set to stay on during device sleep. The problem went away when I set wifi to turn off when device sleeps.
Haven't had this issue on Z2 tablet. Have you tried toggling wifi optimization in advanced wifi settings? Toggled extended standby in stamina mode settings? Disabled any system apps that may affect wifi connectivity?
 
SANGER_A2
Old
#5  
Member
Thanks Meter 12
Posts: 88
Join Date: Aug 2009
I have stamina mode turn wifi off during sleep. I've always had my Android devices set to turn it off when sleeping and won't be changing that as it's just a waste of energy. I assume this is a software error that Sony will eventually fix.
 
ranf
Old
#6  
Member
Thanks Meter 7
Posts: 34
Join Date: May 2012
Which firmware version do you guys have?

IIRC I had that with the firmware that it came with (17.1.A.2.36)

Settings | Wifi
switch to the right. After a while it just switches back off?

Fixed for me with firmware 17.1.1.A.0.402 (SGP511).
 
DeadlyDazza
Old
#7  
DeadlyDazza's Avatar
Senior Member - OP
Thanks Meter 78
Posts: 623
Join Date: Jul 2010
Quote:
Originally Posted by ranf View Post
Which firmware version do you guys have?

IIRC I had that with the firmware that it came with (17.1.A.2.36)

Settings | Wifi
switch to the right. After a while it just switches back off?

Fixed for me with firmware 17.1.1.A.0.402 (SGP511).
Latest official. It doesn't turn off it just fails to gain a proper connection.
Can see the WiFi connection active.
Sometimes with flashing upload arrow but no active download arrow. Sometimes active but with a yellow exclamation mark (limited connectivity).
A reboot of tablet usually cures it.
 
degraaff
Old
#8  
Senior Member
Thanks Meter 9
Posts: 111
Join Date: Jan 2012
Quote:
Originally Posted by DeadlyDazza View Post
Latest official. It doesn't turn off it just fails to gain a proper connection.
Can see the WiFi connection active.
Sometimes with flashing upload arrow but no active download arrow. Sometimes active but with a yellow exclamation mark (limited connectivity).
A reboot of tablet usually cures it.
Using any proxy? Vpn? Ad blocker? Any app that specifically targets the connection?
Try setting the WiFi to always stay on to see if that makes a difference? (not talking about the stamina mode option, but the option in advanced wifi settings) (maybe the two options don't cooperate so well)
 
ranf
Old
#9  
Member
Thanks Meter 7
Posts: 34
Join Date: May 2012
Quote:
Originally Posted by ranf View Post
Which firmware version do you guys have?

IIRC I had that with the firmware that it came with (17.1.A.2.36)

Settings | Wifi
switch to the right. After a while it just switches back off?

Fixed for me with firmware 17.1.1.A.0.402 (SGP511).
NOT fixed. Had the same yesterday. I took a bugreport.

Can someone make some sense out of this kernel panic?
Code:
Select Code
<6>[249217.591756] wifi_set_power = 1
<3>[249217.633036] qup_i2c f9928000.i2c: QUP: I2C status flags :0xc1300c8, irq:132
<3>[249217.633067] qup_i2c f9928000.i2c: I2C slave addr:0x28 not connected
<6>[249217.797379] wifi_set_carddetect = 1
<6>[249217.797387] mmc0: Slot status change detected (0 -> 1)
<4>[249217.853462] mmc0: queuing unknown CIS tuple 0x91 (3 bytes)
<6>[249217.853552] mmc0: new ultra high speed DDR50 SDIO card at address 0001
<6>[249217.881970] F1 signature OK, socitype:0x1 chip:0x4339 rev:0x1 pkg:0x2
<6>[249217.882673] DHD: dongle ram size is set to 786432(orig 786432) at 0x180000
<4>[249217.910181] WifiStateMachin: page allocation failure: order:5, mode:0xc4d0
<6>[249217.910226] [<c010c278>] (unwind_backtrace+0x0/0x11c) from [<c0222a7c>] (warn_alloc_failed+0xf4/0x11c)
<6>[249217.910236] [<c0222a7c>] (warn_alloc_failed+0xf4/0x11c) from [<c0225d68>] (__alloc_pages_nodemask+0x744/0x85c)
<6>[249217.910245] [<c0225d68>] (__alloc_pages_nodemask+0x744/0x85c) from [<c0225ed8>] (__get_free_pages+0x10/0x24)
<6>[249217.910256] [<c0225ed8>] (__get_free_pages+0x10/0x24) from [<c02510d0>] (kmalloc_order_trace+0x20/0xd0)
<6>[249217.910271] [<c02510d0>] (kmalloc_order_trace+0x20/0xd0) from [<c08d92b8>] (wiphy_new+0xfc/0x3a4)
<6>[249217.910325] [<c08d92b8>] (wiphy_new+0xfc/0x3a4) from [<bf086130>] (wl_cfg80211_attach+0xe4/0xf94 [wlan])
<6>[249217.910366] [<bf086130>] (wl_cfg80211_attach+0xe4/0xf94 [wlan]) from [<bf04e5ac>] (dhd_attach+0x314/0x88c [wlan])
<6>[249217.910403] [<bf04e5ac>] (dhd_attach+0x314/0x88c [wlan]) from [<bf057060>] (dhdsdio_probe+0x314/0x6a4 [wlan])
<6>[249217.910438] [<bf057060>] (dhdsdio_probe+0x314/0x6a4 [wlan]) from [<bf042e88>] (bcmsdh_probe+0x108/0x168 [wlan])
<6>[249217.910471] [<bf042e88>] (bcmsdh_probe+0x108/0x168 [wlan]) from [<bf044c54>] (bcmsdh_sdmmc_probe+0x98/0xc0 [wlan])
<6>[249217.910494] [<bf044c54>] (bcmsdh_sdmmc_probe+0x98/0xc0 [wlan]) from [<c0671bf8>] (sdio_bus_probe+0x8c/0x100)
<6>[249217.910508] [<c0671bf8>] (sdio_bus_probe+0x8c/0x100) from [<c049d210>] (driver_probe_device+0x134/0x340)
<6>[249217.910518] [<c049d210>] (driver_probe_device+0x134/0x340) from [<c049d484>] (__driver_attach+0x68/0x8c)
<6>[249217.910527] [<c049d484>] (__driver_attach+0x68/0x8c) from [<c049b740>] (bus_for_each_dev+0x48/0x80)
<6>[249217.910536] [<c049b740>] (bus_for_each_dev+0x48/0x80) from [<c049c800>] (bus_add_driver+0x100/0x26c)
<6>[249217.910545] [<c049c800>] (bus_add_driver+0x100/0x26c) from [<c049d978>] (driver_register+0x9c/0x120)
<6>[249217.910567] [<c049d978>] (driver_register+0x9c/0x120) from [<bf044f20>] (sdio_function_init+0x40/0x74 [wlan])
<6>[249217.910601] [<bf044f20>] (sdio_function_init+0x40/0x74 [wlan]) from [<bf0c01c4>] (init_module+0x1c4/0x1000 [wlan])
<6>[249217.910624] [<bf0c01c4>] (init_module+0x1c4/0x1000 [wlan]) from [<c01005f4>] (do_one_initcall+0x90/0x160)
<6>[249217.910634] [<c01005f4>] (do_one_initcall+0x90/0x160) from [<c01e29e4>] (sys_init_module+0x1a9c/0x1c6c)
<6>[249217.910646] [<c01e29e4>] (sys_init_module+0x1a9c/0x1c6c) from [<c0106100>] (ret_fast_syscall+0x0/0x30)

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA PORTAL POSTS

Slide Dial Replacement Dialer Lets You Make Calls from Anywhere

If you frequently make phone calls, your dialer (aka phone app)is one of the … more

Navigate with Your Samsung Gear 2 Using DMA Navi Watch

Whether you’re travelling to a new destination or exploring some previously … more

Xperia Z1 Stereo Speaker Mod, Cell Phone Unlocking Legal Again! – XDA Developer TV

Cell Phone Unlocking is legal again!! That and much … more