Post Reply

[Q] No audio from bottom front facing speaker

OP daddymoe

31st August 2014, 05:25 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Aug 2014
Hey guys,

I've just noticed that when I play music or videos (YouTube etc), literally no audio come from the bottom speaker. Only realised after i washed it lightly because I splashed some shaving cream on it. Anyone experienced anything like this?
31st August 2014, 06:53 PM   |  #2  
King Cole's Avatar
Senior Member
Flag Boston, MA
Thanks Meter: 22
 
156 posts
Join Date:Joined: Jun 2012
More
After the phone gets wet, you do need to give it some time in order to dry out. I don't totally understand it, but basically, once you submerge the phone, the speakers kinda shut off, so the sound you hear is coming from inside the phone, but within half an hour to an hour it'll eventually come back.
31st August 2014, 10:26 PM   |  #3  
gallardo5's Avatar
Senior Member
Flag Glasgow
Thanks Meter: 234
 
991 posts
Join Date:Joined: Apr 2011
More
Quote:
Originally Posted by King Cole

After the phone gets wet, you do need to give it some time in order to dry out. I don't totally understand it, but basically, once you submerge the phone, the speakers kinda shut off, so the sound you hear is coming from inside the phone, but within half an hour to an hour it'll eventually come back.

It doesnt shut off, its just the water blocks the sound while its in the speaker. What I do is I put my mouth next to speaker and literally suck the water from the speaker.
31st August 2014, 11:08 PM   |  #4  
OP Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Aug 2014
Quote:
Originally Posted by gallardo5

It doesnt shut off, its just the water blocks the sound while its in the speaker. What I do is I put my mouth next to speaker and literally suck the water from the speaker.

LOL you just made my morning. Yeah, I waited overnight and the speakers work now. It's definitely because of the water. If anyone has the same problem, just give it a bit of time to dry.

Thanks guys!
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia Z2 Q&A, Help & Troubleshooting by ThreadRank