Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,778,037 Members 52,369 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Some apps not working after using Link2sd

Tip us?
 
nilanko
Old
(Last edited by nilanko; 10th July 2014 at 11:43 AM.) Reason: Typo
#1  
Member - OP
Thanks Meter 2
Posts: 38
Join Date: Jun 2014
Location: New Delhi

 
DONATE TO ME
Question [Q] Some apps not working after using Link2sd

I use link2sd to link app, dalvik (dex), lib and data files of all 3rd party apps that I install to my SD card to keep the internal memory clean and save space. Most of the apps work but some apps like Subway Surfers, Rail Rush, etc. stop working after linking everything and REBOOTING the phone. Until I reboot, it works but not after that. When I try to launch them, I get "[app] has stopped working error". 95% of the linked apps work totally fine. Problem is only with some apps (these apps that are troublesome are mostly the ones that automatically get installed to the SD card. But even if they do, only apk is stored on SD card and the dex, lib, data are still on the internal memory so I still need to use Link2SD).

Any solutions? Or workarounds?
 
ghostofcain
Old
#2  
ghostofcain's Avatar
Senior Member
Thanks Meter 791
Posts: 2,513
Join Date: Nov 2009
Location: Birkenhead
Quote:
Originally Posted by nilanko View Post
I use link2sd to link app, dalvik (dex), lib and data files of all 3rd party apps that I install to my SD card to keep the internal memory clean and save space. Most of the apps work but some apps like Subway Surfers, Rail Rush, etc. stop working after linking everything and REBOOTING the phone. Until I reboot, it works but not after that. When I try to launch them, I get "[app] has stopped working error". 95% of the linked apps work totally fine. Problem is only with some apps (these apps that are troublesome are mostly the ones that automatically get installed to the SD card. But even if they do, only apk is stored on SD card and the dex, lib, data are still on the internal memory so I still need to use Link2SD).

Any solutions? Or workarounds?
Install these minority of apps as the developer intended? , if it's only a few apps it's hardly going to swamp your internal memory.
I'm a linux user and smug about it, this is your problem not mine.
 
nilanko
Old
#3  
Member - OP
Thanks Meter 2
Posts: 38
Join Date: Jun 2014
Location: New Delhi

 
DONATE TO ME
Quote:
Originally Posted by ghostofcain View Post
Install these minority of apps as the developer intended? , if it's only a few apps it's hardly going to swamp your internal memory.
Yeah its just a few but I'm afraid I wanna keep more such apps in future which might behave this way. As far as it seems, this problem is only with some of those apps which automatically get installed to the SD card (like subway surfers). I found a workaround that seems to be working. Firstly the app needs to be moved to the internal memory before linking (which I already did before). But there are two ways to do this: One through the Android system (Settings -> Apps -> SD card -> Select app -> Move to phone) and other by using the Link2SD app (Select app -> Move to phone). The second option solves the problem. If the app is moved to phone using Android system, then linked to SD card and rebooted, apps stop working. So, its needed to move it to phone using link2sd.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes