Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,812,702 Members 45,085 Now Online
XDA Developers Android and Mobile Development Forum

Camera button problem with the official camera app

Tip us?
 
Hossam.Abdelsalam
Old
(Last edited by Hossam.Abdelsalam; 10th August 2014 at 11:28 PM.) Reason: A possible fix for the problem
#1  
Senior Member - OP
Thanks Meter 10
Posts: 116
Join Date: Jul 2012
Default Camera button problem with the official camera app

Folks,

[Update] This is a possible fix for the dedicated camera button as below:

1-The symptoms i had before:

this is my second month with my 4th Xperia Z2, as the last 3 had all possible defects you can ever imagine, anyway, i recently noticed that the dedicated camera button has some sort of a problem, it launches the camera app perfectly then it doesn't respond at all, i keep pressing it like crazy with no luck to capture the shot.

the weird thing is it works perfectly with any other camera app from the market, and it sometimes works with the official camera app after like 1 minute of waiting or maybe randomly, i don't really know, then after i capture the photo it stops responding again for a minute or so.

what do you think guys?

i'm on .314 FW
tried a factory reset, tried uninstalling all other 3rd party camera apps with no luck

2- The Fix

i've tried removing all 3rd party camera apps with no luck, tried the factory reset and then the PC Companion repair with no luck as well.
googled it but no one is talking about it, even here, i didn't find a real fix which made me really nervous about it as this is my 4th Z2, here is what i did.

A- I pressed it very hard for like 10 times as i was really nervous coz there are no fix
B- while pressing and releasing i felt that sometimes it get released for the 2 clicks, the shutter click then the focus click
C- I started sensing when it get released for just the shutter click then stopes and when it get released for the 2 clicks
D- bought an AKAI electronic spray and sprayed the button several times while keep pressing and releasing it hundreds of times till it stopped the faulty 1 release and it became most of the times releasing the 2 clicks

3- The conclusion:

when the official app launches while the focus click not released the button will not function at all, and when it launches while the 2 clicks are released everything will be perfect

Hope this help you folks as i'm sure there will be lots of you guys with this problem without a fix for it (as most of Xperia Z2 devices has their defects) for me only I've replaced 3 devices and this is the 4th one
 
Envious_Data
Old
#2  
Envious_Data's Avatar
Recognized Contributor
Thanks Meter 867
Posts: 2,182
Join Date: Oct 2012
Location: Imagination

 
DONATE TO ME
Quote:
Originally Posted by Hossam.Abdelsalam View Post
Folks,

this is my second month with my 4th Xperia Z2, as the last 3 had all possible defects you can ever imagine, anyway, i recently noticed that the dedicated camera button has some sort of a problem, it launches the camera app perfectly then it doesn't respond at all, i keep pressing it like crazy with no luck to capture the shot.

the weird thing is it works perfectly with any other camera app from the market, and it sometimes works with the official camera app after like 1 minute of waiting or maybe randomly, i don't really know, then after i capture the photo it stops responding again for a minute or so.

what do you think guys?

i'm on .314 FW
tried a factory reset, tried uninstalling all other 3rd party camera apps with no luck
how did you factory reset?

perhaps try repairing your device via Sony Pc companion. if your problem peesists try contacting sony support and get a device repair as this should be covered by your 2 year warrenty that sony gives with all xperias.
you do need proof of purchase for this


Hi there

"Music Makes me forget the traumas that plague my mind. Music is the cure to a normaly unfixable problem"
-Nozomi Yamauchi

http://envious.host-my-rom.eu/
Credits to zantekk for the WebSpace


Deviant Art page
http://enviousdata.deviantart.com/
 
Hossam.Abdelsalam
Old
#3  
Senior Member - OP
Thanks Meter 10
Posts: 116
Join Date: Jul 2012
Quote:
Originally Posted by Envious_Data View Post
how did you factory reset?

perhaps try repairing your device via Sony Pc companion. if your problem peesists try contacting sony support and get a device repair as this should be covered by your 2 year warrenty that sony gives with all xperias.
you do need proof of purchase for this
thanks for the reply man,

but what is the difference between the factory reset and the PC Companion repair? i think both of them are doing the same job, correct me if i'm wrong.

also please i need more clarifications for the 2 years warranty, and does this need to be shipped to the country i bought it from or any Sony branch can handle this?
 
Envious_Data
Old
#4  
Envious_Data's Avatar
Recognized Contributor
Thanks Meter 867
Posts: 2,182
Join Date: Oct 2012
Location: Imagination

 
DONATE TO ME
Quote:
Originally Posted by Hossam.Abdelsalam View Post
thanks for the reply man,

but what is the difference between the factory reset and the PC Companion repair? i think both of them are doing the same job, correct me if i'm wrong.

also please i need more clarifications for the 2 years warranty, and does this need to be shipped to the country i bought it from or any Sony branch can handle this?


no. factory reset just resets the user data, sony PC companion repair, reinstalls the entire OS, hence removing any problems with your current System.

and for warrenty, all xperia devices have a 2 year warrenty if you have proof of purchase. (emails,reciepts,cell contract.. etc)
all faults with the device which are not caused by the owner, sony will repair as this is a Device fault. this is covered by warrenty


Hi there

"Music Makes me forget the traumas that plague my mind. Music is the cure to a normaly unfixable problem"
-Nozomi Yamauchi

http://envious.host-my-rom.eu/
Credits to zantekk for the WebSpace


Deviant Art page
http://enviousdata.deviantart.com/
 
CodeNameRedNeck
Old
#5  
CodeNameRedNeck's Avatar
Member
Thanks Meter 26
Posts: 97
Join Date: May 2012
Location: Cardboard Box
Quote:
Originally Posted by Hossam.Abdelsalam View Post
Folks,



i'm on .314 FW
tried a factory reset, tried uninstalling all other 3rd party camera apps with no luck
As I posted in this thread
http://forum.xda-developers.com/xper...amera-t2827868
It wasn't always third party camera apps that made mine quit working but that there is also one of my cases that makes my camera button quit working.
The Following User Says Thank You to CodeNameRedNeck For This Useful Post: [ Click to Expand ]
 
Hossam.Abdelsalam
Old
#6  
Senior Member - OP
Thanks Meter 10
Posts: 116
Join Date: Jul 2012
Default I found a fix, please check the 1st post update

Quote:
Originally Posted by CodeNameRedNeck View Post
As I posted in this thread
http://forum.xda-developers.com/xper...amera-t2827868
It wasn't always third party camera apps that made mine quit working but that there is also one of my cases that makes my camera button quit working.
I found a fix, please check the 1st post update
 
CodeNameRedNeck
Old
#7  
CodeNameRedNeck's Avatar
Member
Thanks Meter 26
Posts: 97
Join Date: May 2012
Location: Cardboard Box
Quote:
Originally Posted by Hossam.Abdelsalam View Post
I found a fix, please check the 1st post update
I am glad you got it working right!

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Sony PS4 Remote Play Ported to All Android Devices

Im pretty sure that every informed gamer out there perked their ears up when Sony came out … more

Change Your Samsung Galaxy S2’s Dialer Background in Real Time

As with anything, if youve looked at something long enough, things can … more

Increase Your Multitasking Workflow with C-Floating Windows

Technology has put life on the fast track. Lazy, relaxed days have turned into … more

Compile Your Own Kernel From Source with Comprehensive Tutorial

One glance at any developer section of any device forum on XDA and youll find … more