Post Reply

[Q] Choppy Sound w/ USB DAC

14th August 2014, 12:12 AM   |  #1  
OP Senior Member
Flag SF Bay Area
Thanks Meter: 21
 
141 posts
Join Date:Joined: Aug 2011
More
Hey Guys - having some issues recently with my Z2 and USB DAC output; though frankly hi res output hasn't worked properly unless I use USB Audio Recorder app.

But usually, if I keep Hi Res Audio via USB unchecked, Pandora & Beats Music will output properly. That's been the case through .402 firmware. I have .314 installed right now and with the USB option checked or unchecked, music starts off smooth and then becomes choppy. I'm on .314 rooted with the bootloader locked (it has been unlocked in the past ... just used the locked bootloader root method the last time I upgraded the firmware).

The only mod I have installed is the dual stereo speakers for speakerphone. Any suggestions? Should I do a clean FTF install or something? Go back to .402 maybe?

Thanks,

Praz
20th August 2014, 01:31 AM   |  #2  
OP Senior Member
Flag SF Bay Area
Thanks Meter: 21
 
141 posts
Join Date:Joined: Aug 2011
More
UPDATE:

I did a fresh install of the US/Canada .314 firmware and then rooted via the exploit (kept the bootloader locked). Aside from USB Audio Player Pro, any other output via USB ends up in choppy audio. I dropped Sony support an e-mail and they were useless, so I'm at a loss as to what's causing the issue - the phone or something else?

Those who unlocked your bootloaders and / or rooted, and are using USB DACs w/ the Z2 - is everything working ok?

Thanks,

Praz.
20th August 2014, 08:41 PM   |  #3  
OP Senior Member
Flag SF Bay Area
Thanks Meter: 21
 
141 posts
Join Date:Joined: Aug 2011
More
UPDATE 2:

Did a full repair via PC Companion, only installed Spotify and tested w/ DAC. Same issue with or without USB enhancement enabled. Hmm. Running out of ideas.
21st August 2014, 02:54 AM   |  #4  
OP Senior Member
Flag SF Bay Area
Thanks Meter: 21
 
141 posts
Join Date:Joined: Aug 2011
More
UPDATE 3:

So after much ado, it just looks like there are some compatibility issues with the Z2 and Fiio X5 in DAC mode. I came home and connected the Z2 to my full size Schitt Gungnir DAC's USB input and everything works perfectly. Then I grabbed my HRT Microstreamer and ....it's working perfectly now too! I hadn't actually tried it for several weeks so may have been something to do with prior setup I guess.

Anyway ..tentatively, looks like I'm good mostly. X5 bad. Microstreamer good.
Post Reply Subscribe to Thread

Tags
dac, otg, usb, xperia + z2
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia Z2 Q&A, Help & Troubleshooting by ThreadRank