FORUMS

Analysis & Opinion

[Q] Choppy Sound w/ USB DAC

161 posts
Thanks Meter: 22
 
By prazvt, Senior Member on 14th August 2014, 12:12 AM
Post Reply Subscribe to Thread Email Thread
Hey Guys - having some issues recently with my Z2 and USB DAC output; though frankly hi res output hasn't worked properly unless I use USB Audio Recorder app.

But usually, if I keep Hi Res Audio via USB unchecked, Pandora & Beats Music will output properly. That's been the case through .402 firmware. I have .314 installed right now and with the USB option checked or unchecked, music starts off smooth and then becomes choppy. I'm on .314 rooted with the bootloader locked (it has been unlocked in the past ... just used the locked bootloader root method the last time I upgraded the firmware).

The only mod I have installed is the dual stereo speakers for speakerphone. Any suggestions? Should I do a clean FTF install or something? Go back to .402 maybe?

Thanks,

Praz
 
 
20th August 2014, 01:31 AM |#2  
OP Senior Member
Flag SF Bay Area
Thanks Meter: 22
 
More
UPDATE:

I did a fresh install of the US/Canada .314 firmware and then rooted via the exploit (kept the bootloader locked). Aside from USB Audio Player Pro, any other output via USB ends up in choppy audio. I dropped Sony support an e-mail and they were useless, so I'm at a loss as to what's causing the issue - the phone or something else?

Those who unlocked your bootloaders and / or rooted, and are using USB DACs w/ the Z2 - is everything working ok?

Thanks,

Praz.
20th August 2014, 08:41 PM |#3  
OP Senior Member
Flag SF Bay Area
Thanks Meter: 22
 
More
UPDATE 2:

Did a full repair via PC Companion, only installed Spotify and tested w/ DAC. Same issue with or without USB enhancement enabled. Hmm. Running out of ideas.
21st August 2014, 02:54 AM |#4  
OP Senior Member
Flag SF Bay Area
Thanks Meter: 22
 
More
UPDATE 3:

So after much ado, it just looks like there are some compatibility issues with the Z2 and Fiio X5 in DAC mode. I came home and connected the Z2 to my full size Schitt Gungnir DAC's USB input and everything works perfectly. Then I grabbed my HRT Microstreamer and ....it's working perfectly now too! I hadn't actually tried it for several weeks so may have been something to do with prior setup I guess.

Anyway ..tentatively, looks like I'm good mostly. X5 bad. Microstreamer good.
14th October 2014, 04:59 AM |#5  
Out of curiosity did you get any crackling noises with the microstreamer? That's what I'm experiencing now. Happens after about 4 minutes of play time.

Sent from my D6653 using XDA Free mobile app
14th October 2014, 05:55 AM |#6  
OP Senior Member
Flag SF Bay Area
Thanks Meter: 22
 
More
Quote:
Originally Posted by jonamafun

Out of curiosity did you get any crackling noises with the microstreamer? That's what I'm experiencing now. Happens after about 4 minutes of play time.

Sent from my D6653 using XDA Free mobile app

Yes, eventually it did start crackling. Someone on head-fi explained it to me here:

http://www.head-fi.org/t/720785/sony...nw-zx1-walkman

Still, I never had problems with my Note 2 or Note 3, so perhaps they're using different USB drivers. If you use USB Audio Player Pro, though, there's no crackling. It's only if you're using the native Sony Walkman app or any streaming app like Pandora / Spotify / etc.

Hope that helps!
Last edited by prazvt; 14th October 2014 at 06:00 AM.
14th October 2014, 07:45 AM |#7  
Member
Thanks Meter: 12
 
More
Hrm interesting I've been getting the same issue running cm11 based ROMs on z2, though I would describe the sound as more of a clicking.

I wonder if the native USB DAC support in android L will rectify the issue.

Sent from my Xperia Z2 using XDA Free mobile app
4th February 2015, 12:30 PM |#8  
Junior Member
Thanks Meter: 0
 
More
Can someone tell me if this problem is solved? or will it work with a fiio e17 without the choppy sound? i would like to use it with spotify
Last edited by Klueze; 4th February 2015 at 12:33 PM.
Post Reply Subscribe to Thread

Tags
dac, otg, usb, xperia + z2

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes