5,815,179 Members 38,752 Now Online
XDA Developers Android and Mobile Development Forum

[Q] PC doesn't detect Z2 flash mode

Tip us?
 
cempwns
Old
(Last edited by cempwns; 5th August 2014 at 08:10 PM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Aug 2014
Post [Q] PC doesn't detect Z2 flash mode

I "accidently" wiped my entire phone (dalvik,system,cache,data,internal) in twrp recovery because i was stuck in a bootloop and installed envi-rom 0.2B and the phone was able to boot normally and get the phone working again.

After getting my phone to turn on and working again i wasn't able to use flashtool and it looks like this:
05/041/2014 14:41:04 - INFO - Device connected with USB debugging on
05/041/2014 14:41:05 - INFO - Connected device : Sony Xperia Z2
05/041/2014 14:41:05 - INFO - Installed version of busybox : BusyBox v1.22.1-Stericson (2014-01-25 17:27:18 CET) multi-call binary.
05/041/2014 14:41:05 - INFO - Android version : 4.4.2 / kernel version : 3.4.0-perf-gef0bdc3 / Build number : 17.1.1.A.0.402
05/041/2014 14:41:05 - INFO - Checking root access
05/041/2014 14:41:05 - INFO - Root Access Allowed
05/041/2014 14:41:23 - INFO - Selected Bundle for Sony Xperia Z2 (D6503). FW release : 17.1.2.A.0.314. Customization : Generic Thailand
05/041/2014 14:41:23 - INFO - Preparing files for flashing
05/041/2014 14:41:24 - INFO - Please connect your device into flashmode.
05/041/2014 14:41:34 - INFO - Device disconnected
05/041/2014 14:41:59 - INFO - Device connected with USB debugging off
05/041/2014 14:41:59 - INFO - For 2011 devices line, be sure you are not in MTP mode
05/042/2014 14:42:11 - INFO - Flash canceled

LED blinks red,green, then turns off and flashtool doesn't detect it all.
Afterwards i need to use the power button and volume up key to turn off the phone and reboot.
I also tried via sony pc companion and the phone update itself to update and get 17.1.2.A.0.314 but that didn't work either.
Occasionally flashtool gets stuck on installftkit:
05/010/2014 14:10:37 - INFO - Checking root access
05/010/2014 14:10:43 - INFO - Root Access Allowed
05/010/2014 14:10:43 - INFO - Installing toolbox to device...
05/010/2014 14:10:43 - INFO - Pushing C:\Flashtool\custom\root\ftkit.tar to /data/local/tmp
05/010/2014 14:10:44 - INFO - Running installftkit as root thru sysrun

So i can't update by flashing, pc companion, or via phone. It would also work if anyone knows how i can update without flashing.
-Sorry for long post, just wanted to provide some background info.
 
ChrisRoxor
Old
#2  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Aug 2014
Im having a similar issue!
Except i cant even boot up my phone, it shows sony logo, then goes to the boot animation sound but the screen is black.
I need to get my phone into flashmode for pcompanion to repair it, but when i try to, the led flashed red, green and off, very quickly.
 
ChrisRoxor
Old
#3  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Aug 2014
Please can someone help? I can't use my new phone
 
tonypro79
Old
#4  
tonypro79's Avatar
Member
Thanks Meter 8
Posts: 30
Join Date: Aug 2014
Quote:
Originally Posted by ChrisRoxor View Post
Please can someone help? I can't use my new phone
Connect Phone & PC and press the Volume Down button (see LEDs blink, then let go)
 
ChrisRoxor
Old
#5  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Aug 2014
Quote:
Originally Posted by tonypro79 View Post
Connect Phone & PC and press the Volume Down button (see LEDs blink, then let go)
According to the pc companion it should stay green and also it doesn't notice the phone connected at all :/
 
cempwns
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Aug 2014
Yeah pressed those buttons and tried the options i found on other threads (re-installing drivers, using different pc, etc.) still nothing. I don't have the original wire that came with the phone but i doubt that has an impact.
 
ChrisRoxor
Old
#7  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Aug 2014
It's the same with me
 
JackHanAnLG
Old
#8  
Senior Member
Thanks Meter 67
Posts: 509
Join Date: Apr 2012
Location: Southend
Make sure usb debugging mode is on for a start.

Pick the firmware you want to flash and let it prepear.

When it comes up saying please connect your phone. Make sure your phone is off. While plugging the USB into the phone hold down the vol down button. It will then connect and proceed to flash the firmware

Sent from my D6503 using XDA Free mobile app
 
ChrisRoxor
Old
#9  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Aug 2014
Quote:
Originally Posted by JackHanAnLG View Post
Make sure usb debugging mode is on for a start.

Pick the firmware you want to flash and let it prepear.

When it comes up saying please connect your phone. Make sure your phone is off. While plugging the USB into the phone hold down the vol down button. It will then connect and proceed to flash the firmware

Sent from my D6503 using XDA Free mobile app
The problem i have is the computer doesnt notice the phone when its in flashmode. It just keeps saying 'Connect device'
 
cempwns
Old
#10  
Junior Member - OP
Thanks Meter 0
Posts: 6
Join Date: Aug 2014
Quote:
Originally Posted by JackHanAnLG View Post
Make sure usb debugging mode is on for a start.

Pick the firmware you want to flash and let it prepear.

When it comes up saying please connect your phone. Make sure your phone is off. While plugging the USB into the phone hold down the vol down button. It will then connect and proceed to flash the firmware

Sent from my D6503 using XDA Free mobile app
Sorry i don't think you noticed it was on in my post:
"05/041/2014 14:41:04 - INFO - Device connected with USB debugging on"

But yeah, apparently usb debugging turns off or something of the sort?

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes