Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Microphone no sound

OP jvx300

27th July 2014, 11:07 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
28 posts
Join Date:Joined: Dec 2010
Had the Z2 for about a month, all of the sudden the primary microphone have no sound. The secondary still work...I need to take my call with either speaker phone or a bluetooth headset. Any idea on how to fix this?? I tried updating the firmware to the latest one and resetting my phone and still didn't fix it.
15th September 2014, 01:03 AM   |  #2  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Nov 2010
Quote:
Originally Posted by jvx300

Had the Z2 for about a month, all of the sudden the primary microphone have no sound. The secondary still work...I need to take my call with either speaker phone or a bluetooth headset. Any idea on how to fix this?? I tried updating the firmware to the latest one and resetting my phone and still didn't fix it.


I got my new Z2 three days ago and it now have the same problem as you. I can use speaker while talking on the phone only. If I don't use speaker, then the other party cannot hear me.

I went to the setting -> about phone -> diagnostic -> microphone and it failed with no sound recorded.

It did got fixed for no reason and it is now dead again.

I'm going to replace the whole thing. Cannot live without a phone for one day.

Ashera
17th September 2014, 09:16 AM   |  #3  
Envious_Data's Avatar
Recognized Contributor
Imagination
Thanks Meter: 1,447
 
3,317 posts
Join Date:Joined: Oct 2012
Donate to Me
More
have both of you concidered contacting sony customer repair as this is known as a xperia fault

you are both entitled to a free repair or replacement thanks to sonys 2 year international warrenty
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes