Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] what is wrong

OP IIVIIrb

9th July 2014, 12:45 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Jul 2014
I am trying too root my sony xperia z2, using the EasyRootTool,

i have followed all of the steps and it does not seem to work,
i have also took advice given too other people in the post and nothing is still happening,
it is just stuck at the first step where it tell you to connect your device,
I have the latest version of the easy root tool and my xperia z2 is on. 402

Any help would highly be appreciated.
9th July 2014, 12:55 AM   |  #2  
Costinutz32's Avatar
Senior Member
Bucharest
Thanks Meter: 786
 
1,035 posts
Join Date:Joined: Oct 2011
Donate to Me
More
Why don't you try unlocking your bootloader and then rooting via recovery ?
Useful link : http://unlockbootloader.sonymobile.com.
9th July 2014, 01:02 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Jul 2014
Quote:
Originally Posted by Costinutz32

Why don't you try unlocking your bootloader and then rooting via recovery ?

Because I want to be able to ta backup and keep all my keys which means I can keep my warranty
9th July 2014, 05:19 AM   |  #4  
hush66's Avatar
Senior Member
Thanks Meter: 401
 
853 posts
Join Date:Joined: Apr 2010
More
Have you ensured that:
(1) USB debugging mode is enabled?
(2) Unknown sources is enabled?
(3) ADB drivers are properly installed?

You need to provide more details on the problem so that we can help. What exactly happens when you connect your device to the PC?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes