Post Reply

Xperia Z2, experiencing weird issues.

OP TheWobling

21st August 2014, 02:29 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Aug 2014
Hi all, had my Xperia since May and its been great until recently its started acting weird and not turning on the display when I hit the power button or taking a long time to turn the screen on, has anyone else experienced anything like this?

Thanks.
21st August 2014, 04:51 PM   |  #2  
Envious_Data's Avatar
Recognized Contributor
Imagination
Thanks Meter: 1,027
 
2,530 posts
Join Date:Joined: Oct 2012
Donate to Me
More
Quote:
Originally Posted by TheWobling

Hi all, had my Xperia since May and its been great until recently its started acting weird and not turning on the display when I hit the power button or taking a long time to turn the screen on, has anyone else experienced anything like this?

Thanks.

im unsure what can cause this but there are some posibilities

here is a list:
malicious apps
advertising apps
badly designed apps

try removing some apps that have been recently installed, if the problem persists then repair your device using support zone found within Sony PC Companion
24th August 2014, 11:19 PM   |  #3  
AlexTek's Avatar
Junior Member
Flag Lisboa
Thanks Meter: 0
 
6 posts
Join Date:Joined: Aug 2010
Donate to Me
More
Finally someone with the same problem, i bought my Z2 last week and i am feeling that the mobile takes long to start up (like 10 seconds) like pressing the button to vibrate, after vibrate is quick, with or without extra apps, its weird, anyone else feeling these?
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Xperia Z2 Q&A, Help & Troubleshooting by ThreadRank