Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,807,866 Members 50,807 Now Online
XDA Developers Android and Mobile Development Forum

xperia z2 - headphone port issues

Tip us?
 
Kernel Fergus
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Nov 2012
Location: norwich
Default xperia z2 - headphone port issues

hi guys, basicallynim wondering if anybody else is experiencing the issues that i am.

Essentially im ecstatically happy with my z2, except the headphone port seems faulty. While driving i use the 3.5mm jack on the z2 to connect tk the car.

This is when i noticed the faults with the headphone port. If i insert a 3 or 4 pid connector, either a 3.5-3.5 cable, a standard 3pin headphone connector, or a 4 pin headset, a slight nudge on the connector disconnects the headphones/cable and music stops. Sometimes, google now gets triggered as well. The same things happen if i twist the jack, whatever is connected. It also seems quite loose, and there is no positive click when a jack is inserted.

I would upload a video showing what happens, but my only video camera is in my z2.........

It has also not been submerged/wet at all, and is kept in a case (i tested the jack without the case as well, but it still happens)
 
HugePotato
Old
#2  
Member
Thanks Meter 9
Posts: 51
Join Date: Apr 2009
Location: Cracow
In my brand new Z2 I also don't hear that click when inserting headphones but they are in the deep all the way. I tested 4 different earphones and speakers but none gave me any problems(I was twisting jack and trying to move it but connection was too tight), no loss of sound. I think you should get your Z2 serviced or replaced. Also I have a question. When you plug in normal headphones or speakers(not the noise cancelling ones), do you get a notification saying that you connected them or not? I only get something like this when Smart Connect is enabled...
 
VykoJust
Old
#3  
Junior Member
Thanks Meter 0
Posts: 8
Join Date: Jun 2013
I have issues with jack too. When you pulg in headphones, it sometimes wont recognize that something was plugged in, but if you try to twist the jack in the phone, it may get working (the sound is clear, no loss). The problem is when you put the phone in a pocket and walk, the jack is moving there so it is very likely to stop working and u have to twist it again.

When I bought the phone, I had no problems with it, but after first water test (which resulted fine, there was no water inside), the problem started.
Got the phone for 2 months and the issue still persists.

My solution is plugging in, search for the right spot before it starts worrking and walk with phone in a hand, holding the cable so it wont move in the jack.
 
Kernel Fergus
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 8
Join Date: Nov 2012
Location: norwich
i got it replaced in the end, had the new one for 2 weeks with no issues, so definitely a hardware fault.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes