Sony Encouraging SmartWatch 2 Development

Mobile device companies like selling devices–it’s how they make their money and … more

Easily Toggles Your Lollipop Mobile Data Network Type

Android Lollipop is by good margin the most advanced and refinedversion of … more

Unofficial CM12 for Android One, Disabling Encryption on Nexus 6 – XDA TV

Android One devices have received an Unofficial CyanogenMod … more

Pushbullet Universal Copy/Paste Availabe for Linux, Mac OS X

Pushbullet is one of those useful utilities that once installed, permanently … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[SOLVED] Z2 cannot install ADB driver

OP GalosSide

31st July 2014, 08:44 AM   |  #1  
OP Junior Member
Thanks Meter: 1
 
6 posts
Join Date:Joined: Jul 2014
Two days ago I tried to use Easy Root ToolV11 to root my device that's running 14.1.1.A.0.402 Model D6503, it said "waiting for device".
I looked something up a bit and tried to install ADB driver, but nothing shown up in my detected ANDROID device list even though it was already plugged in to my PC.
I also tried to set up ADB PATH by following a tutorial in this thread http://forum.xda-developers.com/show....php?t=2559009 but it didn't work.
In my device manager my device is under "portable devices" instead "android devices"

I also tried towelroot on my phone. It said that my phone is rooted, but root checker said "This device does not have proper root access"

Ps. usb debugging mode and unknown sources are enabled

edit:
The driver that was install for my device is from microsoft. (see pictures below)

I uninstalled the driver and it was reinstall again every time i plugged my device in. I tried to update the driver, but it said that my driver is already up to date.
Attached Thumbnails
Click image for larger version

Name:	z2 driver.png
Views:	144
Size:	75.2 KB
ID:	2878164   Click image for larger version

Name:	z2 driver - 2.png
Views:	134
Size:	26.3 KB
ID:	2878165   Click image for larger version

Name:	z2 driver - 3.png
Views:	125
Size:	40.3 KB
ID:	2878166  
Last edited by GalosSide; 1st August 2014 at 09:35 AM.
31st July 2014, 09:30 AM   |  #2  
cpumaster's Avatar
Senior Member
Thanks Meter: 161
 
292 posts
Join Date:Joined: Jan 2011
Donate to Me
More
Quote:
Originally Posted by GalosSide

Two days ago I tried to use Easy Root ToolV11 to root my device that's running 14.1.1.A.0.402 Model D6503, it said "waiting for device".
I looked something up a bit and tried to install ADB driver, but nothing shown up in my detected ANDROID device list even though it was already plugged in to my PC.
I also tried to set up ADB PATH by following a tutorial in this thread http://forum.xda-developers.com/show....php?t=2559009 but it didn't work.
In my device manager my device is under "portable devices" instead "android devices"

I also tried towelroot on my phone. It said that my phone is rooted, but root checker said "This device does not have proper root access"

Ps. usb debugging mode and unknown sources are enabled

Are you using Windows 8?
31st July 2014, 09:39 AM   |  #3  
OP Junior Member
Thanks Meter: 1
 
6 posts
Join Date:Joined: Jul 2014
Quote:
Originally Posted by cpumaster

Are you using Windows 8?

im using windows 7 sp1

also I just realize that i cannot use Sony PC Companion to do anything with my device it said that internet connection is required, but I am already connected.
31st July 2014, 03:45 PM   |  #4  
hush66's Avatar
Senior Member
Thanks Meter: 401
 
850 posts
Join Date:Joined: Apr 2010
More
Not sure but perhaps the drivers were not correctly installed. Try this?

http://forum.xda-developers.com/show....php?t=2635830
31st July 2014, 05:51 PM   |  #5  
OP Junior Member
Thanks Meter: 1
 
6 posts
Join Date:Joined: Jul 2014
Quote:
Originally Posted by hush66

Not sure but perhaps the drivers were not correctly installed. Try this?

http://forum.xda-developers.com/show....php?t=2635830

I'm still getting the same problem with the driver install.


I think i know what the problem is right now. The driver that was install for my device is from microsoft. (see pictures below)





I uninstalled the driver and it was reinstall again every time i plugged my device in. I tried to update the driver, but it said that my driver is already up to date.

Attached Thumbnails
Click image for larger version

Name:	z2 driver.png
Views:	61
Size:	75.2 KB
ID:	2878135   Click image for larger version

Name:	z2 driver - 2.png
Views:	59
Size:	26.3 KB
ID:	2878136   Click image for larger version

Name:	z2 driver - 3.png
Views:	54
Size:	40.3 KB
ID:	2878137  
31st July 2014, 07:00 PM   |  #6  
hush66's Avatar
Senior Member
Thanks Meter: 401
 
850 posts
Join Date:Joined: Apr 2010
More
Well, I just plugged in my Z2 to my PC and checked the driver details and it's exactly the same as yours. So it might not be an issue with the driver after all.

You mentioned that you have already done the ADB setup but it didn't work. When you said "it didn't work", do you mean the ADB couldn't be setup, or did you mean you still got the "waiting for device" message? To check if your ADB has been setup properly, go into the command prompt and type adb devices. You should see a serial number (of your phone) as the response.

And you should also have had the fastboot drivers installed. Use this tool to install fastboot drivers: http://forum.xda-developers.com/show....php?t=2588979
The Following User Says Thank You to hush66 For This Useful Post: [ View ]
1st August 2014, 09:08 AM   |  #7  
OP Junior Member
Thanks Meter: 1
 
6 posts
Join Date:Joined: Jul 2014
Quote:
Originally Posted by hush66

Well, I just plugged in my Z2 to my PC and checked the driver details and it's exactly the same as yours. So it might not be an issue with the driver after all.

You mentioned that you have already done the ADB setup but it didn't work. When you said "it didn't work", do you mean the ADB couldn't be setup, or did you mean you still got the "waiting for device" message? To check if your ADB has been setup properly, go into the command prompt and type adb devices. You should see a serial number (of your phone) as the response.

And you should also have had the fastboot drivers installed. Use this tool to install fastboot drivers: http://forum.xda-developers.com/show....php?t=2588979

Finally it work!!!!

I'm rooting right now and it's stuck at cleaning up......what do i do now
1st August 2014, 09:19 AM   |  #8  
Frantiic87a's Avatar
Member
Flag Malmö
Thanks Meter: 4
 
38 posts
Join Date:Joined: Jul 2014
More
Quote:
Originally Posted by GalosSide

Finally it work!!!!

I'm rooting right now and it's stuck at cleaning up......what do i do now

restart the install.bat file.. happens from time to time that it get stuck on cleaning up.

Check the official thread about Easy Root and you'll see loads of people had the same problem.

Just re-run the program and it will work.
The Following User Says Thank You to Frantiic87a For This Useful Post: [ View ]
1st August 2014, 09:30 AM   |  #9  
OP Junior Member
Thanks Meter: 1
 
6 posts
Join Date:Joined: Jul 2014
Quote:
Originally Posted by Frantiic87a

restart the install.bat file.. happens from time to time that it get stuck on cleaning up.

Check the official thread about Easy Root and you'll see loads of people had the same problem.

Just re-run the program and it will work.


I did and it said "insmod: init_module '/data/local/tmp/wp_mod.ko' failed (File exists)"

edit:
I restart my phone and root again. It's finally rooted.

Thank you every one for helping me.
Last edited by GalosSide; 1st August 2014 at 09:34 AM.
1st August 2014, 11:47 AM   |  #10  
Senior Member
Thanks Meter: 44
 
274 posts
Join Date:Joined: Dec 2011
Thank you!

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes