Default Z2 Spell Checker

Hello

I have being having some issues with the Z2.

It seems to like to constantly autocorrect words that it doesn't like such as names. But then it will also add any word that you may use to the dictionary.

I want to disable autocorrect (which I've done) but now I want any misspellings to be underlined just like they were on my Samsung S2. Anyone know how to do this? My spell checker settings never load.