Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,804,576 Members 43,927 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Troubleshooting spontaneous reboot's on 230

Tip us?
 
scifan
Old
#1  
scifan's Avatar
Senior Member - OP
Thanks Meter 173
Posts: 982
Join Date: Dec 2008
Default [Q] Troubleshooting spontaneous reboot's on 230

Guess I need to ask for help/idea's.

If I upgrade my "4.3/101" installation to 4.4/230, everything initially works, and then at some point (after a few days) I start experiencing spontaneous reboots. I thought perhaps it was an issue with xposed... so I tried doing this again but removed xposed from my phone prior to upgrading and re-rooting... no real change.

I tried doing a wipe/clean install and then restoring applications & data via TiBu... still have the reboots

I've never had this particular kind of issue before... I expected that a clean install and restoring some key applications via TiBu wouldn't have this issue...

I'm game to try another clean install without restoring anything via Tibu if that would really help...

Is there an on-phone logcat tool that will automatically store logs to my sdcard?

Any other idea's about what might be going on?
 
scifan
Old
(Last edited by scifan; 26th August 2014 at 04:43 AM.)
#2  
scifan's Avatar
Senior Member - OP
Thanks Meter 173
Posts: 982
Join Date: Dec 2008
Hmmm...

Zero responses, but several views.

Figured out (after looking elsewhere) that I could pull a last_kmsg among others...

Logcat
dmesg
last_kmsg

Can anyone give me some idea's about what's causing my phone to restart?

Just remembered in an attempt to get a different result, I'd actually flashed Gustafo's kernel... hmmm... wonder if I'd get the same results on the stock kernel...
 
scifan
Old
#3  
scifan's Avatar
Senior Member - OP
Thanks Meter 173
Posts: 982
Join Date: Dec 2008
Seems like after a clean install, it's working fine - I'm suspecting this might be some sort of issue with Xposed....

we'll see if it re-manifests...
 
hasei
Old
#4  
Senior Member
Thanks Meter 27
Posts: 152
Join Date: Sep 2009
Location: Erlanger
I just had the same issue fixed. I've had a constant reboot approximately 30 times a day.
I wiped everything including internal SD card, and flashed the 4.4.2 firmware. I was suspecting the Xposed as well but I installed for the heck of it 5 hours after the flesh installation of firmware. I only needed the wakelock terminator for Xposed to prevent battery drain.

After 48 hours even with Xposed, there has been no single reboot so far.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes