Post Reply

[Q] Help...Xperia ZR not powering on.

OP anthonythangaraj

10th July 2014, 03:10 AM   |  #1  
OP Senior Member
Flag Chennai
Thanks Meter: 106
 
177 posts
Join Date:Joined: May 2012
More
I need to confirm before submitting to Sony Service center.

Day before yesterday, I check my phone in morning, It was powered off. I connected the charger & My Phone is not powering on. Not even the LED is lighting up. I let the phone over the charger throughout the night but still no response. Unable to connect the PC in Flashmode / Fastboot mode.

Just noticed that, if I connect the phone to the charger without battery the LED is lighting up. If I connect the battery to the phone the LED powers off. Is it normal in our Xperia ZR, that the LED will light up if connected to charger without battery. Or My Battery / Phone is dead ?

I am in Locked Bootloader

Any suggestion would be helpful. I am asking It because I have rooted my mobile. I am trying to flash clean stock firmware before submitting to Service center.
10th July 2014, 10:10 AM   |  #2  
SirVer's Avatar
Junior Member
Thanks Meter: 10
 
26 posts
Join Date:Joined: Jul 2014
Did you recently flash a custom ROM? If so, did it boot before this issue? When you press and hold the power button, does the phone vibrate? How did you try to booting into flashmode and fastboot? As a reminder, for flashmode, press and hold the down volume key and plug in the cable, for fastboot press and hold up volume key. Try both of these while connected to your computer with Flashtool open, and check if you've succeeded. If yes, go ahead and flash your stock ROM, problem solved.
If you didn't recently flash a ROM, or none of the steps detailed above are working, it is probably a battery issue, or a kernel issue (some custom kernels have a bug which allows the battery to completely drain, making it unable to charge again). Try buying another battery and check if it works.
After all this, if you still cannot flash the stock, your only option is Sony Service, and even they may not be able to do anything. Plus, if they get it working again, you may not be able to claim warranty if you're on a custom ROM, though you might get lucky, since your bootloader is still locked.

Hope this helps.
The Following User Says Thank You to SirVer For This Useful Post: [ View ]
10th July 2014, 03:19 PM   |  #3  
OP Senior Member
Flag Chennai
Thanks Meter: 106
 
177 posts
Join Date:Joined: May 2012
More
Quote:
Originally Posted by SirVer

Did you recently flash a custom ROM? If so, did it boot before this issue? When you press and hold the power button, does the phone vibrate? How did you try to booting into flashmode and fastboot? As a reminder, for flashmode, press and hold the down volume key and plug in the cable, for fastboot press and hold up volume key. Try both of these while connected to your computer with Flashtool open, and check if you've succeeded. If yes, go ahead and flash your stock ROM, problem solved.
If you didn't recently flash a ROM, or none of the steps detailed above are working, it is probably a battery issue, or a kernel issue (some custom kernels have a bug which allows the battery to completely drain, making it unable to charge again). Try buying another battery and check if it works.
After all this, if you still cannot flash the stock, your only option is Sony Service, and even they may not be able to do anything. Plus, if they get it working again, you may not be able to claim warranty if you're on a custom ROM, though you might get lucky, since your bootloader is still locked.

Hope this helps.

I just rooted & on full stock rom. It was working fine all day. Nothing major is done on my phone. No vibrate while pressing power button.

I tried connecting flashmode & fastboot mode by pressing up arrow(and down arrow) while connecting to PC. Device is not detected in Device manager as well as in flashtools.

Just now only I returned home after submitting mobile to service center.
10th July 2014, 03:56 PM   |  #4  
SirVer's Avatar
Junior Member
Thanks Meter: 10
 
26 posts
Join Date:Joined: Jul 2014
Quote:
Originally Posted by anthonythangaraj

I just rooted & on full stock rom. It was working fine all day. Nothing major is done on my phone. No vibrate while pressing power button.

I tried connecting flashmode & fastboot mode by pressing up arrow(and down arrow) while connecting to PC. Device is not detected in Device manager as well as in flashtools.

Just now only I returned home after submitting mobile to service center.

Then it was probably a battery defect. If all you did is root, then you have a reasonable chance of getting it replaced under warranty, mainly depending on the mood of the service inspector.
The Following User Says Thank You to SirVer For This Useful Post: [ View ]
Post Reply Subscribe to Thread

Tags
not powering on, xperia zr
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes