FORUMS

Huawei To Sell Honor Smartphones Via Indian Retail Outlets

World’s fourth largest smartphone maker Huawei plans to now sell its … more

Sunday Debate: Are Smaller Bezels Better or Worth It?

Bezels have been getting smaller and smaller as the years go by, and while devices … more

LG G4 First Impressions and Unboxing – XDA TV

The latest in LG’s signature line of “G phones” has been released. … more

Galaxy S6 Weekly Shooting Challenge

Over in our forums this weekend, XDA Forum member DevonSloan has started a thread for talented … more
Post Reply Subscribe to Thread Email Thread

How can I reduce msm_hsic_host wakelock

20th August 2014, 05:03 PM |#1  
OP Junior Member
Thanks Meter: 0
 
More
It drains my battery.I know it cannot be eliminated,but how to do reduce it to a acceptable amount.Thanks.

Tapatalked from Xperia ZR
 
 
20th August 2014, 08:49 PM |#2  
Senior Member
Thanks Meter: 961
 
More
There is no "acceptable amount". I suggest to leave it, if you like your phone connected, and look for the real reasons for draining your battery.
22nd August 2014, 05:37 AM |#3  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Jack_R1

There is no "acceptable amount". I suggest to leave it, if you like your phone connected, and look for the real reasons for draining your battery.

But it's waking my phone 30percent of the time. Can't it be solved?

Tapatalked from Xperia ZR
22nd August 2014, 06:21 AM |#4  
Senior Member
Thanks Meter: 961
 
More
Well, yes. Turn on Flight mode, it should be solved But if you want your phone to have cellular connection - then just leave it be and check for the reasons instead.
As I wrote somewhere before, this phone has amazing battery life, if you have something else - make sure you have an original battery and from that point check your apps and make sure your cellular reception is acceptable. Leave the OS alone, it does a good job.
22nd August 2014, 03:58 PM |#5  
OP Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by Jack_R1

Well, yes. Turn on Flight mode, it should be solved But if you want your phone to have cellular connection - then just leave it be and check for the reasons instead.
As I wrote somewhere before, this phone has amazing battery life, if you have something else - make sure you have an original battery and from that point check your apps and make sure your cellular reception is acceptable. Leave the OS alone, it does a good job.

Thanks for your advice.[emoji1] And how to find out apps which triggered cellular reception? Is betterbatterystats ok?

Tapatalked from Xperia ZR
4th September 2014, 05:59 PM |#6  
Tommylee567's Avatar
Senior Member
Flag Bangalore
Thanks Meter: 40
 
More
Quote:
Originally Posted by Jack_R1

Well, yes. Turn on Flight mode, it should be solved But if you want your phone to have cellular connection - then just leave it be and check for the reasons instead.
As I wrote somewhere before, this phone has amazing battery life, if you have something else - make sure you have an original battery and from that point check your apps and make sure your cellular reception is acceptable. Leave the OS alone, it does a good job.

I noticed the same thing, will it change the battery life if we change the Baseband? Have any ideas?
5th September 2014, 06:21 AM |#7  
Junior Member
Thanks Meter: 2
 
More
The battery drain is propably caused by a service called fast dormancy. When The service is active while your network provider does not support the service, it causes a lot of wakelocks.
On my old xperia Ray the service can be disabled by editing the build.prop file. Somewhere on xda I have read that you can make a blacklist of providers witch don't use the service.

Sent from my C5503 using XDA Free mobile app

Here is the link of the xda topic: http://forum.xda-developers.com/show....php?t=2382680
Last edited by vanbroekhoven.wim; 5th September 2014 at 06:34 PM. Reason: link added
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes